%global _empty_manifest_terminate_build 0
Name: python-glfw
Version: 2.5.9
Release: 1
Summary: A ctypes-based wrapper for GLFW3.
License: MIT
URL: https://github.com/FlorianRhiem/pyGLFW
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a7/e1/06f03dfc2e8c8af9a722d0add2c99a16e88714b98df866303944731b33c5/glfw-2.5.9.tar.gz
Requires: python3-glfw-preview
%description
This module provides Python bindings for `GLFW `__
(on GitHub: `glfw/glfw `__). It is a
``ctypes`` wrapper which keeps very close to the original GLFW API,
except for:
- function names use the pythonic ``words_with_underscores`` notation
instead of ``camelCase``
- ``GLFW_`` and ``glfw`` prefixes have been removed, as their function
is replaced by the module namespace
(you can use ``from glfw.GLFW import *`` if you prefer the naming
convention used by the GLFW C API)
- structs have been replaced with Python sequences and namedtuples
- functions like ``glfwGetMonitors`` return a list instead of a pointer
and an object count
- Gamma ramps use floats between 0.0 and 1.0 instead of unsigned shorts
(use ``glfw.NORMALIZE_GAMMA_RAMPS=False`` to disable this)
- GLFW errors are reported as ``glfw.GLFWError`` warnings if no error
callback is set (use ``glfw.ERROR_REPORTING=False`` to disable this,
set it to 'warn' instead to issue warnings, set it to 'log' to log it
using the 'glfw' logger or set it to a dict to define the behavior for
specific error codes)
- instead of a sequence for ``GLFWimage`` structs, PIL/pillow ``Image``
objects can be used
%package -n python3-glfw
Summary: A ctypes-based wrapper for GLFW3.
Provides: python-glfw
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-glfw
This module provides Python bindings for `GLFW `__
(on GitHub: `glfw/glfw `__). It is a
``ctypes`` wrapper which keeps very close to the original GLFW API,
except for:
- function names use the pythonic ``words_with_underscores`` notation
instead of ``camelCase``
- ``GLFW_`` and ``glfw`` prefixes have been removed, as their function
is replaced by the module namespace
(you can use ``from glfw.GLFW import *`` if you prefer the naming
convention used by the GLFW C API)
- structs have been replaced with Python sequences and namedtuples
- functions like ``glfwGetMonitors`` return a list instead of a pointer
and an object count
- Gamma ramps use floats between 0.0 and 1.0 instead of unsigned shorts
(use ``glfw.NORMALIZE_GAMMA_RAMPS=False`` to disable this)
- GLFW errors are reported as ``glfw.GLFWError`` warnings if no error
callback is set (use ``glfw.ERROR_REPORTING=False`` to disable this,
set it to 'warn' instead to issue warnings, set it to 'log' to log it
using the 'glfw' logger or set it to a dict to define the behavior for
specific error codes)
- instead of a sequence for ``GLFWimage`` structs, PIL/pillow ``Image``
objects can be used
%package help
Summary: Development documents and examples for glfw
Provides: python3-glfw-doc
%description help
This module provides Python bindings for `GLFW `__
(on GitHub: `glfw/glfw `__). It is a
``ctypes`` wrapper which keeps very close to the original GLFW API,
except for:
- function names use the pythonic ``words_with_underscores`` notation
instead of ``camelCase``
- ``GLFW_`` and ``glfw`` prefixes have been removed, as their function
is replaced by the module namespace
(you can use ``from glfw.GLFW import *`` if you prefer the naming
convention used by the GLFW C API)
- structs have been replaced with Python sequences and namedtuples
- functions like ``glfwGetMonitors`` return a list instead of a pointer
and an object count
- Gamma ramps use floats between 0.0 and 1.0 instead of unsigned shorts
(use ``glfw.NORMALIZE_GAMMA_RAMPS=False`` to disable this)
- GLFW errors are reported as ``glfw.GLFWError`` warnings if no error
callback is set (use ``glfw.ERROR_REPORTING=False`` to disable this,
set it to 'warn' instead to issue warnings, set it to 'log' to log it
using the 'glfw' logger or set it to a dict to define the behavior for
specific error codes)
- instead of a sequence for ``GLFWimage`` structs, PIL/pillow ``Image``
objects can be used
%prep
%autosetup -n glfw-2.5.9
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-glfw -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 2.5.9-1
- Package Spec generated