%global _empty_manifest_terminate_build 0
Name: python-Delorean
Version: 1.0.0
Release: 1
Summary: library for manipulating datetimes with ease and clarity
License: MIT license
URL: https://github.com/myusuf3/delorean
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/76/40/5e8d179a0311236b2e83aa1c80b0b363700035ad6639858c75ef5be975e6/Delorean-1.0.0.tar.gz
BuildArch: noarch
%description
`Delorean` is a library for clearing up the inconvenient truths that arise dealing with datetimes in Python. Understanding that timing is a delicate enough of a problem `delorean` hopes to provide a cleaner less troublesome solution to shifting, manipulating, and generating `datetimes`.
Delorean stands on the shoulders of giants `pytz `_ and `dateutil `_
`Delorean` will provide natural language improvements for manipulating time, as well as datetime abstractions for ease of use. The overall goal is to improve datetime manipulations, with a little bit of software and philosophy.
Pretty much make you a badass time traveller.
Getting Started
^^^^^^^^^^^^^^^
Here is the world without a flux capacitor at your side:
from datetime import datetime
import pytz
est = pytz.timezone('US/Eastern')
d = datetime.now(pytz.utc)
d = est.normalize(d.astimezone(est))
return d
Now lets warm up the `delorean`:
from delorean import Delorean
d = Delorean()
d = d.shift('US/Eastern')
return d
Look at you looking all fly. This was just a test drive: check out out what else
`delorean` can help with in the `documentation `_.
%package -n python3-Delorean
Summary: library for manipulating datetimes with ease and clarity
Provides: python-Delorean
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Delorean
`Delorean` is a library for clearing up the inconvenient truths that arise dealing with datetimes in Python. Understanding that timing is a delicate enough of a problem `delorean` hopes to provide a cleaner less troublesome solution to shifting, manipulating, and generating `datetimes`.
Delorean stands on the shoulders of giants `pytz `_ and `dateutil `_
`Delorean` will provide natural language improvements for manipulating time, as well as datetime abstractions for ease of use. The overall goal is to improve datetime manipulations, with a little bit of software and philosophy.
Pretty much make you a badass time traveller.
Getting Started
^^^^^^^^^^^^^^^
Here is the world without a flux capacitor at your side:
from datetime import datetime
import pytz
est = pytz.timezone('US/Eastern')
d = datetime.now(pytz.utc)
d = est.normalize(d.astimezone(est))
return d
Now lets warm up the `delorean`:
from delorean import Delorean
d = Delorean()
d = d.shift('US/Eastern')
return d
Look at you looking all fly. This was just a test drive: check out out what else
`delorean` can help with in the `documentation `_.
%package help
Summary: Development documents and examples for Delorean
Provides: python3-Delorean-doc
%description help
`Delorean` is a library for clearing up the inconvenient truths that arise dealing with datetimes in Python. Understanding that timing is a delicate enough of a problem `delorean` hopes to provide a cleaner less troublesome solution to shifting, manipulating, and generating `datetimes`.
Delorean stands on the shoulders of giants `pytz `_ and `dateutil `_
`Delorean` will provide natural language improvements for manipulating time, as well as datetime abstractions for ease of use. The overall goal is to improve datetime manipulations, with a little bit of software and philosophy.
Pretty much make you a badass time traveller.
Getting Started
^^^^^^^^^^^^^^^
Here is the world without a flux capacitor at your side:
from datetime import datetime
import pytz
est = pytz.timezone('US/Eastern')
d = datetime.now(pytz.utc)
d = est.normalize(d.astimezone(est))
return d
Now lets warm up the `delorean`:
from delorean import Delorean
d = Delorean()
d = d.shift('US/Eastern')
return d
Look at you looking all fly. This was just a test drive: check out out what else
`delorean` can help with in the `documentation `_.
%prep
%autosetup -n Delorean-1.0.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Delorean -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 1.0.0-1
- Package Spec generated