%global _empty_manifest_terminate_build 0
Name: python-url64
Version: 0.1.0
Release: 1
Summary: url64 decode/encode for python
License: Apache-2.0
URL: https://github.com/puria/url64
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c0/4f/01a4f1f8e59a559fdc4ff9884976cad3697e0d98bb988865bc7f55f1d394/url64-0.1.0.tar.gz
BuildArch: noarch
Requires: python3-pytest
Requires: python3-pytest-cov
%description
url64
๐ base64url decode/encode for python
`url64` is the common name for the `base64url` described in the
[RFC4648 ยง5](https://tools.ietf.org/html/rfc4648#section-5).
Since the original base64 alphabet contains invalid characters for URLs a safe
base64 for url is suggested, replacing the 62nd (plus sign +) and 63rd
(slash /) with new chars respectively the minus `-` and underscore `_` and
removing also the padding that is represented with the equal sign `=`.
This a handy small utility to encode/decode strings in url64 with python3
very useful for JWT
๐ฉ Table of Contents (click to expand)
* [Install](#-install)
* [Quick start](#-quick-start)
* [Links](#-links)
* [Contributing](#-contributing)
* [License](#-license)
***
## ๐พ Install
```pip install url64```
***
## ๐ฎ Quick start
### encode
```python
import url64
encoded = url64.encode('Hello world!')
print(encoded) # SGVsbG8gd29ybGQh
dict_exncode = url64.encode(dict(alg="HS256", typ="JWT"))
print(dict_exncode) # eyJhbGciOiAiSFMyNTYiLCAidHlwIjogIkpXVCJ9
```
### decode
```python
import url64
decoded = url64.decode('SGVsbG8gd29ybGQh')
print(decoded) # Hello world!
dict_decoded = url64.decode('eyJhbGciOiAiSFMyNTYiLCAidHlwIjogIkpXVCJ9')
print(dict_decoded) # {"alg": "HS256", "typ": "JWT"}
```
***
## ๐ Links
https://tools.ietf.org/html/rfc4648#section-5
https://en.wikipedia.org/wiki/Base64#URL_applications
https://base64.guru/standards/base64url
***
## ๐ค Contributing
1. ๐ [FORK IT](../../fork)
2. Create your feature branch `git checkout -b feature/branch`
3. Commit your changes `git commit -am 'Add some fooBar'`
4. Push to the branch `git push origin feature/branch`
5. Create a new Pull Request
6. ๐ Thank you
***
## ๐ผ License
Copyright (c) 2019 Puria Nafisi Azizi
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at
http://www.apache.org/licenses/LICENSE-2.0
Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.
%package -n python3-url64
Summary: url64 decode/encode for python
Provides: python-url64
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-url64
url64
๐ base64url decode/encode for python
`url64` is the common name for the `base64url` described in the
[RFC4648 ยง5](https://tools.ietf.org/html/rfc4648#section-5).
Since the original base64 alphabet contains invalid characters for URLs a safe
base64 for url is suggested, replacing the 62nd (plus sign +) and 63rd
(slash /) with new chars respectively the minus `-` and underscore `_` and
removing also the padding that is represented with the equal sign `=`.
This a handy small utility to encode/decode strings in url64 with python3
very useful for JWT
๐ฉ Table of Contents (click to expand)
* [Install](#-install)
* [Quick start](#-quick-start)
* [Links](#-links)
* [Contributing](#-contributing)
* [License](#-license)
***
## ๐พ Install
```pip install url64```
***
## ๐ฎ Quick start
### encode
```python
import url64
encoded = url64.encode('Hello world!')
print(encoded) # SGVsbG8gd29ybGQh
dict_exncode = url64.encode(dict(alg="HS256", typ="JWT"))
print(dict_exncode) # eyJhbGciOiAiSFMyNTYiLCAidHlwIjogIkpXVCJ9
```
### decode
```python
import url64
decoded = url64.decode('SGVsbG8gd29ybGQh')
print(decoded) # Hello world!
dict_decoded = url64.decode('eyJhbGciOiAiSFMyNTYiLCAidHlwIjogIkpXVCJ9')
print(dict_decoded) # {"alg": "HS256", "typ": "JWT"}
```
***
## ๐ Links
https://tools.ietf.org/html/rfc4648#section-5
https://en.wikipedia.org/wiki/Base64#URL_applications
https://base64.guru/standards/base64url
***
## ๐ค Contributing
1. ๐ [FORK IT](../../fork)
2. Create your feature branch `git checkout -b feature/branch`
3. Commit your changes `git commit -am 'Add some fooBar'`
4. Push to the branch `git push origin feature/branch`
5. Create a new Pull Request
6. ๐ Thank you
***
## ๐ผ License
Copyright (c) 2019 Puria Nafisi Azizi
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at
http://www.apache.org/licenses/LICENSE-2.0
Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.
%package help
Summary: Development documents and examples for url64
Provides: python3-url64-doc
%description help
url64
๐ base64url decode/encode for python
`url64` is the common name for the `base64url` described in the
[RFC4648 ยง5](https://tools.ietf.org/html/rfc4648#section-5).
Since the original base64 alphabet contains invalid characters for URLs a safe
base64 for url is suggested, replacing the 62nd (plus sign +) and 63rd
(slash /) with new chars respectively the minus `-` and underscore `_` and
removing also the padding that is represented with the equal sign `=`.
This a handy small utility to encode/decode strings in url64 with python3
very useful for JWT
๐ฉ Table of Contents (click to expand)
* [Install](#-install)
* [Quick start](#-quick-start)
* [Links](#-links)
* [Contributing](#-contributing)
* [License](#-license)
***
## ๐พ Install
```pip install url64```
***
## ๐ฎ Quick start
### encode
```python
import url64
encoded = url64.encode('Hello world!')
print(encoded) # SGVsbG8gd29ybGQh
dict_exncode = url64.encode(dict(alg="HS256", typ="JWT"))
print(dict_exncode) # eyJhbGciOiAiSFMyNTYiLCAidHlwIjogIkpXVCJ9
```
### decode
```python
import url64
decoded = url64.decode('SGVsbG8gd29ybGQh')
print(decoded) # Hello world!
dict_decoded = url64.decode('eyJhbGciOiAiSFMyNTYiLCAidHlwIjogIkpXVCJ9')
print(dict_decoded) # {"alg": "HS256", "typ": "JWT"}
```
***
## ๐ Links
https://tools.ietf.org/html/rfc4648#section-5
https://en.wikipedia.org/wiki/Base64#URL_applications
https://base64.guru/standards/base64url
***
## ๐ค Contributing
1. ๐ [FORK IT](../../fork)
2. Create your feature branch `git checkout -b feature/branch`
3. Commit your changes `git commit -am 'Add some fooBar'`
4. Push to the branch `git push origin feature/branch`
5. Create a new Pull Request
6. ๐ Thank you
***
## ๐ผ License
Copyright (c) 2019 Puria Nafisi Azizi
Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at
http://www.apache.org/licenses/LICENSE-2.0
Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.
%prep
%autosetup -n url64-0.1.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-url64 -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 0.1.0-1
- Package Spec generated