%global _empty_manifest_terminate_build 0
Name:		python-condor-git-config
Version:	0.1.5
Release:	1
Summary:	dynamically configure an HTCondor node from a git repository
License:	MIT License
URL:		https://pypi.org/project/condor-git-config/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/4b/9b/022603f7afbd23149eca86072531b9b0f4bf0dbcf23d44e920ec2bd675f9/condor_git_config-0.1.5.tar.gz
BuildArch:	noarch

Requires:	python3-filelock
Requires:	python3-pytest
Requires:	python3-flake8
Requires:	python3-flake8-bugbear
Requires:	python3-black
Requires:	python3-mypy
Requires:	python3-types-filelock

%description
Installation provides the ``condor-git-config`` executable.
All other dependencies are installed automatically.
Stable release version
    pip3 install condor_git_config
Current development version
    pip3 install git+https://github.com/MatterMiners/condor-git-config.git
We recommend to install the hook to a
`virtual environment <https://docs.python.org/3/library/venv.html>`_.
However, the hook is simple enough to not disturb global environments.

%package -n python3-condor-git-config
Summary:	dynamically configure an HTCondor node from a git repository
Provides:	python-condor-git-config
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-condor-git-config
Installation provides the ``condor-git-config`` executable.
All other dependencies are installed automatically.
Stable release version
    pip3 install condor_git_config
Current development version
    pip3 install git+https://github.com/MatterMiners/condor-git-config.git
We recommend to install the hook to a
`virtual environment <https://docs.python.org/3/library/venv.html>`_.
However, the hook is simple enough to not disturb global environments.

%package help
Summary:	Development documents and examples for condor-git-config
Provides:	python3-condor-git-config-doc
%description help
Installation provides the ``condor-git-config`` executable.
All other dependencies are installed automatically.
Stable release version
    pip3 install condor_git_config
Current development version
    pip3 install git+https://github.com/MatterMiners/condor-git-config.git
We recommend to install the hook to a
`virtual environment <https://docs.python.org/3/library/venv.html>`_.
However, the hook is simple enough to not disturb global environments.

%prep
%autosetup -n condor-git-config-0.1.5

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-condor-git-config -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.5-1
- Package Spec generated