%global _empty_manifest_terminate_build 0
Name:		python-edx-submissions
Version:	3.5.4
Release:	1
Summary:	An API for creating submissions and scores.
License:	AGPL
URL:		http://github.com/edx/edx-submissions.git
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/6f/78/c5e4b4ff9d594e3872c616c4bd72f08a9554e86c4a6f57abeef31fc12333/edx-submissions-3.5.4.tar.gz
BuildArch:	noarch

Requires:	python3-django-model-utils
Requires:	python3-Django
Requires:	python3-djangorestframework
Requires:	python3-jsonfield
Requires:	python3-pytz

%description
An API for creating and scoring submissions for the Open edX platform


%package -n python3-edx-submissions
Summary:	An API for creating submissions and scores.
Provides:	python-edx-submissions
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-edx-submissions
An API for creating and scoring submissions for the Open edX platform


%package help
Summary:	Development documents and examples for edx-submissions
Provides:	python3-edx-submissions-doc
%description help
An API for creating and scoring submissions for the Open edX platform


%prep
%autosetup -n edx-submissions-3.5.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-edx-submissions -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 3.5.4-1
- Package Spec generated