%global _empty_manifest_terminate_build 0
Name:		python-edx-completion
Version:	4.2.0
Release:	1
Summary:	A library for tracking completion of blocks by learners in edX courses.
License:	AGPL 3.0
URL:		https://github.com/edx/completion
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/8f/0c/82532c218990b6e0dc00d81c6c1a64d2fa11dd25f02f6ac726b268d43418/edx-completion-4.2.0.tar.gz
BuildArch:	noarch

Requires:	python3-Django
Requires:	python3-XBlock
Requires:	python3-django-model-utils
Requires:	python3-djangorestframework
Requires:	python3-edx-drf-extensions
Requires:	python3-edx-opaque-keys
Requires:	python3-edx-toggles
Requires:	python3-pytz

%description
|pypi-badge| |CI| |codecov-badge| |doc-badge| |pyversions-badge|
|license-badge|
A library for tracking completion of blocks by learners in edX courses.
Overview
________
This repository provides a Django model `BlockCompletion` that is intended to be plugged into ``edx-platform``.  It
provides various handlers and services for the recording of completion data.  It also provides a DRF API for submitting
completion data in batches.

%package -n python3-edx-completion
Summary:	A library for tracking completion of blocks by learners in edX courses.
Provides:	python-edx-completion
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-edx-completion
|pypi-badge| |CI| |codecov-badge| |doc-badge| |pyversions-badge|
|license-badge|
A library for tracking completion of blocks by learners in edX courses.
Overview
________
This repository provides a Django model `BlockCompletion` that is intended to be plugged into ``edx-platform``.  It
provides various handlers and services for the recording of completion data.  It also provides a DRF API for submitting
completion data in batches.

%package help
Summary:	Development documents and examples for edx-completion
Provides:	python3-edx-completion-doc
%description help
|pypi-badge| |CI| |codecov-badge| |doc-badge| |pyversions-badge|
|license-badge|
A library for tracking completion of blocks by learners in edX courses.
Overview
________
This repository provides a Django model `BlockCompletion` that is intended to be plugged into ``edx-platform``.  It
provides various handlers and services for the recording of completion data.  It also provides a DRF API for submitting
completion data in batches.

%prep
%autosetup -n edx-completion-4.2.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-edx-completion -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 4.2.0-1
- Package Spec generated