%global _empty_manifest_terminate_build 0
Name: python-json-lines
Version: 0.5.0
Release: 1
Summary: Reading JSON lines (jl) files, recover broken files
License: MIT
URL: https://github.com/TeamHG-Memex/json-lines
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ad/fc/53be3bd1997800228c3dfc3b5b72b758263f8e08aa12429c1f72030688b9/json-lines-0.5.0.tar.gz
BuildArch: noarch
%description
This is a tiny library for reading JSON lines (.jl) files,
including gzipped and broken files.
`JSON lines `_ is a text file format
where each line is a single json encoded item.
%package -n python3-json-lines
Summary: Reading JSON lines (jl) files, recover broken files
Provides: python-json-lines
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-json-lines
This is a tiny library for reading JSON lines (.jl) files,
including gzipped and broken files.
`JSON lines `_ is a text file format
where each line is a single json encoded item.
%package help
Summary: Development documents and examples for json-lines
Provides: python3-json-lines-doc
%description help
This is a tiny library for reading JSON lines (.jl) files,
including gzipped and broken files.
`JSON lines `_ is a text file format
where each line is a single json encoded item.
%prep
%autosetup -n json-lines-0.5.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-json-lines -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 0.5.0-1
- Package Spec generated