%global _empty_manifest_terminate_build 0
Name: python-pytorch-crf
Version: 0.7.2
Release: 1
Summary: Conditional random field in PyTorch
License: MIT
URL: https://github.com/kmkurn/pytorch-crf
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/e2/8c/aa58618f8c9cc8b2ddd22d4e700028101ec331d4c65c8cca663844a9dc24/pytorch-crf-0.7.2.tar.gz
BuildArch: noarch
%description
Conditional random field in `PyTorch `_.
This package provides an implementation of `conditional random field
`_ (CRF) in PyTorch.
This implementation borrows mostly from `AllenNLP CRF module
`_ with some modifications.
%package -n python3-pytorch-crf
Summary: Conditional random field in PyTorch
Provides: python-pytorch-crf
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pytorch-crf
Conditional random field in `PyTorch `_.
This package provides an implementation of `conditional random field
`_ (CRF) in PyTorch.
This implementation borrows mostly from `AllenNLP CRF module
`_ with some modifications.
%package help
Summary: Development documents and examples for pytorch-crf
Provides: python3-pytorch-crf-doc
%description help
Conditional random field in `PyTorch `_.
This package provides an implementation of `conditional random field
`_ (CRF) in PyTorch.
This implementation borrows mostly from `AllenNLP CRF module
`_ with some modifications.
%prep
%autosetup -n pytorch-crf-0.7.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pytorch-crf -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 0.7.2-1
- Package Spec generated