%global _empty_manifest_terminate_build 0
Name:		python-discord-py-interactions
Version:	5.1.0
Release:	1
Summary:	Easy, simple, scalable and modular: a Python API wrapper for interactions.
License:	MIT License
URL:		https://github.com/interactions-py/interactions.py
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ec/c5/57b28e50b8bde797fd38af0c65d3cfd6b00d667a3ddb741bdeb7aee985ea/discord-py-interactions-5.1.0.tar.gz
BuildArch:	noarch

Requires:	python3-aiohttp
Requires:	python3-attrs
Requires:	python3-discord-typings
Requires:	python3-emoji
Requires:	python3-tomli
Requires:	python3-PyNaCl
Requires:	python3-aiodns
Requires:	python3-orjson
Requires:	python3-Brotli
Requires:	python3-faust-cchardet
Requires:	python3-sentry-sdk
Requires:	python3-jurigged
Requires:	python3-aioconsole
Requires:	python3-uvloop
Requires:	python3-aioconsole
Requires:	python3-pytest
Requires:	python3-pytest-recording
Requires:	python3-pytest-asyncio
Requires:	python3-pytest-cov
Requires:	python3-dotenv
Requires:	python3-typeguard
Requires:	python3-PyNaCl
Requires:	python3-aiodns
Requires:	python3-orjson
Requires:	python3-Brotli
Requires:	python3-faust-cchardet
Requires:	python3-sentry-sdk
Requires:	python3-jurigged
Requires:	python3-aioconsole
Requires:	python3-mkdocs-autorefs
Requires:	python3-mkdocs-awesome-pages-plugin
Requires:	python3-mkdocs-material
Requires:	python3-mkdocstrings-python
Requires:	python3-mkdocs-minify-plugin
Requires:	python3-mkdocs-git-committers-plugin-2
Requires:	python3-mkdocs-git-revision-date-localized-plugin
Requires:	python3-pre-commit
Requires:	python3-uvloop
Requires:	python3-PyNaCl
Requires:	python3-aiodns
Requires:	python3-orjson
Requires:	python3-Brotli
Requires:	python3-faust-cchardet
Requires:	python3-sentry-sdk
Requires:	python3-jurigged
Requires:	python3-aioconsole
Requires:	python3-mkdocs-autorefs
Requires:	python3-mkdocs-awesome-pages-plugin
Requires:	python3-mkdocs-material
Requires:	python3-mkdocstrings-python
Requires:	python3-mkdocs-minify-plugin
Requires:	python3-mkdocs-git-committers-plugin-2
Requires:	python3-mkdocs-git-revision-date-localized-plugin
Requires:	python3-uvloop
Requires:	python3-jurigged
Requires:	python3-sentry-sdk
Requires:	python3-aiodns
Requires:	python3-orjson
Requires:	python3-Brotli
Requires:	python3-faust-cchardet
Requires:	python3-uvloop
Requires:	python3-pytest
Requires:	python3-pytest-recording
Requires:	python3-pytest-asyncio
Requires:	python3-pytest-cov
Requires:	python3-dotenv
Requires:	python3-typeguard
Requires:	python3-PyNaCl

%description
<div align="center">

   # Interactions.py
   <br>

   ![](https://img.shields.io/pypi/v/discord-py-interactions.svg?label=Version&logo=pypi)
   ![](https://img.shields.io/badge/Python-3.10+-1081c1?logo=python)
   [![](https://img.shields.io/pypi/dm/discord-py-slash-command.svg?logo=python&label=Downloads)](https://pypi.org/project/discord-py-interactions/)

   [![](https://img.shields.io/badge/Code%20Style-black-000000.svg)](https://github.com/psf/black)
   [![License](https://img.shields.io/badge/License-GPL-blue)](https://github.com/interactions-py/interactions.py/blob/stable/LICENSE)

   [![](https://img.shields.io/badge/Docs-latest-x?logo=readthedocs)](https://interactions-py.github.io/interactions.py/)
   [![](https://img.shields.io/badge/Guides-latest-x?logo=readthedocs)](https://interactions-py.github.io/interactions.py/Guides/01%20Getting%20Started)
   [![image](https://discord.com/api/guilds/789032594456576001/embed.png)](https://discord.gg/interactions)

</div>

## A Feature-rich Discord Bot Framework for Python

A highly extensible, easy to use, and feature complete framework for Discord.

`interactions.py` is the culmination of years of experience with Discord's APIs and bot development. This framework has been built from the ground up with community feedback and suggestions in mind. Our framework provides a modern and intuitive set of language bindings for easy interaction with Discord.

## Key Features
interactions.py offers a wide range of features for building Python-powered Discord bots and web applications alike:
- ✅ 100% coverage of the Discord API
- ✅ Dynamic cache with TTL support
- ✅ Modern and Pythonic API for easy interaction with Discord
- ✅ Proper rate-limit handling
- ✅ Feature parity with most other Discord API wrappers
- ✅ Fully automated command synchronisation

In addition to core functionality, `interactions.py` provides a range of optional extensions, allowing you to further customize your bot and add new features with ease.

## Extensibility

So the base library doesn't do what you want? No problem! With builtin extensions, you are able to extend the functionality of the library. And if none of those pique your interest, there are a myriad of other extension libraries available.

Just type `bot.load("extension")`

<details>
    <summary>Extensions</summary>

   ### Prefixed Commands

   Prefixed commands, message commands, or legacy commands.
   Whatever you want to call them, by default the `interactions.py` library will not handle these. But rest assured this extension will get you going

  - ✅ Automatic command registration
  - ✅ Annotation support

  ### Debug Extension

  A fully featured debug and utilities suite to help you get your bots made

  ### Jurigged

  A hot reloading extension allowing you to automagically update your bot without reboots

  ### Sentry

  Integrates Sentry.io error tracking into your bot with a single line

  ### Console

  Adds `aiomonitor` support with enables cli commands over a web interface

  ### Paginators

  Easily create multi-page embeds without having to implement the UX

</details>

## Where do I start?

Getting started with `interactions.py` is easy! Simply install it via `pip` and start building your Discord application in Python:

`pip install -U discord-py-interactions`
```python
import interactions

bot = interactions.Client()

@interactions.listen()
async def on_startup():
    print("Bot is ready!")

bot.start("token")
```

With `interactions.py`, you can quickly and easily build complex Discord applications with Python. Check out our [guides](https://interactions-py.github.io/interactions.py/Guides/01%20Getting%20Started) for more information. Or join our [discord](https://discord.gg/interactions).


%package -n python3-discord-py-interactions
Summary:	Easy, simple, scalable and modular: a Python API wrapper for interactions.
Provides:	python-discord-py-interactions
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-discord-py-interactions
<div align="center">

   # Interactions.py
   <br>

   ![](https://img.shields.io/pypi/v/discord-py-interactions.svg?label=Version&logo=pypi)
   ![](https://img.shields.io/badge/Python-3.10+-1081c1?logo=python)
   [![](https://img.shields.io/pypi/dm/discord-py-slash-command.svg?logo=python&label=Downloads)](https://pypi.org/project/discord-py-interactions/)

   [![](https://img.shields.io/badge/Code%20Style-black-000000.svg)](https://github.com/psf/black)
   [![License](https://img.shields.io/badge/License-GPL-blue)](https://github.com/interactions-py/interactions.py/blob/stable/LICENSE)

   [![](https://img.shields.io/badge/Docs-latest-x?logo=readthedocs)](https://interactions-py.github.io/interactions.py/)
   [![](https://img.shields.io/badge/Guides-latest-x?logo=readthedocs)](https://interactions-py.github.io/interactions.py/Guides/01%20Getting%20Started)
   [![image](https://discord.com/api/guilds/789032594456576001/embed.png)](https://discord.gg/interactions)

</div>

## A Feature-rich Discord Bot Framework for Python

A highly extensible, easy to use, and feature complete framework for Discord.

`interactions.py` is the culmination of years of experience with Discord's APIs and bot development. This framework has been built from the ground up with community feedback and suggestions in mind. Our framework provides a modern and intuitive set of language bindings for easy interaction with Discord.

## Key Features
interactions.py offers a wide range of features for building Python-powered Discord bots and web applications alike:
- ✅ 100% coverage of the Discord API
- ✅ Dynamic cache with TTL support
- ✅ Modern and Pythonic API for easy interaction with Discord
- ✅ Proper rate-limit handling
- ✅ Feature parity with most other Discord API wrappers
- ✅ Fully automated command synchronisation

In addition to core functionality, `interactions.py` provides a range of optional extensions, allowing you to further customize your bot and add new features with ease.

## Extensibility

So the base library doesn't do what you want? No problem! With builtin extensions, you are able to extend the functionality of the library. And if none of those pique your interest, there are a myriad of other extension libraries available.

Just type `bot.load("extension")`

<details>
    <summary>Extensions</summary>

   ### Prefixed Commands

   Prefixed commands, message commands, or legacy commands.
   Whatever you want to call them, by default the `interactions.py` library will not handle these. But rest assured this extension will get you going

  - ✅ Automatic command registration
  - ✅ Annotation support

  ### Debug Extension

  A fully featured debug and utilities suite to help you get your bots made

  ### Jurigged

  A hot reloading extension allowing you to automagically update your bot without reboots

  ### Sentry

  Integrates Sentry.io error tracking into your bot with a single line

  ### Console

  Adds `aiomonitor` support with enables cli commands over a web interface

  ### Paginators

  Easily create multi-page embeds without having to implement the UX

</details>

## Where do I start?

Getting started with `interactions.py` is easy! Simply install it via `pip` and start building your Discord application in Python:

`pip install -U discord-py-interactions`
```python
import interactions

bot = interactions.Client()

@interactions.listen()
async def on_startup():
    print("Bot is ready!")

bot.start("token")
```

With `interactions.py`, you can quickly and easily build complex Discord applications with Python. Check out our [guides](https://interactions-py.github.io/interactions.py/Guides/01%20Getting%20Started) for more information. Or join our [discord](https://discord.gg/interactions).


%package help
Summary:	Development documents and examples for discord-py-interactions
Provides:	python3-discord-py-interactions-doc
%description help
<div align="center">

   # Interactions.py
   <br>

   ![](https://img.shields.io/pypi/v/discord-py-interactions.svg?label=Version&logo=pypi)
   ![](https://img.shields.io/badge/Python-3.10+-1081c1?logo=python)
   [![](https://img.shields.io/pypi/dm/discord-py-slash-command.svg?logo=python&label=Downloads)](https://pypi.org/project/discord-py-interactions/)

   [![](https://img.shields.io/badge/Code%20Style-black-000000.svg)](https://github.com/psf/black)
   [![License](https://img.shields.io/badge/License-GPL-blue)](https://github.com/interactions-py/interactions.py/blob/stable/LICENSE)

   [![](https://img.shields.io/badge/Docs-latest-x?logo=readthedocs)](https://interactions-py.github.io/interactions.py/)
   [![](https://img.shields.io/badge/Guides-latest-x?logo=readthedocs)](https://interactions-py.github.io/interactions.py/Guides/01%20Getting%20Started)
   [![image](https://discord.com/api/guilds/789032594456576001/embed.png)](https://discord.gg/interactions)

</div>

## A Feature-rich Discord Bot Framework for Python

A highly extensible, easy to use, and feature complete framework for Discord.

`interactions.py` is the culmination of years of experience with Discord's APIs and bot development. This framework has been built from the ground up with community feedback and suggestions in mind. Our framework provides a modern and intuitive set of language bindings for easy interaction with Discord.

## Key Features
interactions.py offers a wide range of features for building Python-powered Discord bots and web applications alike:
- ✅ 100% coverage of the Discord API
- ✅ Dynamic cache with TTL support
- ✅ Modern and Pythonic API for easy interaction with Discord
- ✅ Proper rate-limit handling
- ✅ Feature parity with most other Discord API wrappers
- ✅ Fully automated command synchronisation

In addition to core functionality, `interactions.py` provides a range of optional extensions, allowing you to further customize your bot and add new features with ease.

## Extensibility

So the base library doesn't do what you want? No problem! With builtin extensions, you are able to extend the functionality of the library. And if none of those pique your interest, there are a myriad of other extension libraries available.

Just type `bot.load("extension")`

<details>
    <summary>Extensions</summary>

   ### Prefixed Commands

   Prefixed commands, message commands, or legacy commands.
   Whatever you want to call them, by default the `interactions.py` library will not handle these. But rest assured this extension will get you going

  - ✅ Automatic command registration
  - ✅ Annotation support

  ### Debug Extension

  A fully featured debug and utilities suite to help you get your bots made

  ### Jurigged

  A hot reloading extension allowing you to automagically update your bot without reboots

  ### Sentry

  Integrates Sentry.io error tracking into your bot with a single line

  ### Console

  Adds `aiomonitor` support with enables cli commands over a web interface

  ### Paginators

  Easily create multi-page embeds without having to implement the UX

</details>

## Where do I start?

Getting started with `interactions.py` is easy! Simply install it via `pip` and start building your Discord application in Python:

`pip install -U discord-py-interactions`
```python
import interactions

bot = interactions.Client()

@interactions.listen()
async def on_startup():
    print("Bot is ready!")

bot.start("token")
```

With `interactions.py`, you can quickly and easily build complex Discord applications with Python. Check out our [guides](https://interactions-py.github.io/interactions.py/Guides/01%20Getting%20Started) for more information. Or join our [discord](https://discord.gg/interactions).


%prep
%autosetup -n discord-py-interactions-5.1.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-discord-py-interactions -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 5.1.0-1
- Package Spec generated