%global _empty_manifest_terminate_build 0
Name: python-hive-metastore-client
Version: 1.0.9
Release: 1
Summary: A client for connecting and running DDLs on Hive Metastore with Thrift protocol
License: Copyright
URL: https://github.com/quintoandar/hive-metastore-client
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/07/ed/f15d3f3e4f3676368993beedde77f499456a64debc7fd244e9278f5b9631/hive_metastore_client-1.0.9.tar.gz
BuildArch: noarch
Requires: python3-thrift
%description
## Hive Metastore Client
_A client for connecting and running DDLs on [Hive](https://hive.apache.org/) Metastore using [Thrift](https://thrift.apache.org/) protocol._
[![Release](https://img.shields.io/github/v/release/quintoandar/hive-metastore-client)]((https://pypi.org/project/hive-metastore-client/))
![Python Version](https://img.shields.io/badge/python-3.7%20%7C%203.8-brightgreen.svg)
[![License](https://img.shields.io/badge/License-Apache%202.0-blue.svg)](https://opensource.org/licenses/Apache-2.0)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
| Source | Downloads | Page | Installation Command |
|-----------|---------------------------------------------------------------------------------------------------------------------------------|------------------------------------------------------|--------------------------------------------|
| **PyPi** | [![PyPi Downloads](https://pepy.tech/badge/hive-metastore-client)](https://pypi.org/project/hive-metastore-client/) | [Link](https://pypi.org/project/hive-metastore-client/) | `pip install hive-metastore-client ` |
### Build status
| Develop | Stable | Documentation | Sonar |
|-----------------------------------------------------------------------------|-----------------------------------------------------------------------------------|---------------------------------------------------------------------------------------------------------------------------------------------------------|------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|
| ![Test](https://github.com/quintoandar/hive-metastore-client/workflows/Test/badge.svg) | ![Publish](https://github.com/quintoandar/hive-metastore-client/workflows/Publish/badge.svg) | [![Documentation Status](https://readthedocs.org/projects/hive-metastore-client/badge/?version=latest)](https://hive-metastore-client.readthedocs.io/en/latest/?badge=latest) | [![Quality Gate Status](https://sonarcloud.io/api/project_badges/measure?project=quintoandar_hive-metastore-client&metric=alert_status)](https://sonarcloud.io/dashboard?id=quintoandar_hive-metastore-client) |
This library supports Python version 3.7+.
To check library main features you can check [Hive Metastore Client's Documentation](https://hive-metastore-client.readthedocs.io/en/latest/), which is hosted by Read the Docs.
An example of how to use the library for running DDL commands in hive metastore:
```python
from hive_metastore_client.builders import DatabaseBuilder
from hive_metastore_client import HiveMetastoreClient
database = DatabaseBuilder(name='new_db').build()
with HiveMetastoreClient(HIVE_HOST, HIVE_PORT) as hive_metastore_client:
hive_metastore_client.create_database(database)
```
To learn more use cases in practice, see [Hive Metastore Client examples](https://github.com/quintoandar/hive-metastore-client/tree/main/examples)
## Requirements and Installation
Hive Metastore Client depends on **Python 3.7+**
[Python Package Index](https://pypi.org/project/hive-metastore-client/) hosts reference to a pip-installable module of this library, using it is as straightforward as including it on your project's requirements.
```bash
pip install hive-metastore-client
```
## License
[Apache License 2.0](https://github.com/quintoandar/hive-metastore-client/blob/main/LICENSE)
## Contributing
All contributions are welcome! Feel free to open Pull Requests. Check the development and contributing **guidelines**
described in [CONTRIBUTING.md](https://github.com/quintoandar/hive-metastore-client/blob/main/CONTRIBUTING.md)
Made with :heart: by the **Data Engineering** team from [QuintoAndar](https://github.com/quintoandar/)
%package -n python3-hive-metastore-client
Summary: A client for connecting and running DDLs on Hive Metastore with Thrift protocol
Provides: python-hive-metastore-client
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-hive-metastore-client
## Hive Metastore Client
_A client for connecting and running DDLs on [Hive](https://hive.apache.org/) Metastore using [Thrift](https://thrift.apache.org/) protocol._
[![Release](https://img.shields.io/github/v/release/quintoandar/hive-metastore-client)]((https://pypi.org/project/hive-metastore-client/))
![Python Version](https://img.shields.io/badge/python-3.7%20%7C%203.8-brightgreen.svg)
[![License](https://img.shields.io/badge/License-Apache%202.0-blue.svg)](https://opensource.org/licenses/Apache-2.0)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
| Source | Downloads | Page | Installation Command |
|-----------|---------------------------------------------------------------------------------------------------------------------------------|------------------------------------------------------|--------------------------------------------|
| **PyPi** | [![PyPi Downloads](https://pepy.tech/badge/hive-metastore-client)](https://pypi.org/project/hive-metastore-client/) | [Link](https://pypi.org/project/hive-metastore-client/) | `pip install hive-metastore-client ` |
### Build status
| Develop | Stable | Documentation | Sonar |
|-----------------------------------------------------------------------------|-----------------------------------------------------------------------------------|---------------------------------------------------------------------------------------------------------------------------------------------------------|------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|
| ![Test](https://github.com/quintoandar/hive-metastore-client/workflows/Test/badge.svg) | ![Publish](https://github.com/quintoandar/hive-metastore-client/workflows/Publish/badge.svg) | [![Documentation Status](https://readthedocs.org/projects/hive-metastore-client/badge/?version=latest)](https://hive-metastore-client.readthedocs.io/en/latest/?badge=latest) | [![Quality Gate Status](https://sonarcloud.io/api/project_badges/measure?project=quintoandar_hive-metastore-client&metric=alert_status)](https://sonarcloud.io/dashboard?id=quintoandar_hive-metastore-client) |
This library supports Python version 3.7+.
To check library main features you can check [Hive Metastore Client's Documentation](https://hive-metastore-client.readthedocs.io/en/latest/), which is hosted by Read the Docs.
An example of how to use the library for running DDL commands in hive metastore:
```python
from hive_metastore_client.builders import DatabaseBuilder
from hive_metastore_client import HiveMetastoreClient
database = DatabaseBuilder(name='new_db').build()
with HiveMetastoreClient(HIVE_HOST, HIVE_PORT) as hive_metastore_client:
hive_metastore_client.create_database(database)
```
To learn more use cases in practice, see [Hive Metastore Client examples](https://github.com/quintoandar/hive-metastore-client/tree/main/examples)
## Requirements and Installation
Hive Metastore Client depends on **Python 3.7+**
[Python Package Index](https://pypi.org/project/hive-metastore-client/) hosts reference to a pip-installable module of this library, using it is as straightforward as including it on your project's requirements.
```bash
pip install hive-metastore-client
```
## License
[Apache License 2.0](https://github.com/quintoandar/hive-metastore-client/blob/main/LICENSE)
## Contributing
All contributions are welcome! Feel free to open Pull Requests. Check the development and contributing **guidelines**
described in [CONTRIBUTING.md](https://github.com/quintoandar/hive-metastore-client/blob/main/CONTRIBUTING.md)
Made with :heart: by the **Data Engineering** team from [QuintoAndar](https://github.com/quintoandar/)
%package help
Summary: Development documents and examples for hive-metastore-client
Provides: python3-hive-metastore-client-doc
%description help
## Hive Metastore Client
_A client for connecting and running DDLs on [Hive](https://hive.apache.org/) Metastore using [Thrift](https://thrift.apache.org/) protocol._
[![Release](https://img.shields.io/github/v/release/quintoandar/hive-metastore-client)]((https://pypi.org/project/hive-metastore-client/))
![Python Version](https://img.shields.io/badge/python-3.7%20%7C%203.8-brightgreen.svg)
[![License](https://img.shields.io/badge/License-Apache%202.0-blue.svg)](https://opensource.org/licenses/Apache-2.0)
[![Code style: black](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
| Source | Downloads | Page | Installation Command |
|-----------|---------------------------------------------------------------------------------------------------------------------------------|------------------------------------------------------|--------------------------------------------|
| **PyPi** | [![PyPi Downloads](https://pepy.tech/badge/hive-metastore-client)](https://pypi.org/project/hive-metastore-client/) | [Link](https://pypi.org/project/hive-metastore-client/) | `pip install hive-metastore-client ` |
### Build status
| Develop | Stable | Documentation | Sonar |
|-----------------------------------------------------------------------------|-----------------------------------------------------------------------------------|---------------------------------------------------------------------------------------------------------------------------------------------------------|------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------|
| ![Test](https://github.com/quintoandar/hive-metastore-client/workflows/Test/badge.svg) | ![Publish](https://github.com/quintoandar/hive-metastore-client/workflows/Publish/badge.svg) | [![Documentation Status](https://readthedocs.org/projects/hive-metastore-client/badge/?version=latest)](https://hive-metastore-client.readthedocs.io/en/latest/?badge=latest) | [![Quality Gate Status](https://sonarcloud.io/api/project_badges/measure?project=quintoandar_hive-metastore-client&metric=alert_status)](https://sonarcloud.io/dashboard?id=quintoandar_hive-metastore-client) |
This library supports Python version 3.7+.
To check library main features you can check [Hive Metastore Client's Documentation](https://hive-metastore-client.readthedocs.io/en/latest/), which is hosted by Read the Docs.
An example of how to use the library for running DDL commands in hive metastore:
```python
from hive_metastore_client.builders import DatabaseBuilder
from hive_metastore_client import HiveMetastoreClient
database = DatabaseBuilder(name='new_db').build()
with HiveMetastoreClient(HIVE_HOST, HIVE_PORT) as hive_metastore_client:
hive_metastore_client.create_database(database)
```
To learn more use cases in practice, see [Hive Metastore Client examples](https://github.com/quintoandar/hive-metastore-client/tree/main/examples)
## Requirements and Installation
Hive Metastore Client depends on **Python 3.7+**
[Python Package Index](https://pypi.org/project/hive-metastore-client/) hosts reference to a pip-installable module of this library, using it is as straightforward as including it on your project's requirements.
```bash
pip install hive-metastore-client
```
## License
[Apache License 2.0](https://github.com/quintoandar/hive-metastore-client/blob/main/LICENSE)
## Contributing
All contributions are welcome! Feel free to open Pull Requests. Check the development and contributing **guidelines**
described in [CONTRIBUTING.md](https://github.com/quintoandar/hive-metastore-client/blob/main/CONTRIBUTING.md)
Made with :heart: by the **Data Engineering** team from [QuintoAndar](https://github.com/quintoandar/)
%prep
%autosetup -n hive-metastore-client-1.0.9
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-hive-metastore-client -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 1.0.9-1
- Package Spec generated