%global _empty_manifest_terminate_build 0
Name:		python-sphinx-markdown-builder
Version:	0.5.5
Release:	1
Summary:	sphinx builder that outputs markdown files
License:	MIT
URL:		https://github.com/codejamninja/sphinx-markdown-builder
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/49/94/55ba382219583c587bfb43ad54a7f9ccdf5d89825b1c4eb7b379f21f1d20/sphinx-markdown-builder-0.5.5.tar.gz
BuildArch:	noarch

Requires:	python3-html2text
Requires:	python3-pydash
Requires:	python3-sphinx
Requires:	python3-unify
Requires:	python3-yapf

%description
# sphinx-markdown-builder

[![PyPI](https://img.shields.io/pypi/v/sphinx-markdown-builder.svg?style=flat-square)](https://pypi.org/project/sphinx-markdown-builder)
[![PyPI - Downloads](https://img.shields.io/pypi/dm/sphinx-markdown-builder.svg?style=flat-square)](https://pypi.org/project/sphinx-markdown-builder)
[![PyPI - Python Version](https://img.shields.io/pypi/pyversions/sphinx-markdown-builder.svg?style=flat-square)](https://pypi.org/project/sphinx-markdown-builder)
[![GitHub stars](https://img.shields.io/github/stars/codejamninja/sphinx-markdown-builder.svg?style=flat-square&label=Stars)](https://github.com/codejamninja/sphinx-markdown-builder)
[![Liberapay receiving](https://img.shields.io/liberapay/receives/codejamninja.svg?style=flat-square)](https://liberapay.com/codejamninja/donate)
[![Liberapay patrons](https://img.shields.io/liberapay/patrons/codejamninja.svg?style=flat-square)](https://liberapay.com/codejamninja/donate)

> sphinx builder that outputs markdown files

Please ★ this repo if you found it useful ★ ★ ★

If you want frontmatter support please use [sphinx-jekyll-builder](https://github.com/codejamninja/sphinx-jekyll-builder)


## Built by Silicon Hills LLC

[![index](https://user-images.githubusercontent.com/6234038/71054254-f284ad80-2116-11ea-9013-d68306726854.jpeg)](https://nuevesolutions.com)

Silicon Hills offers premium Node and React develpoment and support services. Get in touch at [nuevesolutions.com](https://nuevesolutions.com).


## Recommended Projects

* [sphinx-markdown-parser](https://github.com/codejamninja/sphinx-markdown-parser) - write markdown inside of docutils & sphinx projects


## Features

* Generates markdown


## Installation

```sh
pip3 install sphinx-markdown-builder
```


## Dependencies

* [Python 3](https://www.python.org)


## Usage

Build markdown files with Makefile

```sh
make markdown
```

Build markdown files with `sphinx-build` command

```sh
cd docs
sphinx-build -M markdown ./ build
```


## Support

Submit an [issue](https://github.com/codejamninja/sphinx-markdown-builder/issues/new)


## Screenshots

[Contribute](https://github.com/codejamninja/sphinx-markdown-builder/blob/master/CONTRIBUTING.md) a screenshot


## Contributing

Review the [guidelines for contributing](https://github.com/codejamninja/sphinx-markdown-builder/blob/master/CONTRIBUTING.md)


## License

[MIT License](https://github.com/codejamninja/sphinx-markdown-builder/blob/master/LICENSE)

[Jam Risser](https://codejam.ninja) © 2018


## Changelog

Review the [changelog](https://github.com/codejamninja/sphinx-markdown-builder/blob/master/CHANGELOG.md)


## Credits

* [Jam Risser](https://codejam.ninja) - Author
* [Matthew Brett](https://github.com/matthew-brett/nb2plots/blob/master/nb2plots/doctree2md.py) - doctree2md


## Support on Liberapay

A ridiculous amount of coffee ☕ ☕ ☕ was consumed in the process of building this project.

[Add some fuel](https://liberapay.com/codejamninja/donate) if you'd like to keep me going!

[![Liberapay receiving](https://img.shields.io/liberapay/receives/codejamninja.svg?style=flat-square)](https://liberapay.com/codejamninja/donate)
[![Liberapay patrons](https://img.shields.io/liberapay/patrons/codejamninja.svg?style=flat-square)](https://liberapay.com/codejamninja/donate)




%package -n python3-sphinx-markdown-builder
Summary:	sphinx builder that outputs markdown files
Provides:	python-sphinx-markdown-builder
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-sphinx-markdown-builder
# sphinx-markdown-builder

[![PyPI](https://img.shields.io/pypi/v/sphinx-markdown-builder.svg?style=flat-square)](https://pypi.org/project/sphinx-markdown-builder)
[![PyPI - Downloads](https://img.shields.io/pypi/dm/sphinx-markdown-builder.svg?style=flat-square)](https://pypi.org/project/sphinx-markdown-builder)
[![PyPI - Python Version](https://img.shields.io/pypi/pyversions/sphinx-markdown-builder.svg?style=flat-square)](https://pypi.org/project/sphinx-markdown-builder)
[![GitHub stars](https://img.shields.io/github/stars/codejamninja/sphinx-markdown-builder.svg?style=flat-square&label=Stars)](https://github.com/codejamninja/sphinx-markdown-builder)
[![Liberapay receiving](https://img.shields.io/liberapay/receives/codejamninja.svg?style=flat-square)](https://liberapay.com/codejamninja/donate)
[![Liberapay patrons](https://img.shields.io/liberapay/patrons/codejamninja.svg?style=flat-square)](https://liberapay.com/codejamninja/donate)

> sphinx builder that outputs markdown files

Please ★ this repo if you found it useful ★ ★ ★

If you want frontmatter support please use [sphinx-jekyll-builder](https://github.com/codejamninja/sphinx-jekyll-builder)


## Built by Silicon Hills LLC

[![index](https://user-images.githubusercontent.com/6234038/71054254-f284ad80-2116-11ea-9013-d68306726854.jpeg)](https://nuevesolutions.com)

Silicon Hills offers premium Node and React develpoment and support services. Get in touch at [nuevesolutions.com](https://nuevesolutions.com).


## Recommended Projects

* [sphinx-markdown-parser](https://github.com/codejamninja/sphinx-markdown-parser) - write markdown inside of docutils & sphinx projects


## Features

* Generates markdown


## Installation

```sh
pip3 install sphinx-markdown-builder
```


## Dependencies

* [Python 3](https://www.python.org)


## Usage

Build markdown files with Makefile

```sh
make markdown
```

Build markdown files with `sphinx-build` command

```sh
cd docs
sphinx-build -M markdown ./ build
```


## Support

Submit an [issue](https://github.com/codejamninja/sphinx-markdown-builder/issues/new)


## Screenshots

[Contribute](https://github.com/codejamninja/sphinx-markdown-builder/blob/master/CONTRIBUTING.md) a screenshot


## Contributing

Review the [guidelines for contributing](https://github.com/codejamninja/sphinx-markdown-builder/blob/master/CONTRIBUTING.md)


## License

[MIT License](https://github.com/codejamninja/sphinx-markdown-builder/blob/master/LICENSE)

[Jam Risser](https://codejam.ninja) © 2018


## Changelog

Review the [changelog](https://github.com/codejamninja/sphinx-markdown-builder/blob/master/CHANGELOG.md)


## Credits

* [Jam Risser](https://codejam.ninja) - Author
* [Matthew Brett](https://github.com/matthew-brett/nb2plots/blob/master/nb2plots/doctree2md.py) - doctree2md


## Support on Liberapay

A ridiculous amount of coffee ☕ ☕ ☕ was consumed in the process of building this project.

[Add some fuel](https://liberapay.com/codejamninja/donate) if you'd like to keep me going!

[![Liberapay receiving](https://img.shields.io/liberapay/receives/codejamninja.svg?style=flat-square)](https://liberapay.com/codejamninja/donate)
[![Liberapay patrons](https://img.shields.io/liberapay/patrons/codejamninja.svg?style=flat-square)](https://liberapay.com/codejamninja/donate)




%package help
Summary:	Development documents and examples for sphinx-markdown-builder
Provides:	python3-sphinx-markdown-builder-doc
%description help
# sphinx-markdown-builder

[![PyPI](https://img.shields.io/pypi/v/sphinx-markdown-builder.svg?style=flat-square)](https://pypi.org/project/sphinx-markdown-builder)
[![PyPI - Downloads](https://img.shields.io/pypi/dm/sphinx-markdown-builder.svg?style=flat-square)](https://pypi.org/project/sphinx-markdown-builder)
[![PyPI - Python Version](https://img.shields.io/pypi/pyversions/sphinx-markdown-builder.svg?style=flat-square)](https://pypi.org/project/sphinx-markdown-builder)
[![GitHub stars](https://img.shields.io/github/stars/codejamninja/sphinx-markdown-builder.svg?style=flat-square&label=Stars)](https://github.com/codejamninja/sphinx-markdown-builder)
[![Liberapay receiving](https://img.shields.io/liberapay/receives/codejamninja.svg?style=flat-square)](https://liberapay.com/codejamninja/donate)
[![Liberapay patrons](https://img.shields.io/liberapay/patrons/codejamninja.svg?style=flat-square)](https://liberapay.com/codejamninja/donate)

> sphinx builder that outputs markdown files

Please ★ this repo if you found it useful ★ ★ ★

If you want frontmatter support please use [sphinx-jekyll-builder](https://github.com/codejamninja/sphinx-jekyll-builder)


## Built by Silicon Hills LLC

[![index](https://user-images.githubusercontent.com/6234038/71054254-f284ad80-2116-11ea-9013-d68306726854.jpeg)](https://nuevesolutions.com)

Silicon Hills offers premium Node and React develpoment and support services. Get in touch at [nuevesolutions.com](https://nuevesolutions.com).


## Recommended Projects

* [sphinx-markdown-parser](https://github.com/codejamninja/sphinx-markdown-parser) - write markdown inside of docutils & sphinx projects


## Features

* Generates markdown


## Installation

```sh
pip3 install sphinx-markdown-builder
```


## Dependencies

* [Python 3](https://www.python.org)


## Usage

Build markdown files with Makefile

```sh
make markdown
```

Build markdown files with `sphinx-build` command

```sh
cd docs
sphinx-build -M markdown ./ build
```


## Support

Submit an [issue](https://github.com/codejamninja/sphinx-markdown-builder/issues/new)


## Screenshots

[Contribute](https://github.com/codejamninja/sphinx-markdown-builder/blob/master/CONTRIBUTING.md) a screenshot


## Contributing

Review the [guidelines for contributing](https://github.com/codejamninja/sphinx-markdown-builder/blob/master/CONTRIBUTING.md)


## License

[MIT License](https://github.com/codejamninja/sphinx-markdown-builder/blob/master/LICENSE)

[Jam Risser](https://codejam.ninja) © 2018


## Changelog

Review the [changelog](https://github.com/codejamninja/sphinx-markdown-builder/blob/master/CHANGELOG.md)


## Credits

* [Jam Risser](https://codejam.ninja) - Author
* [Matthew Brett](https://github.com/matthew-brett/nb2plots/blob/master/nb2plots/doctree2md.py) - doctree2md


## Support on Liberapay

A ridiculous amount of coffee ☕ ☕ ☕ was consumed in the process of building this project.

[Add some fuel](https://liberapay.com/codejamninja/donate) if you'd like to keep me going!

[![Liberapay receiving](https://img.shields.io/liberapay/receives/codejamninja.svg?style=flat-square)](https://liberapay.com/codejamninja/donate)
[![Liberapay patrons](https://img.shields.io/liberapay/patrons/codejamninja.svg?style=flat-square)](https://liberapay.com/codejamninja/donate)




%prep
%autosetup -n sphinx-markdown-builder-0.5.5

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-sphinx-markdown-builder -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.5-1
- Package Spec generated