%global _empty_manifest_terminate_build 0
Name: python-virtualenvwrapper-win
Version: 1.2.7
Release: 1
Summary: Port of Doug Hellmann's virtualenvwrapper to Windows batch scripts
License: BSD 3-clause
URL: https://github.com/davidmarble/virtualenvwrapper-win/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/25/1e/5325fa392d6d6618b4ffc11fa973e94c38d7661b6edb6058cc20099e03bd/virtualenvwrapper-win-1.2.7.tar.gz
BuildArch: noarch
Requires: python3-virtualenv
%description
This is a port of Doug Hellmann's `virtualenvwrapper `_
to Windows batch scripts. The idea behind virtualenvwrapper is to ease usage of
Ian Bicking's `virtualenv `_, a tool
for creating isolated Python virtual environments, each with their own libraries
and site-packages.
These scripts should work on any version of Windows (Windows XP, Windows Vista, Windows 7/8/10).
However, they only work in the **regular command prompt**. They **will not work in Powershell.** There are other virtualenvwrapper projects out there for Powershell.
%package -n python3-virtualenvwrapper-win
Summary: Port of Doug Hellmann's virtualenvwrapper to Windows batch scripts
Provides: python-virtualenvwrapper-win
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-virtualenvwrapper-win
This is a port of Doug Hellmann's `virtualenvwrapper `_
to Windows batch scripts. The idea behind virtualenvwrapper is to ease usage of
Ian Bicking's `virtualenv `_, a tool
for creating isolated Python virtual environments, each with their own libraries
and site-packages.
These scripts should work on any version of Windows (Windows XP, Windows Vista, Windows 7/8/10).
However, they only work in the **regular command prompt**. They **will not work in Powershell.** There are other virtualenvwrapper projects out there for Powershell.
%package help
Summary: Development documents and examples for virtualenvwrapper-win
Provides: python3-virtualenvwrapper-win-doc
%description help
This is a port of Doug Hellmann's `virtualenvwrapper `_
to Windows batch scripts. The idea behind virtualenvwrapper is to ease usage of
Ian Bicking's `virtualenv `_, a tool
for creating isolated Python virtual environments, each with their own libraries
and site-packages.
These scripts should work on any version of Windows (Windows XP, Windows Vista, Windows 7/8/10).
However, they only work in the **regular command prompt**. They **will not work in Powershell.** There are other virtualenvwrapper projects out there for Powershell.
%prep
%autosetup -n virtualenvwrapper-win-1.2.7
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-virtualenvwrapper-win -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 1.2.7-1
- Package Spec generated