%global _empty_manifest_terminate_build 0
Name:		python-pycollect
Version:	0.2.3
Release:	1
Summary:	Utility library to collect files recursively
License:	MIT license
URL:		https://github.com/allrod5/pycollect
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/50/7c/550a5011f530a1e14d240a85f34ea7e455fb48d3b57c34ab8dff71a4bdc0/pycollect-0.2.3.tar.gz
BuildArch:	noarch


%description
Utility library dealing with Python files.
**Features**
 * Collect Python files recursively from a given directory
 * Find the Python module name respective to a Python file

%package -n python3-pycollect
Summary:	Utility library to collect files recursively
Provides:	python-pycollect
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pycollect
Utility library dealing with Python files.
**Features**
 * Collect Python files recursively from a given directory
 * Find the Python module name respective to a Python file

%package help
Summary:	Development documents and examples for pycollect
Provides:	python3-pycollect-doc
%description help
Utility library dealing with Python files.
**Features**
 * Collect Python files recursively from a given directory
 * Find the Python module name respective to a Python file

%prep
%autosetup -n pycollect-0.2.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pycollect -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.3-1
- Package Spec generated