%global _empty_manifest_terminate_build 0
Name: python-ffmpeg-progress-yield
Version: 0.7.2
Release: 1
Summary: Run an ffmpeg command with progress
License: MIT
URL: https://github.com/slhck/ffmpeg-progress-yield
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/76/54/a82d8be874fd756540e3cdd790a6564ef828bf98193b5108dab0b89c71d2/ffmpeg-progress-yield-0.7.2.tar.gz
BuildArch: noarch
%description
## Requirements
- Python 3.8 or higher
- ffmpeg v3.1 or above from installed in your \$PATH
## Installation
pip3 install ffmpeg-progress-yield
Or download this repository, then run `pip install .`.
## Usage
### As a library
In your Python project, import the helper class and run `run_command_with_progress`.
For more information see the [API documentation](https://htmlpreview.github.io/?https://github.com/slhck/ffmpeg-progress-yield/blob/master/docs/ffmpeg_progress_yield.html).
Example:
```python
from ffmpeg_progress_yield import FfmpegProgress
cmd = [
"ffmpeg", "-i", "test/test.mp4", "-c:v", "libx264", "-vf", "scale=1920x1080", "-preset", "fast", "-f", "null", "/dev/null",
]
ff = FfmpegProgress(cmd)
for progress in ff.run_command_with_progress():
print(f"{progress}/100")
```
The command will yield the current progress in percent.
`run_command_with_progress` takes a `duration_override` argument where you can manually override the duration of the command in seconds. This is useful if your input doesn't have an implicit duration (e.g. if you use `testsrc`).
If you have `tqdm` installed, you can create a fancy progress bar:
```python
from tqdm import tqdm
from ffmpeg_progress_yield import FfmpegProgress
cmd = [
"ffmpeg", "-i", "test/test.mp4", "-c:v", "libx264", "-vf", "scale=1920x1080", "-preset", "fast", "-f", "null", "/dev/null",
]
ff = FfmpegProgress(cmd)
with tqdm(total=100, position=1, desc="Test") as pbar:
for progress in ff.run_command_with_progress():
pbar.update(progress - pbar.n)
# get the output
print(ff.stderr)
```
You can also quit the command by calling `.quit()`:
```python
ff = FfmpegProgress(cmd)
for progress in ff.run_command_with_progress():
if progress > 50:
ff.quit()
break
```
This will send a hard quit to the ffmpeg process, and may not wait for it to finish. To quit gracefully, use `.quit_gracefully()` instead, which sends 'q' to the ffmpeg process, and waits for it to finish.
This is probably most useful in asynchronous environments, where you can run the command in a separate thread, and quit it from the main thread (e.g. using a [Condition Variable](https://docs.python.org/3/library/threading.html#threading.Condition)).
### On the command line
Simply prefix your ffmpeg command with `ffmpeg-progress-yield`:
```bash
ffmpeg-progress-yield ffmpeg -i input.mp4 output.mp4
```
It will show a progress bar, and once the command is done, show the ffmpeg stderr output.
If you want to manually override the duration to, say, 12.5 seconds (e.g. because your input doesn't have an implicit one):
```bash
ffmpeg-progress-yield --duration 12.5 ffmpeg -f lavfi -i testsrc -t 12.5 output.mp4
```
## Caveats
Currently, we do not differentiate between `stderr` and `stdout`. This means progress will be mixed with the ffmpeg log.
You can also check out [`ffmpeg-progress`](https://github.com/Tatsh/ffmpeg-progress) for a similar project with a different feature set.
## Contributors
## License
The MIT License (MIT)
Copyright (c) 2021-2022 Werner Robitza
Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:
The above copyright notice and this permission notice shall be included in all
copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.
# Changelog
## v0.7.2 (2023-03-04)
* Do not print input information when probing, addresses #10.
## v0.7.1 (2023-02-24)
* Fix types in CI.
* Remove unneeded import.
* Typo.
* Docs: add @kskadart as a contributor.
* Fix formatting.
* Fix types.
* Feat(ffprobe): FEAT-0001 try to get duration by ffprobe in case if loglevel=error.
* Fix CI file.
## v0.7.0 (2023-01-24)
* Add duration override to API.
* Remove manifest.in.
* Add mypy settings.
## v0.6.1 (2022-12-18)
* Add py.typed.
* Move API docs to existing section.
## v0.6.0 (2022-12-17)
* Link to API docs.
* Add API docs.
* Add export.
* Bump requirements to python 3.8 or higher.
* Document methods.
* Remove unused import.
* Docs: add @WyattBlue as a contributor.
* Docs: add @slhck as a contributor.
* Unhide to_ms.
* Add type hints + simplify.
* Add python CI badge.
* Fix quit tests.
* Add all-contributors.
* Add pytest to dev requirements.
* Add github workflows.
* Formatting.
* Fix a few type and formatting errors.
## v0.5.0 (2022-12-12)
* Add stderr callback method.
* Update README.
* Add graceful quit method.
* Add a GIF in the readme.
## v0.4.0 (2022-12-11)
* Add a quit method, fixes #4.
## v0.3.0 (2022-08-02)
* Update python requirements.
## v0.2.0 (2021-11-21)
* Add a usage option.
## v0.1.2 (2021-08-14)
* Remove universal_newlines for Windows compat.
## v0.1.1 (2021-07-01)
* Remove stats_period option for backwards compatibility, fixes #2.
## v0.1.0 (2021-06-30)
* Format code with black.
* Yield 0 in progress and improve logic.
* Set universal_newlines to true and add kwargs support.
* Increase stats period.
* Document method.
* Add typing.
* Also check for 0 in output.
* Update gitignore.
* Drop python 3.5 support.
* Update badge link.
## v0.0.4 (2021-03-10)
* Add python_requires to setup.py.
## v0.0.3 (2021-03-06)
* Remove release script.
## v0.0.2 (2021-03-06)
* Fix release script.
* Remove support for older versions.
* Format setup.py.
* Remove requirement for command to start with ffmpeg.
* Add link to similar project.
* Add changelog.
* Rename project.
* Initial commit.
%package -n python3-ffmpeg-progress-yield
Summary: Run an ffmpeg command with progress
Provides: python-ffmpeg-progress-yield
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-ffmpeg-progress-yield
## Requirements
- Python 3.8 or higher
- ffmpeg v3.1 or above from installed in your \$PATH
## Installation
pip3 install ffmpeg-progress-yield
Or download this repository, then run `pip install .`.
## Usage
### As a library
In your Python project, import the helper class and run `run_command_with_progress`.
For more information see the [API documentation](https://htmlpreview.github.io/?https://github.com/slhck/ffmpeg-progress-yield/blob/master/docs/ffmpeg_progress_yield.html).
Example:
```python
from ffmpeg_progress_yield import FfmpegProgress
cmd = [
"ffmpeg", "-i", "test/test.mp4", "-c:v", "libx264", "-vf", "scale=1920x1080", "-preset", "fast", "-f", "null", "/dev/null",
]
ff = FfmpegProgress(cmd)
for progress in ff.run_command_with_progress():
print(f"{progress}/100")
```
The command will yield the current progress in percent.
`run_command_with_progress` takes a `duration_override` argument where you can manually override the duration of the command in seconds. This is useful if your input doesn't have an implicit duration (e.g. if you use `testsrc`).
If you have `tqdm` installed, you can create a fancy progress bar:
```python
from tqdm import tqdm
from ffmpeg_progress_yield import FfmpegProgress
cmd = [
"ffmpeg", "-i", "test/test.mp4", "-c:v", "libx264", "-vf", "scale=1920x1080", "-preset", "fast", "-f", "null", "/dev/null",
]
ff = FfmpegProgress(cmd)
with tqdm(total=100, position=1, desc="Test") as pbar:
for progress in ff.run_command_with_progress():
pbar.update(progress - pbar.n)
# get the output
print(ff.stderr)
```
You can also quit the command by calling `.quit()`:
```python
ff = FfmpegProgress(cmd)
for progress in ff.run_command_with_progress():
if progress > 50:
ff.quit()
break
```
This will send a hard quit to the ffmpeg process, and may not wait for it to finish. To quit gracefully, use `.quit_gracefully()` instead, which sends 'q' to the ffmpeg process, and waits for it to finish.
This is probably most useful in asynchronous environments, where you can run the command in a separate thread, and quit it from the main thread (e.g. using a [Condition Variable](https://docs.python.org/3/library/threading.html#threading.Condition)).
### On the command line
Simply prefix your ffmpeg command with `ffmpeg-progress-yield`:
```bash
ffmpeg-progress-yield ffmpeg -i input.mp4 output.mp4
```
It will show a progress bar, and once the command is done, show the ffmpeg stderr output.
If you want to manually override the duration to, say, 12.5 seconds (e.g. because your input doesn't have an implicit one):
```bash
ffmpeg-progress-yield --duration 12.5 ffmpeg -f lavfi -i testsrc -t 12.5 output.mp4
```
## Caveats
Currently, we do not differentiate between `stderr` and `stdout`. This means progress will be mixed with the ffmpeg log.
You can also check out [`ffmpeg-progress`](https://github.com/Tatsh/ffmpeg-progress) for a similar project with a different feature set.
## Contributors
## License
The MIT License (MIT)
Copyright (c) 2021-2022 Werner Robitza
Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:
The above copyright notice and this permission notice shall be included in all
copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.
# Changelog
## v0.7.2 (2023-03-04)
* Do not print input information when probing, addresses #10.
## v0.7.1 (2023-02-24)
* Fix types in CI.
* Remove unneeded import.
* Typo.
* Docs: add @kskadart as a contributor.
* Fix formatting.
* Fix types.
* Feat(ffprobe): FEAT-0001 try to get duration by ffprobe in case if loglevel=error.
* Fix CI file.
## v0.7.0 (2023-01-24)
* Add duration override to API.
* Remove manifest.in.
* Add mypy settings.
## v0.6.1 (2022-12-18)
* Add py.typed.
* Move API docs to existing section.
## v0.6.0 (2022-12-17)
* Link to API docs.
* Add API docs.
* Add export.
* Bump requirements to python 3.8 or higher.
* Document methods.
* Remove unused import.
* Docs: add @WyattBlue as a contributor.
* Docs: add @slhck as a contributor.
* Unhide to_ms.
* Add type hints + simplify.
* Add python CI badge.
* Fix quit tests.
* Add all-contributors.
* Add pytest to dev requirements.
* Add github workflows.
* Formatting.
* Fix a few type and formatting errors.
## v0.5.0 (2022-12-12)
* Add stderr callback method.
* Update README.
* Add graceful quit method.
* Add a GIF in the readme.
## v0.4.0 (2022-12-11)
* Add a quit method, fixes #4.
## v0.3.0 (2022-08-02)
* Update python requirements.
## v0.2.0 (2021-11-21)
* Add a usage option.
## v0.1.2 (2021-08-14)
* Remove universal_newlines for Windows compat.
## v0.1.1 (2021-07-01)
* Remove stats_period option for backwards compatibility, fixes #2.
## v0.1.0 (2021-06-30)
* Format code with black.
* Yield 0 in progress and improve logic.
* Set universal_newlines to true and add kwargs support.
* Increase stats period.
* Document method.
* Add typing.
* Also check for 0 in output.
* Update gitignore.
* Drop python 3.5 support.
* Update badge link.
## v0.0.4 (2021-03-10)
* Add python_requires to setup.py.
## v0.0.3 (2021-03-06)
* Remove release script.
## v0.0.2 (2021-03-06)
* Fix release script.
* Remove support for older versions.
* Format setup.py.
* Remove requirement for command to start with ffmpeg.
* Add link to similar project.
* Add changelog.
* Rename project.
* Initial commit.
%package help
Summary: Development documents and examples for ffmpeg-progress-yield
Provides: python3-ffmpeg-progress-yield-doc
%description help
## Requirements
- Python 3.8 or higher
- ffmpeg v3.1 or above from installed in your \$PATH
## Installation
pip3 install ffmpeg-progress-yield
Or download this repository, then run `pip install .`.
## Usage
### As a library
In your Python project, import the helper class and run `run_command_with_progress`.
For more information see the [API documentation](https://htmlpreview.github.io/?https://github.com/slhck/ffmpeg-progress-yield/blob/master/docs/ffmpeg_progress_yield.html).
Example:
```python
from ffmpeg_progress_yield import FfmpegProgress
cmd = [
"ffmpeg", "-i", "test/test.mp4", "-c:v", "libx264", "-vf", "scale=1920x1080", "-preset", "fast", "-f", "null", "/dev/null",
]
ff = FfmpegProgress(cmd)
for progress in ff.run_command_with_progress():
print(f"{progress}/100")
```
The command will yield the current progress in percent.
`run_command_with_progress` takes a `duration_override` argument where you can manually override the duration of the command in seconds. This is useful if your input doesn't have an implicit duration (e.g. if you use `testsrc`).
If you have `tqdm` installed, you can create a fancy progress bar:
```python
from tqdm import tqdm
from ffmpeg_progress_yield import FfmpegProgress
cmd = [
"ffmpeg", "-i", "test/test.mp4", "-c:v", "libx264", "-vf", "scale=1920x1080", "-preset", "fast", "-f", "null", "/dev/null",
]
ff = FfmpegProgress(cmd)
with tqdm(total=100, position=1, desc="Test") as pbar:
for progress in ff.run_command_with_progress():
pbar.update(progress - pbar.n)
# get the output
print(ff.stderr)
```
You can also quit the command by calling `.quit()`:
```python
ff = FfmpegProgress(cmd)
for progress in ff.run_command_with_progress():
if progress > 50:
ff.quit()
break
```
This will send a hard quit to the ffmpeg process, and may not wait for it to finish. To quit gracefully, use `.quit_gracefully()` instead, which sends 'q' to the ffmpeg process, and waits for it to finish.
This is probably most useful in asynchronous environments, where you can run the command in a separate thread, and quit it from the main thread (e.g. using a [Condition Variable](https://docs.python.org/3/library/threading.html#threading.Condition)).
### On the command line
Simply prefix your ffmpeg command with `ffmpeg-progress-yield`:
```bash
ffmpeg-progress-yield ffmpeg -i input.mp4 output.mp4
```
It will show a progress bar, and once the command is done, show the ffmpeg stderr output.
If you want to manually override the duration to, say, 12.5 seconds (e.g. because your input doesn't have an implicit one):
```bash
ffmpeg-progress-yield --duration 12.5 ffmpeg -f lavfi -i testsrc -t 12.5 output.mp4
```
## Caveats
Currently, we do not differentiate between `stderr` and `stdout`. This means progress will be mixed with the ffmpeg log.
You can also check out [`ffmpeg-progress`](https://github.com/Tatsh/ffmpeg-progress) for a similar project with a different feature set.
## Contributors
## License
The MIT License (MIT)
Copyright (c) 2021-2022 Werner Robitza
Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:
The above copyright notice and this permission notice shall be included in all
copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.
# Changelog
## v0.7.2 (2023-03-04)
* Do not print input information when probing, addresses #10.
## v0.7.1 (2023-02-24)
* Fix types in CI.
* Remove unneeded import.
* Typo.
* Docs: add @kskadart as a contributor.
* Fix formatting.
* Fix types.
* Feat(ffprobe): FEAT-0001 try to get duration by ffprobe in case if loglevel=error.
* Fix CI file.
## v0.7.0 (2023-01-24)
* Add duration override to API.
* Remove manifest.in.
* Add mypy settings.
## v0.6.1 (2022-12-18)
* Add py.typed.
* Move API docs to existing section.
## v0.6.0 (2022-12-17)
* Link to API docs.
* Add API docs.
* Add export.
* Bump requirements to python 3.8 or higher.
* Document methods.
* Remove unused import.
* Docs: add @WyattBlue as a contributor.
* Docs: add @slhck as a contributor.
* Unhide to_ms.
* Add type hints + simplify.
* Add python CI badge.
* Fix quit tests.
* Add all-contributors.
* Add pytest to dev requirements.
* Add github workflows.
* Formatting.
* Fix a few type and formatting errors.
## v0.5.0 (2022-12-12)
* Add stderr callback method.
* Update README.
* Add graceful quit method.
* Add a GIF in the readme.
## v0.4.0 (2022-12-11)
* Add a quit method, fixes #4.
## v0.3.0 (2022-08-02)
* Update python requirements.
## v0.2.0 (2021-11-21)
* Add a usage option.
## v0.1.2 (2021-08-14)
* Remove universal_newlines for Windows compat.
## v0.1.1 (2021-07-01)
* Remove stats_period option for backwards compatibility, fixes #2.
## v0.1.0 (2021-06-30)
* Format code with black.
* Yield 0 in progress and improve logic.
* Set universal_newlines to true and add kwargs support.
* Increase stats period.
* Document method.
* Add typing.
* Also check for 0 in output.
* Update gitignore.
* Drop python 3.5 support.
* Update badge link.
## v0.0.4 (2021-03-10)
* Add python_requires to setup.py.
## v0.0.3 (2021-03-06)
* Remove release script.
## v0.0.2 (2021-03-06)
* Fix release script.
* Remove support for older versions.
* Format setup.py.
* Remove requirement for command to start with ffmpeg.
* Add link to similar project.
* Add changelog.
* Rename project.
* Initial commit.
%prep
%autosetup -n ffmpeg-progress-yield-0.7.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-ffmpeg-progress-yield -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Sun Apr 23 2023 Python_Bot - 0.7.2-1
- Package Spec generated