%global _empty_manifest_terminate_build 0
Name:		python-slicerator
Version:	1.1.0
Release:	1
Summary:	A lazy-loading, fancy-sliceable iterable.
License:	BSD
URL:		http://github.com/soft-matter/slicerator
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/0c/52/f38586b82b2935f8b59a09b0a79c545a22ed062e728c9418bafeb51f61e0/slicerator-1.1.0.tar.gz
BuildArch:	noarch


%description
a lazy-loading, fancy-slicable iterable
Think of it like a generator that is "reusable" and has a length.
[Please see the documentation](http://slicerator.readthedocs.io/en/latest/) for examples and an API reference.
[![build status](https://travis-ci.org/soft-matter/slicerator.png?branch=master)](https://travis-ci.org/soft-matter/slicerator) [![Documentation Status](https://readthedocs.org/projects/slicerator/badge/?version=latest)](http://slicerator.readthedocs.io/en/latest/?badge=latest)

%package -n python3-slicerator
Summary:	A lazy-loading, fancy-sliceable iterable.
Provides:	python-slicerator
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-slicerator
a lazy-loading, fancy-slicable iterable
Think of it like a generator that is "reusable" and has a length.
[Please see the documentation](http://slicerator.readthedocs.io/en/latest/) for examples and an API reference.
[![build status](https://travis-ci.org/soft-matter/slicerator.png?branch=master)](https://travis-ci.org/soft-matter/slicerator) [![Documentation Status](https://readthedocs.org/projects/slicerator/badge/?version=latest)](http://slicerator.readthedocs.io/en/latest/?badge=latest)

%package help
Summary:	Development documents and examples for slicerator
Provides:	python3-slicerator-doc
%description help
a lazy-loading, fancy-slicable iterable
Think of it like a generator that is "reusable" and has a length.
[Please see the documentation](http://slicerator.readthedocs.io/en/latest/) for examples and an API reference.
[![build status](https://travis-ci.org/soft-matter/slicerator.png?branch=master)](https://travis-ci.org/soft-matter/slicerator) [![Documentation Status](https://readthedocs.org/projects/slicerator/badge/?version=latest)](http://slicerator.readthedocs.io/en/latest/?badge=latest)

%prep
%autosetup -n slicerator-1.1.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-slicerator -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.0-1
- Package Spec generated