%global _empty_manifest_terminate_build 0
Name:		python-Flask-Menu
Version:	0.7.2
Release:	1
Summary:	Flask-Menu is a Flask extension that adds support for generating menus.
License:	BSD
URL:		https://github.com/inveniosoftware/flask-menu
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/b2/9e/dfeedf166af0d91c72c448634019b7268fdf29b0811ff5d48c57ee1c56ae/Flask-Menu-0.7.2.tar.gz
BuildArch:	noarch

Requires:	python3-Flask
Requires:	python3-six
Requires:	python3-sphinx
Requires:	python3-flask-classy
Requires:	python3-check-manifest
Requires:	python3-coverage
Requires:	python3-isort
Requires:	python3-pydocstyle
Requires:	python3-pytest
Requires:	python3-pytest-cache
Requires:	python3-pytest-cov
Requires:	python3-pytest-pep8
Requires:	python3-flask-classy
Requires:	python3-sphinx
Requires:	python3-flask-classy
Requires:	python3-check-manifest
Requires:	python3-coverage
Requires:	python3-isort
Requires:	python3-pydocstyle
Requires:	python3-pytest
Requires:	python3-pytest-cache
Requires:	python3-pytest-cov
Requires:	python3-pytest-pep8

%description


%package -n python3-Flask-Menu
Summary:	Flask-Menu is a Flask extension that adds support for generating menus.
Provides:	python-Flask-Menu
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Flask-Menu


%package help
Summary:	Development documents and examples for Flask-Menu
Provides:	python3-Flask-Menu-doc
%description help


%prep
%autosetup -n Flask-Menu-0.7.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Flask-Menu -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7.2-1
- Package Spec generated