%global _empty_manifest_terminate_build 0
Name:		python-pytest-airflow
Version:	0.0.3
Release:	1
Summary:	pytest support for airflow.
License:	Mozilla Public License 2.0 (MPL 2.0)
URL:		https://github.com/Flowminder/pytest-airflow
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/c7/60/97494d30bedb50b4eea5367a63cbadaac2aeb8034218e479d768a5746fd4/pytest-airflow-0.0.3.tar.gz
BuildArch:	noarch

Requires:	python3-pytest
Requires:	python3-apache-airflow

%description
``pytest-airflow`` is a plugin for ``pytest`` that allows tests to be run
within an Airflow DAG.
``pytest`` handles test discovery and function encapsulation, allowing
test declaration to operate in the usual way with the use of
parametrization, fixtures and marks. The generated test callables tests
are eventually passed to ``PythonOperators`` that are run as separate
Airflow tasks.

%package -n python3-pytest-airflow
Summary:	pytest support for airflow.
Provides:	python-pytest-airflow
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-pytest-airflow
``pytest-airflow`` is a plugin for ``pytest`` that allows tests to be run
within an Airflow DAG.
``pytest`` handles test discovery and function encapsulation, allowing
test declaration to operate in the usual way with the use of
parametrization, fixtures and marks. The generated test callables tests
are eventually passed to ``PythonOperators`` that are run as separate
Airflow tasks.

%package help
Summary:	Development documents and examples for pytest-airflow
Provides:	python3-pytest-airflow-doc
%description help
``pytest-airflow`` is a plugin for ``pytest`` that allows tests to be run
within an Airflow DAG.
``pytest`` handles test discovery and function encapsulation, allowing
test declaration to operate in the usual way with the use of
parametrization, fixtures and marks. The generated test callables tests
are eventually passed to ``PythonOperators`` that are run as separate
Airflow tasks.

%prep
%autosetup -n pytest-airflow-0.0.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-pytest-airflow -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.3-1
- Package Spec generated