%global _empty_manifest_terminate_build 0
Name:		python-amba-event-stream
Version:	1.0.3
Release:	1
Summary:	amba-event-stream for kafka
License:	MIT License
URL:		https://pypi.org/project/amba-event-stream/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/52/de/7449c5fd62b1b9460f0d8e1df22a4aff68f45ed80832fd21ee229f171c31/amba-event-stream-1.0.3.tar.gz
BuildArch:	noarch

Requires:	python3-kafka-python
Requires:	python3-sqlalchemy
Requires:	python3-psycopg2

%description
# amba-event-stream

[![PyPI][]][1]

  [PyPI]: https://img.shields.io/pypi/v/amba-event-stream
  [1]: https://pypi.org/project/amba-event-stream/

The Amba Analysis Streams package is used as a Kafka connection wrapper to abstract from infrastructure implementation details by providing functions to connect to Kafka and PostgreSQL. It defines the event model used in the streaming platform and provides base consumer and producer classes. The package is implemented as a python package that is hosted on pypi.org, and documented with mkdocs.

The consumer and producer are capable of running in multiple processes to allow for parallel processing to better utilize modern CPUs. Both have built in monitoring capabilities: a counter shared by all processes is updated for each processed event. A thread running a function every few seconds is checking the counter and resetting it. If no data is processed over a defined period of time (meaning multiple consecutive check function runs), the container is restarted automatically by closing all python processed. This heart beat function ensures that even unforeseeable errors, such as container crashes or blockings are resolved by restarting the container and providing a clean system state. 

more Information can be found [here](https://github.com/ambalytics/amba-analysis-streams/blob/fce56afbd7d8207b847c270ffa2c6e025dcc1950/docs/Recognition-of-Scholarly-Publication-Trends-based-on-Social-Data-Stream-Processing_Lukas-Jesche.pdf)

# Installation

``` bash
pip install amba-event-stream
```

# Releasing

Releases are published automatically when a tag is pushed to GitHub.

``` bash
# Set next version number
export RELEASE=x.x.x

# Create tags
git commit --allow-empty -m "Release $RELEASE"
git tag -a $RELEASE -m "Version $RELEASE"

# Push
git push upstream --tags
```




%package -n python3-amba-event-stream
Summary:	amba-event-stream for kafka
Provides:	python-amba-event-stream
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-amba-event-stream
# amba-event-stream

[![PyPI][]][1]

  [PyPI]: https://img.shields.io/pypi/v/amba-event-stream
  [1]: https://pypi.org/project/amba-event-stream/

The Amba Analysis Streams package is used as a Kafka connection wrapper to abstract from infrastructure implementation details by providing functions to connect to Kafka and PostgreSQL. It defines the event model used in the streaming platform and provides base consumer and producer classes. The package is implemented as a python package that is hosted on pypi.org, and documented with mkdocs.

The consumer and producer are capable of running in multiple processes to allow for parallel processing to better utilize modern CPUs. Both have built in monitoring capabilities: a counter shared by all processes is updated for each processed event. A thread running a function every few seconds is checking the counter and resetting it. If no data is processed over a defined period of time (meaning multiple consecutive check function runs), the container is restarted automatically by closing all python processed. This heart beat function ensures that even unforeseeable errors, such as container crashes or blockings are resolved by restarting the container and providing a clean system state. 

more Information can be found [here](https://github.com/ambalytics/amba-analysis-streams/blob/fce56afbd7d8207b847c270ffa2c6e025dcc1950/docs/Recognition-of-Scholarly-Publication-Trends-based-on-Social-Data-Stream-Processing_Lukas-Jesche.pdf)

# Installation

``` bash
pip install amba-event-stream
```

# Releasing

Releases are published automatically when a tag is pushed to GitHub.

``` bash
# Set next version number
export RELEASE=x.x.x

# Create tags
git commit --allow-empty -m "Release $RELEASE"
git tag -a $RELEASE -m "Version $RELEASE"

# Push
git push upstream --tags
```




%package help
Summary:	Development documents and examples for amba-event-stream
Provides:	python3-amba-event-stream-doc
%description help
# amba-event-stream

[![PyPI][]][1]

  [PyPI]: https://img.shields.io/pypi/v/amba-event-stream
  [1]: https://pypi.org/project/amba-event-stream/

The Amba Analysis Streams package is used as a Kafka connection wrapper to abstract from infrastructure implementation details by providing functions to connect to Kafka and PostgreSQL. It defines the event model used in the streaming platform and provides base consumer and producer classes. The package is implemented as a python package that is hosted on pypi.org, and documented with mkdocs.

The consumer and producer are capable of running in multiple processes to allow for parallel processing to better utilize modern CPUs. Both have built in monitoring capabilities: a counter shared by all processes is updated for each processed event. A thread running a function every few seconds is checking the counter and resetting it. If no data is processed over a defined period of time (meaning multiple consecutive check function runs), the container is restarted automatically by closing all python processed. This heart beat function ensures that even unforeseeable errors, such as container crashes or blockings are resolved by restarting the container and providing a clean system state. 

more Information can be found [here](https://github.com/ambalytics/amba-analysis-streams/blob/fce56afbd7d8207b847c270ffa2c6e025dcc1950/docs/Recognition-of-Scholarly-Publication-Trends-based-on-Social-Data-Stream-Processing_Lukas-Jesche.pdf)

# Installation

``` bash
pip install amba-event-stream
```

# Releasing

Releases are published automatically when a tag is pushed to GitHub.

``` bash
# Set next version number
export RELEASE=x.x.x

# Create tags
git commit --allow-empty -m "Release $RELEASE"
git tag -a $RELEASE -m "Version $RELEASE"

# Push
git push upstream --tags
```




%prep
%autosetup -n amba-event-stream-1.0.3

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-amba-event-stream -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.3-1
- Package Spec generated