%global _empty_manifest_terminate_build 0
Name:		python-Flask-Uploads
Version:	0.2.1
Release:	1
Summary:	Flexible and efficient upload handling for Flask
License:	MIT
URL:		https://github.com/maxcountryman/flask-uploads
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/c9/a8/2c8e9ec04267d94b7852a374cebeb9a32d60f8cba83818af960e64fafbec/Flask-Uploads-0.2.1.tar.gz
BuildArch:	noarch


%description
Flask-Uploads provides flexible upload handling for Flask applications. It
lets you divide your uploads into sets that the application user can publish
separately.
Links
`````
* `documentation <http://flask-uploads.readthedocs.io/en/latest/>`_
* `development version
  <https://github.com/maxcountryman/flask-uploads>`_

%package -n python3-Flask-Uploads
Summary:	Flexible and efficient upload handling for Flask
Provides:	python-Flask-Uploads
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Flask-Uploads
Flask-Uploads provides flexible upload handling for Flask applications. It
lets you divide your uploads into sets that the application user can publish
separately.
Links
`````
* `documentation <http://flask-uploads.readthedocs.io/en/latest/>`_
* `development version
  <https://github.com/maxcountryman/flask-uploads>`_

%package help
Summary:	Development documents and examples for Flask-Uploads
Provides:	python3-Flask-Uploads-doc
%description help
Flask-Uploads provides flexible upload handling for Flask applications. It
lets you divide your uploads into sets that the application user can publish
separately.
Links
`````
* `documentation <http://flask-uploads.readthedocs.io/en/latest/>`_
* `development version
  <https://github.com/maxcountryman/flask-uploads>`_

%prep
%autosetup -n Flask-Uploads-0.2.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Flask-Uploads -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.1-1
- Package Spec generated