%global _empty_manifest_terminate_build 0
Name:		python-django-jsonfield-compat
Version:	0.4.4
Release:	1
Summary:	Compatability layer between django-jsonfield and Django's native JSONField
License:	MIT License
URL:		http://github.com/kbussell/django-jsonfield-compat/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/5c/b3/fd67cc1a09322e715322bfaf219c0693b5e0522659074ada49cf1c91d692/django-jsonfield-compat-0.4.4.tar.gz
BuildArch:	noarch


%description
![Travis Build Status](https://travis-ci.org/kbussell/django-jsonfield-compat.svg?branch=master)
[![Coverage Status](https://coveralls.io/repos/github/kbussell/django-jsonfield-compat/badge.svg?branch=master)](https://coveralls.io/github/kbussell/django-jsonfield-compat?branch=master)
Django 1.9 introduced first-class support for Postgresql's json type. 
Not everyone uses Postgresql, nor has upgraded to 1.9 yet, so a mixed ecosystem exists. 
Unfortunately, these two field types cannot be used together in the same project.
django-jsonfield-compat was created to be able to allow 3rd-party libraries to work in both worlds.
Requires Django >= 1.8

%package -n python3-django-jsonfield-compat
Summary:	Compatability layer between django-jsonfield and Django's native JSONField
Provides:	python-django-jsonfield-compat
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-django-jsonfield-compat
![Travis Build Status](https://travis-ci.org/kbussell/django-jsonfield-compat.svg?branch=master)
[![Coverage Status](https://coveralls.io/repos/github/kbussell/django-jsonfield-compat/badge.svg?branch=master)](https://coveralls.io/github/kbussell/django-jsonfield-compat?branch=master)
Django 1.9 introduced first-class support for Postgresql's json type. 
Not everyone uses Postgresql, nor has upgraded to 1.9 yet, so a mixed ecosystem exists. 
Unfortunately, these two field types cannot be used together in the same project.
django-jsonfield-compat was created to be able to allow 3rd-party libraries to work in both worlds.
Requires Django >= 1.8

%package help
Summary:	Development documents and examples for django-jsonfield-compat
Provides:	python3-django-jsonfield-compat-doc
%description help
![Travis Build Status](https://travis-ci.org/kbussell/django-jsonfield-compat.svg?branch=master)
[![Coverage Status](https://coveralls.io/repos/github/kbussell/django-jsonfield-compat/badge.svg?branch=master)](https://coveralls.io/github/kbussell/django-jsonfield-compat?branch=master)
Django 1.9 introduced first-class support for Postgresql's json type. 
Not everyone uses Postgresql, nor has upgraded to 1.9 yet, so a mixed ecosystem exists. 
Unfortunately, these two field types cannot be used together in the same project.
django-jsonfield-compat was created to be able to allow 3rd-party libraries to work in both worlds.
Requires Django >= 1.8

%prep
%autosetup -n django-jsonfield-compat-0.4.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-django-jsonfield-compat -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.4-1
- Package Spec generated