%global _empty_manifest_terminate_build 0
Name:		python-arthurai
Version:	3.25.0
Release:	1
Summary:	Arthur Python SDK
License:	MIT
URL:		https://pypi.org/project/arthurai/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/77/f0/4a74a876bfefda5ed4dc5d659fa083167b47254eb63ed1b1421d0d1c30d4/arthurai-3.25.0.tar.gz
BuildArch:	noarch

Requires:	python3-dataclasses-json
Requires:	python3-dill
Requires:	python3-docker
Requires:	python3-requests
Requires:	python3-requests-toolbelt
Requires:	python3-numpy
Requires:	python3-pandas
Requires:	python3-lime
Requires:	python3-pyarrow
Requires:	python3-pyjwt
Requires:	python3-dateutil
Requires:	python3-pytz
Requires:	python3-shap
Requires:	python3-shortuuid
Requires:	python3-seaborn
Requires:	python3-yaspin
Requires:	python3-dataclasses

%description
[//]: # (user-facing readme)

# Arthur SDK
[Arthur](https://www.arthur.ai/) is the platform for centralized monitoring of production models. 
We help data scientists, product owners, and business leaders accelerate model operations to optimize 
for accuracy, explainability, and fairness. As a model- and infrastructure-agnostic platform, Arthur 
adds a layer of intelligence to your AI stack and scales with your deployments.

Our SDK makes it easy to integrate your models with the Arthur platform. For help getting started or 
using the SDK, check out [our documentation](https://docs.arthur.ai/).


%package -n python3-arthurai
Summary:	Arthur Python SDK
Provides:	python-arthurai
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-arthurai
[//]: # (user-facing readme)

# Arthur SDK
[Arthur](https://www.arthur.ai/) is the platform for centralized monitoring of production models. 
We help data scientists, product owners, and business leaders accelerate model operations to optimize 
for accuracy, explainability, and fairness. As a model- and infrastructure-agnostic platform, Arthur 
adds a layer of intelligence to your AI stack and scales with your deployments.

Our SDK makes it easy to integrate your models with the Arthur platform. For help getting started or 
using the SDK, check out [our documentation](https://docs.arthur.ai/).


%package help
Summary:	Development documents and examples for arthurai
Provides:	python3-arthurai-doc
%description help
[//]: # (user-facing readme)

# Arthur SDK
[Arthur](https://www.arthur.ai/) is the platform for centralized monitoring of production models. 
We help data scientists, product owners, and business leaders accelerate model operations to optimize 
for accuracy, explainability, and fairness. As a model- and infrastructure-agnostic platform, Arthur 
adds a layer of intelligence to your AI stack and scales with your deployments.

Our SDK makes it easy to integrate your models with the Arthur platform. For help getting started or 
using the SDK, check out [our documentation](https://docs.arthur.ai/).


%prep
%autosetup -n arthurai-3.25.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-arthurai -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 3.25.0-1
- Package Spec generated