%global _empty_manifest_terminate_build 0
Name: python-watson-developer-cloud
Version: 2.10.1
Release: 1
Summary: Client library to use the IBM Watson Services
License: Apache 2.0
URL: https://github.com/watson-developer-cloud/python-sdk
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fc/a5/a89fc49bd82eb6ea569e45b43383c28cd51b5076f43010dcc3331c137ff5/watson-developer-cloud-2.10.1.tar.gz
BuildArch: noarch
%description
|Build Status| |Slack| |Latest Stable Version| |CLA assistant|
Python client library to quickly get started with the various `Watson
APIs `__ services.
Table of Contents
- `Before you begin <#before-you-begin>`__
- `Installation <#installation>`__
- `Examples <#examples>`__
- `Running in IBM Cloud <#running-in-ibm-cloud>`__
- `Authentication <#authentication>`__
- `Getting credentials <#getting-credentials>`__
- `IAM <#iam>`__
- `Username and password <#username-and-password>`__
- `Python version <#python-version>`__
- `Changes for v1.0 <#changes-for-v10>`__
- `Changes for v2.0 <#changes-for-v20>`__
- `Migration <#migration>`__
- `Configuring the http
client <#configuring-the-http-client-supported-from-v110>`__
- `Disable SSL certificate
verification <#disable-ssl-certificate-verification>`__
- `Sending request headers <#sending-request-headers>`__
- `Parsing HTTP response info <#parsing-http-response-info>`__
- `Dependencies <#dependencies>`__
- `License <#license>`__
- `Contributing <#contributing>`__
%package -n python3-watson-developer-cloud
Summary: Client library to use the IBM Watson Services
Provides: python-watson-developer-cloud
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-watson-developer-cloud
|Build Status| |Slack| |Latest Stable Version| |CLA assistant|
Python client library to quickly get started with the various `Watson
APIs `__ services.
Table of Contents
- `Before you begin <#before-you-begin>`__
- `Installation <#installation>`__
- `Examples <#examples>`__
- `Running in IBM Cloud <#running-in-ibm-cloud>`__
- `Authentication <#authentication>`__
- `Getting credentials <#getting-credentials>`__
- `IAM <#iam>`__
- `Username and password <#username-and-password>`__
- `Python version <#python-version>`__
- `Changes for v1.0 <#changes-for-v10>`__
- `Changes for v2.0 <#changes-for-v20>`__
- `Migration <#migration>`__
- `Configuring the http
client <#configuring-the-http-client-supported-from-v110>`__
- `Disable SSL certificate
verification <#disable-ssl-certificate-verification>`__
- `Sending request headers <#sending-request-headers>`__
- `Parsing HTTP response info <#parsing-http-response-info>`__
- `Dependencies <#dependencies>`__
- `License <#license>`__
- `Contributing <#contributing>`__
%package help
Summary: Development documents and examples for watson-developer-cloud
Provides: python3-watson-developer-cloud-doc
%description help
|Build Status| |Slack| |Latest Stable Version| |CLA assistant|
Python client library to quickly get started with the various `Watson
APIs `__ services.
Table of Contents
- `Before you begin <#before-you-begin>`__
- `Installation <#installation>`__
- `Examples <#examples>`__
- `Running in IBM Cloud <#running-in-ibm-cloud>`__
- `Authentication <#authentication>`__
- `Getting credentials <#getting-credentials>`__
- `IAM <#iam>`__
- `Username and password <#username-and-password>`__
- `Python version <#python-version>`__
- `Changes for v1.0 <#changes-for-v10>`__
- `Changes for v2.0 <#changes-for-v20>`__
- `Migration <#migration>`__
- `Configuring the http
client <#configuring-the-http-client-supported-from-v110>`__
- `Disable SSL certificate
verification <#disable-ssl-certificate-verification>`__
- `Sending request headers <#sending-request-headers>`__
- `Parsing HTTP response info <#parsing-http-response-info>`__
- `Dependencies <#dependencies>`__
- `License <#license>`__
- `Contributing <#contributing>`__
%prep
%autosetup -n watson-developer-cloud-2.10.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-watson-developer-cloud -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 2.10.1-1
- Package Spec generated