%global _empty_manifest_terminate_build 0
Name:		python-mkdocs-pdf-export-plugin
Version:	0.5.10
Release:	1
Summary:	An MkDocs plugin to export content pages as PDF files
License:	MIT
URL:		https://github.com/zhaoterryy/mkdocs-pdf-export-plugin/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/ae/3c/5dd22c24873cb8ddd9e8700c82e75322ce617505dd68df54cdb4dccc5140/mkdocs-pdf-export-plugin-0.5.10.tar.gz
BuildArch:	noarch

Requires:	python3-mkdocs
Requires:	python3-weasyprint
Requires:	python3-beautifulsoup4

%description
The pdf-export plugin will export all markdown pages in your MkDocs repository as PDF filesusing WeasyPrint. The exported documents support many advanced features missing in most otherPDF exports, such as a PDF Index and support for CSS paged media module.



%package -n python3-mkdocs-pdf-export-plugin
Summary:	An MkDocs plugin to export content pages as PDF files
Provides:	python-mkdocs-pdf-export-plugin
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-mkdocs-pdf-export-plugin
The pdf-export plugin will export all markdown pages in your MkDocs repository as PDF filesusing WeasyPrint. The exported documents support many advanced features missing in most otherPDF exports, such as a PDF Index and support for CSS paged media module.



%package help
Summary:	Development documents and examples for mkdocs-pdf-export-plugin
Provides:	python3-mkdocs-pdf-export-plugin-doc
%description help
The pdf-export plugin will export all markdown pages in your MkDocs repository as PDF filesusing WeasyPrint. The exported documents support many advanced features missing in most otherPDF exports, such as a PDF Index and support for CSS paged media module.



%prep
%autosetup -n mkdocs-pdf-export-plugin-0.5.10

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-mkdocs-pdf-export-plugin -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.10-1
- Package Spec generated