%global _empty_manifest_terminate_build 0
Name:		python-jupyter-lsp
Version:	2.1.0
Release:	1
Summary:	Multi-Language Server WebSocket proxy for Jupyter Notebook/Lab server
License:	BSD-3-Clause
URL:		https://pypi.org/project/jupyter-lsp/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/b3/41/d718b890bda70d4fd3b402efff7fc6847cf646fcae0d53abfac8cbc37b05/jupyter-lsp-2.1.0.tar.gz
BuildArch:	noarch

Requires:	python3-jupyter-server
Requires:	python3-importlib-metadata

%description
# jupyter-lsp

Multi-[Language Server][language-server] WebSocket proxy for your Jupyter
`notebook` or `lab` server. For Python 3.6+.

> See the parent of this repository,
> [jupyterlab-lsp](https://github.com/jupyter-lsp/jupyterlab-lsp) for the
> reference client implementation for [JupyterLab][].

# Language Servers

`jupyter-lsp` does not come with any Language Servers! Learn more about installing
and configuring [language servers][language servers docs]

[language-server]: https://microsoft.github.io/language-server-protocol/specification
[langserver]: https://langserver.org
[lsp-implementations]: https://microsoft.github.io/language-server-protocol/implementors/servers
[jupyter-lsp]: https://github.com/jupyter-lsp/jupyterlab-lsp.git
[jupyterlab]: https://github.com/jupyterlab/jupyterlab
[language servers docs]: https://jupyterlab-lsp.readthedocs.io/en/latest/Language%20Servers.html


%package -n python3-jupyter-lsp
Summary:	Multi-Language Server WebSocket proxy for Jupyter Notebook/Lab server
Provides:	python-jupyter-lsp
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-jupyter-lsp
# jupyter-lsp

Multi-[Language Server][language-server] WebSocket proxy for your Jupyter
`notebook` or `lab` server. For Python 3.6+.

> See the parent of this repository,
> [jupyterlab-lsp](https://github.com/jupyter-lsp/jupyterlab-lsp) for the
> reference client implementation for [JupyterLab][].

# Language Servers

`jupyter-lsp` does not come with any Language Servers! Learn more about installing
and configuring [language servers][language servers docs]

[language-server]: https://microsoft.github.io/language-server-protocol/specification
[langserver]: https://langserver.org
[lsp-implementations]: https://microsoft.github.io/language-server-protocol/implementors/servers
[jupyter-lsp]: https://github.com/jupyter-lsp/jupyterlab-lsp.git
[jupyterlab]: https://github.com/jupyterlab/jupyterlab
[language servers docs]: https://jupyterlab-lsp.readthedocs.io/en/latest/Language%20Servers.html


%package help
Summary:	Development documents and examples for jupyter-lsp
Provides:	python3-jupyter-lsp-doc
%description help
# jupyter-lsp

Multi-[Language Server][language-server] WebSocket proxy for your Jupyter
`notebook` or `lab` server. For Python 3.6+.

> See the parent of this repository,
> [jupyterlab-lsp](https://github.com/jupyter-lsp/jupyterlab-lsp) for the
> reference client implementation for [JupyterLab][].

# Language Servers

`jupyter-lsp` does not come with any Language Servers! Learn more about installing
and configuring [language servers][language servers docs]

[language-server]: https://microsoft.github.io/language-server-protocol/specification
[langserver]: https://langserver.org
[lsp-implementations]: https://microsoft.github.io/language-server-protocol/implementors/servers
[jupyter-lsp]: https://github.com/jupyter-lsp/jupyterlab-lsp.git
[jupyterlab]: https://github.com/jupyterlab/jupyterlab
[language servers docs]: https://jupyterlab-lsp.readthedocs.io/en/latest/Language%20Servers.html


%prep
%autosetup -n jupyter-lsp-2.1.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-jupyter-lsp -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.0-1
- Package Spec generated