%global _empty_manifest_terminate_build 0
Name: python-taxii2-client
Version: 2.3.0
Release: 1
Summary: TAXII 2 Client Library
License: BSD
URL: https://oasis-open.github.io/cti-documentation/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/75/0f/e556615441432c8a7e07db7695931dbb338e1e177a5faf428cd0eeaace64/taxii2-client-2.3.0.tar.gz
BuildArch: noarch
Requires: python3-requests
Requires: python3-six
Requires: python3-pytz
Requires: python3-sphinx
Requires: python3-sphinx-prompt
Requires: python3-coverage
Requires: python3-pytest
Requires: python3-pytest-cov
Requires: python3-responses
Requires: python3-tox
%description
NOTE: This is an `OASIS TC Open Repository
`_. See the
`Governance`_ section for more information.
cti-taxii-client is a minimal client implementation for the TAXII 2.X server.
It supports the following TAXII 2.X API services:
- Server Discovery
- Get API Root Information
- Get Status
- Get Collections
- Get a Collection
- Get Objects
- Add Objects
- Get an Object
- Delete an Object (2.1 only)
- Get Object Manifests
- Get Object Versions (2.1 only)
%package -n python3-taxii2-client
Summary: TAXII 2 Client Library
Provides: python-taxii2-client
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-taxii2-client
NOTE: This is an `OASIS TC Open Repository
`_. See the
`Governance`_ section for more information.
cti-taxii-client is a minimal client implementation for the TAXII 2.X server.
It supports the following TAXII 2.X API services:
- Server Discovery
- Get API Root Information
- Get Status
- Get Collections
- Get a Collection
- Get Objects
- Add Objects
- Get an Object
- Delete an Object (2.1 only)
- Get Object Manifests
- Get Object Versions (2.1 only)
%package help
Summary: Development documents and examples for taxii2-client
Provides: python3-taxii2-client-doc
%description help
NOTE: This is an `OASIS TC Open Repository
`_. See the
`Governance`_ section for more information.
cti-taxii-client is a minimal client implementation for the TAXII 2.X server.
It supports the following TAXII 2.X API services:
- Server Discovery
- Get API Root Information
- Get Status
- Get Collections
- Get a Collection
- Get Objects
- Add Objects
- Get an Object
- Delete an Object (2.1 only)
- Get Object Manifests
- Get Object Versions (2.1 only)
%prep
%autosetup -n taxii2-client-2.3.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-taxii2-client -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 2.3.0-1
- Package Spec generated