%global _empty_manifest_terminate_build 0
Name: python-pyhoma
Version: 0.7.4
Release: 1
Summary: (deprecated, use pyoverkiz instead). Async Python wrapper to interact with internal Somfy TaHoma API, or other OverKiz API's.
License: MIT
URL: https://github.com/iMicknl/python-tahoma-api
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/27/38/8f131765026ebfa7d183828848b2c8d26072e13739e57df58692ccb69b55/pyhoma-0.7.4.tar.gz
BuildArch: noarch
Requires: python3-aiohttp
Requires: python3-pyhumps
Requires: python3-backoff
Requires: python3-attrs
Requires: python3-boto3
Requires: python3-warrant
%description
# Deprecation Notice
**`pyhoma` is deprecated. Please use `pyoverkiz` 1.0 which is backwards compatible. See https://github.com/iMicknl/python-overkiz-api.**
# Somfy TaHoma / OverKiz
An updated and async version of the original [tahoma-api](https://github.com/philklei/tahoma-api) by [@philklei](https://github.com/philklei). The aim of this wrapper is to offer an easy to consume Python wrapper for the internal API's used by tahomalink.com, or other vendors which use the OverKiz platform.
Somfy TaHoma has an official API, which can be consumed via the [Somfy-open-api](https://github.com/tetienne/somfy-open-api). Unfortunately only a few device classes are supported via the official API, thus the need for this wrapper.
This package is written for the Home Assistant [ha-tahoma](https://github.com/iMicknl/ha-tahoma) integration, but could be used by any Python project interacting with Somfy TaHoma devices.
## Installation
```bash
pip install pyhoma
```
## Getting started
```python
import asyncio
import time
from pyhoma.const import SUPPORTED_SERVERS
from pyhoma.client import TahomaClient
USERNAME = ""
PASSWORD = ""
async def main() -> None:
async with TahomaClient(USERNAME, PASSWORD, server=SUPPORTED_SERVERS["somfy_europe"]) as client:
try:
await client.login()
except Exception as exception: # pylint: disable=broad-except
print(exception)
return
devices = await client.get_devices()
for device in devices:
print(f"{device.label} ({device.id}) - {device.controllable_name}")
print(f"{device.widget} - {device.ui_class}")
while True:
events = await client.fetch_events()
print(events)
time.sleep(2)
asyncio.run(main())
```
## Development
### Installation
- For Linux, install [pyenv](https://github.com/pyenv/pyenv) using [pyenv-installer](https://github.com/pyenv/pyenv-installer)
- For MacOS, run `brew install pyenv`
- Don't forget to update your `.bashrc` file (or similar):
```
export PATH="~/.pyenv/bin:$PATH"
eval "$(pyenv init -)"
```
- Install the required [dependencies](https://github.com/pyenv/pyenv/wiki#suggested-build-environment)
- Install [poetry](https://python-poetry.org): `curl -sSL https://raw.githubusercontent.com/python-poetry/poetry/master/get-poetry.py | python`
- Clone this repository
- `cd python-tahoma-api`
- Install the required Python version: `pyenv install`
- Init the project: `poetry install`
- Run `poetry run pre-commit install`
## PyCharm
As IDE you can use [PyCharm](https://www.jetbrains.com/pycharm/).
Using snap, run `snap install pycharm --classic` to install it.
For MacOS, run `brew cask install pycharm-ce`
Once launched, don't create a new project, but open an existing one and select the **python-tahoma-api** folder.
Go to _File | Settings | Project: nre-tag | Project Interpreter_. Your interpreter must look like `/python-tahoma-api/.venv/bin/python`
%package -n python3-pyhoma
Summary: (deprecated, use pyoverkiz instead). Async Python wrapper to interact with internal Somfy TaHoma API, or other OverKiz API's.
Provides: python-pyhoma
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-pyhoma
# Deprecation Notice
**`pyhoma` is deprecated. Please use `pyoverkiz` 1.0 which is backwards compatible. See https://github.com/iMicknl/python-overkiz-api.**
# Somfy TaHoma / OverKiz
An updated and async version of the original [tahoma-api](https://github.com/philklei/tahoma-api) by [@philklei](https://github.com/philklei). The aim of this wrapper is to offer an easy to consume Python wrapper for the internal API's used by tahomalink.com, or other vendors which use the OverKiz platform.
Somfy TaHoma has an official API, which can be consumed via the [Somfy-open-api](https://github.com/tetienne/somfy-open-api). Unfortunately only a few device classes are supported via the official API, thus the need for this wrapper.
This package is written for the Home Assistant [ha-tahoma](https://github.com/iMicknl/ha-tahoma) integration, but could be used by any Python project interacting with Somfy TaHoma devices.
## Installation
```bash
pip install pyhoma
```
## Getting started
```python
import asyncio
import time
from pyhoma.const import SUPPORTED_SERVERS
from pyhoma.client import TahomaClient
USERNAME = ""
PASSWORD = ""
async def main() -> None:
async with TahomaClient(USERNAME, PASSWORD, server=SUPPORTED_SERVERS["somfy_europe"]) as client:
try:
await client.login()
except Exception as exception: # pylint: disable=broad-except
print(exception)
return
devices = await client.get_devices()
for device in devices:
print(f"{device.label} ({device.id}) - {device.controllable_name}")
print(f"{device.widget} - {device.ui_class}")
while True:
events = await client.fetch_events()
print(events)
time.sleep(2)
asyncio.run(main())
```
## Development
### Installation
- For Linux, install [pyenv](https://github.com/pyenv/pyenv) using [pyenv-installer](https://github.com/pyenv/pyenv-installer)
- For MacOS, run `brew install pyenv`
- Don't forget to update your `.bashrc` file (or similar):
```
export PATH="~/.pyenv/bin:$PATH"
eval "$(pyenv init -)"
```
- Install the required [dependencies](https://github.com/pyenv/pyenv/wiki#suggested-build-environment)
- Install [poetry](https://python-poetry.org): `curl -sSL https://raw.githubusercontent.com/python-poetry/poetry/master/get-poetry.py | python`
- Clone this repository
- `cd python-tahoma-api`
- Install the required Python version: `pyenv install`
- Init the project: `poetry install`
- Run `poetry run pre-commit install`
## PyCharm
As IDE you can use [PyCharm](https://www.jetbrains.com/pycharm/).
Using snap, run `snap install pycharm --classic` to install it.
For MacOS, run `brew cask install pycharm-ce`
Once launched, don't create a new project, but open an existing one and select the **python-tahoma-api** folder.
Go to _File | Settings | Project: nre-tag | Project Interpreter_. Your interpreter must look like `/python-tahoma-api/.venv/bin/python`
%package help
Summary: Development documents and examples for pyhoma
Provides: python3-pyhoma-doc
%description help
# Deprecation Notice
**`pyhoma` is deprecated. Please use `pyoverkiz` 1.0 which is backwards compatible. See https://github.com/iMicknl/python-overkiz-api.**
# Somfy TaHoma / OverKiz
An updated and async version of the original [tahoma-api](https://github.com/philklei/tahoma-api) by [@philklei](https://github.com/philklei). The aim of this wrapper is to offer an easy to consume Python wrapper for the internal API's used by tahomalink.com, or other vendors which use the OverKiz platform.
Somfy TaHoma has an official API, which can be consumed via the [Somfy-open-api](https://github.com/tetienne/somfy-open-api). Unfortunately only a few device classes are supported via the official API, thus the need for this wrapper.
This package is written for the Home Assistant [ha-tahoma](https://github.com/iMicknl/ha-tahoma) integration, but could be used by any Python project interacting with Somfy TaHoma devices.
## Installation
```bash
pip install pyhoma
```
## Getting started
```python
import asyncio
import time
from pyhoma.const import SUPPORTED_SERVERS
from pyhoma.client import TahomaClient
USERNAME = ""
PASSWORD = ""
async def main() -> None:
async with TahomaClient(USERNAME, PASSWORD, server=SUPPORTED_SERVERS["somfy_europe"]) as client:
try:
await client.login()
except Exception as exception: # pylint: disable=broad-except
print(exception)
return
devices = await client.get_devices()
for device in devices:
print(f"{device.label} ({device.id}) - {device.controllable_name}")
print(f"{device.widget} - {device.ui_class}")
while True:
events = await client.fetch_events()
print(events)
time.sleep(2)
asyncio.run(main())
```
## Development
### Installation
- For Linux, install [pyenv](https://github.com/pyenv/pyenv) using [pyenv-installer](https://github.com/pyenv/pyenv-installer)
- For MacOS, run `brew install pyenv`
- Don't forget to update your `.bashrc` file (or similar):
```
export PATH="~/.pyenv/bin:$PATH"
eval "$(pyenv init -)"
```
- Install the required [dependencies](https://github.com/pyenv/pyenv/wiki#suggested-build-environment)
- Install [poetry](https://python-poetry.org): `curl -sSL https://raw.githubusercontent.com/python-poetry/poetry/master/get-poetry.py | python`
- Clone this repository
- `cd python-tahoma-api`
- Install the required Python version: `pyenv install`
- Init the project: `poetry install`
- Run `poetry run pre-commit install`
## PyCharm
As IDE you can use [PyCharm](https://www.jetbrains.com/pycharm/).
Using snap, run `snap install pycharm --classic` to install it.
For MacOS, run `brew cask install pycharm-ce`
Once launched, don't create a new project, but open an existing one and select the **python-tahoma-api** folder.
Go to _File | Settings | Project: nre-tag | Project Interpreter_. Your interpreter must look like `/python-tahoma-api/.venv/bin/python`
%prep
%autosetup -n pyhoma-0.7.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-pyhoma -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Tue Apr 25 2023 Python_Bot - 0.7.4-1
- Package Spec generated