%global _empty_manifest_terminate_build 0
Name:		python-matterhook
Version:	0.2
Release:	1
Summary:	Interact with Mattermost incoming webhooks easily.
License:	BSD
URL:		https://github.com/numberly/matterhook
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/7a/07/c69624a4e1cc08ca0bb61da314c25ed0d39c1be3bbf452a810ae20d9d538/matterhook-0.2.tar.gz
BuildArch:	noarch


%description
- Login to your Mattermost team site and go to **Account Settings -> Integrations**
- Next to **Incoming Webhooks** click **Edit**
- Select the channel or private group to receive webhook payloads, then click **Add** to create the webhook
- The API key is the last part of the URL (eg: u2x8rkfugj8zbqby9pw3huqnyc)

%package -n python3-matterhook
Summary:	Interact with Mattermost incoming webhooks easily.
Provides:	python-matterhook
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-matterhook
- Login to your Mattermost team site and go to **Account Settings -> Integrations**
- Next to **Incoming Webhooks** click **Edit**
- Select the channel or private group to receive webhook payloads, then click **Add** to create the webhook
- The API key is the last part of the URL (eg: u2x8rkfugj8zbqby9pw3huqnyc)

%package help
Summary:	Development documents and examples for matterhook
Provides:	python3-matterhook-doc
%description help
- Login to your Mattermost team site and go to **Account Settings -> Integrations**
- Next to **Incoming Webhooks** click **Edit**
- Select the channel or private group to receive webhook payloads, then click **Add** to create the webhook
- The API key is the last part of the URL (eg: u2x8rkfugj8zbqby9pw3huqnyc)

%prep
%autosetup -n matterhook-0.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-matterhook -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2-1
- Package Spec generated