%global _empty_manifest_terminate_build 0
Name:		python-django-agent-trust
Version:	1.0.4
Release:	1
Summary:	A framework for managing agent trust, such as public vs. private computers.
License:	BSD
URL:		https://github.com/django-otp/django-agent-trust
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/47/7d/13544567b3a872226ac57b6befb0dc058887b8c27c52ba9ed463062f7451/django-agent-trust-1.0.4.tar.gz
BuildArch:	noarch

Requires:	python3-django

%description
.. image:: https://img.shields.io/pypi/v/django-agent-trust?color=blue
   :target: https://pypi.org/project/django-agent-trust/
   :alt: PyPI
.. image:: https://img.shields.io/readthedocs/django-agent-trust-official
   :target: https://django-agent-trust-official.readthedocs.io/
   :alt: Documentation
.. image:: https://img.shields.io/badge/github-django--agent--trust-green
   :target: https://github.com/django-otp/django-agent-trust
   :alt: Source

This project has tools for managing trusted user agents. For example, you might
allow the user to indicate whether they are using a public or private computer
and implement different policies for each. Or you might be using a two-factor
authentication scheme, allowing the users to bypass the second factor on
machines that they designate as trusted. This uses Django's signed cookie
facility and operates independently of sessions.

Short list of features:

    - ``request.agent.is_trusted`` tells you whether the request came from a
      trusted agent.
    - APIs to trust or revoke the agent that made a given request.
    - Global, per-user, and per-agent settings can set the duration of agent
      trust as well as an inactivity timeout.
    - Supports session-scoped agent trust for consistency of authorization
      policies.
    - Revoke all of a user's previously trusted agents at any time.

The mechanisms by which a user is allowed to designate trusted agents is left
entirely to clients of this library. For an application of this API using
one-time passwords, see `django-otp-agents
<https://pypi.org/project/django-otp-agents>`_, part of the `django-otp
<https://pypi.org/project/django-otp>`_ suite.




%package -n python3-django-agent-trust
Summary:	A framework for managing agent trust, such as public vs. private computers.
Provides:	python-django-agent-trust
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-django-agent-trust
.. image:: https://img.shields.io/pypi/v/django-agent-trust?color=blue
   :target: https://pypi.org/project/django-agent-trust/
   :alt: PyPI
.. image:: https://img.shields.io/readthedocs/django-agent-trust-official
   :target: https://django-agent-trust-official.readthedocs.io/
   :alt: Documentation
.. image:: https://img.shields.io/badge/github-django--agent--trust-green
   :target: https://github.com/django-otp/django-agent-trust
   :alt: Source

This project has tools for managing trusted user agents. For example, you might
allow the user to indicate whether they are using a public or private computer
and implement different policies for each. Or you might be using a two-factor
authentication scheme, allowing the users to bypass the second factor on
machines that they designate as trusted. This uses Django's signed cookie
facility and operates independently of sessions.

Short list of features:

    - ``request.agent.is_trusted`` tells you whether the request came from a
      trusted agent.
    - APIs to trust or revoke the agent that made a given request.
    - Global, per-user, and per-agent settings can set the duration of agent
      trust as well as an inactivity timeout.
    - Supports session-scoped agent trust for consistency of authorization
      policies.
    - Revoke all of a user's previously trusted agents at any time.

The mechanisms by which a user is allowed to designate trusted agents is left
entirely to clients of this library. For an application of this API using
one-time passwords, see `django-otp-agents
<https://pypi.org/project/django-otp-agents>`_, part of the `django-otp
<https://pypi.org/project/django-otp>`_ suite.




%package help
Summary:	Development documents and examples for django-agent-trust
Provides:	python3-django-agent-trust-doc
%description help
.. image:: https://img.shields.io/pypi/v/django-agent-trust?color=blue
   :target: https://pypi.org/project/django-agent-trust/
   :alt: PyPI
.. image:: https://img.shields.io/readthedocs/django-agent-trust-official
   :target: https://django-agent-trust-official.readthedocs.io/
   :alt: Documentation
.. image:: https://img.shields.io/badge/github-django--agent--trust-green
   :target: https://github.com/django-otp/django-agent-trust
   :alt: Source

This project has tools for managing trusted user agents. For example, you might
allow the user to indicate whether they are using a public or private computer
and implement different policies for each. Or you might be using a two-factor
authentication scheme, allowing the users to bypass the second factor on
machines that they designate as trusted. This uses Django's signed cookie
facility and operates independently of sessions.

Short list of features:

    - ``request.agent.is_trusted`` tells you whether the request came from a
      trusted agent.
    - APIs to trust or revoke the agent that made a given request.
    - Global, per-user, and per-agent settings can set the duration of agent
      trust as well as an inactivity timeout.
    - Supports session-scoped agent trust for consistency of authorization
      policies.
    - Revoke all of a user's previously trusted agents at any time.

The mechanisms by which a user is allowed to designate trusted agents is left
entirely to clients of this library. For an application of this API using
one-time passwords, see `django-otp-agents
<https://pypi.org/project/django-otp-agents>`_, part of the `django-otp
<https://pypi.org/project/django-otp>`_ suite.




%prep
%autosetup -n django-agent-trust-1.0.4

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-django-agent-trust -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.4-1
- Package Spec generated