%global _empty_manifest_terminate_build 0
Name:		python-autohooks-plugin-black
Version:	23.4.0
Release:	1
Summary:	An autohooks plugin for python code formatting via black
License:	GPL-3.0-or-later
URL:		https://github.com/greenbone/autohooks-plugin-black
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/43/b2/e023aa54f6d6f64c8bf1e3ed616fbd153eb87a44a40a8dfeb2901163c4c2/autohooks_plugin_black-23.4.0.tar.gz
BuildArch:	noarch

Requires:	python3-black
Requires:	python3-autohooks

%description
![Greenbone Logo](https://www.greenbone.net/wp-content/uploads/gb_new-logo_horizontal_rgb_small.png)

# autohooks-plugin-black

[![PyPI release](https://img.shields.io/pypi/v/autohooks-plugin-black.svg)](https://pypi.org/project/autohooks-plugin-black/)

An [autohooks](https://github.com/greenbone/autohooks) plugin for python code
formatting via [black](https://github.com/ambv/black).

## Installation

### Install using pip

You can install the latest stable release of autohooks-plugin-black from the
Python Package Index using [pip](https://pip.pypa.io/):

    pip install autohooks-plugin-black

Note the `pip` refers to the Python 3 package manager. In a environment where
Python 2 is also available the correct command may be `pip3`.

### Install using poetry

It is highly encouraged to use [poetry](https://python-poetry.org) for
maintaining your project's dependencies. Normally autohooks-plugin-black is
installed as a development dependency.

    poetry add --dev autohooks-plugin-black

## Usage

To activate the black autohooks plugin please add the following setting to your
*pyproject.toml* file.

```toml
[tool.autohooks]
pre-commit = ["autohooks.plugins.black"]
```

By default, autohooks plugin black checks all files with a *.py* ending. If only
files in a sub-directory or files with different endings should be formatted,
just add the following setting:

```toml
[tool.autohooks]
pre-commit = ["autohooks.plugins.black"]

[tool.autohooks.plugins.black]
include = ['foo/*.py', '*.foo']
```

Also by default, autohooks plugin black executes black with the `-q` argument.
If e.g. the generated patch should be shown the following setting can be used:

```toml
[tool.autohooks]
pre-commit = ["autohooks.plugins.black"]

[tool.autohooks.plugins.black]
arguments = ["-q", "--diff"]
```

## Maintainer

This project is maintained by [Greenbone AG](https://www.greenbone.net/).

## Contributing

Your contributions are highly appreciated. Please
[create a pull request](https://github.com/greenbone/autohooks-plugin-black/pulls)
on GitHub. Bigger changes need to be discussed with the development team via the
[issues section at GitHub](https://github.com/greenbone/autohooks-plugin-black/issues)
first.

## License

Copyright (C) 2019 [Greenbone AG](https://www.greenbone.net/)

Licensed under the [GNU General Public License v3.0 or later](LICENSE).


%package -n python3-autohooks-plugin-black
Summary:	An autohooks plugin for python code formatting via black
Provides:	python-autohooks-plugin-black
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-autohooks-plugin-black
![Greenbone Logo](https://www.greenbone.net/wp-content/uploads/gb_new-logo_horizontal_rgb_small.png)

# autohooks-plugin-black

[![PyPI release](https://img.shields.io/pypi/v/autohooks-plugin-black.svg)](https://pypi.org/project/autohooks-plugin-black/)

An [autohooks](https://github.com/greenbone/autohooks) plugin for python code
formatting via [black](https://github.com/ambv/black).

## Installation

### Install using pip

You can install the latest stable release of autohooks-plugin-black from the
Python Package Index using [pip](https://pip.pypa.io/):

    pip install autohooks-plugin-black

Note the `pip` refers to the Python 3 package manager. In a environment where
Python 2 is also available the correct command may be `pip3`.

### Install using poetry

It is highly encouraged to use [poetry](https://python-poetry.org) for
maintaining your project's dependencies. Normally autohooks-plugin-black is
installed as a development dependency.

    poetry add --dev autohooks-plugin-black

## Usage

To activate the black autohooks plugin please add the following setting to your
*pyproject.toml* file.

```toml
[tool.autohooks]
pre-commit = ["autohooks.plugins.black"]
```

By default, autohooks plugin black checks all files with a *.py* ending. If only
files in a sub-directory or files with different endings should be formatted,
just add the following setting:

```toml
[tool.autohooks]
pre-commit = ["autohooks.plugins.black"]

[tool.autohooks.plugins.black]
include = ['foo/*.py', '*.foo']
```

Also by default, autohooks plugin black executes black with the `-q` argument.
If e.g. the generated patch should be shown the following setting can be used:

```toml
[tool.autohooks]
pre-commit = ["autohooks.plugins.black"]

[tool.autohooks.plugins.black]
arguments = ["-q", "--diff"]
```

## Maintainer

This project is maintained by [Greenbone AG](https://www.greenbone.net/).

## Contributing

Your contributions are highly appreciated. Please
[create a pull request](https://github.com/greenbone/autohooks-plugin-black/pulls)
on GitHub. Bigger changes need to be discussed with the development team via the
[issues section at GitHub](https://github.com/greenbone/autohooks-plugin-black/issues)
first.

## License

Copyright (C) 2019 [Greenbone AG](https://www.greenbone.net/)

Licensed under the [GNU General Public License v3.0 or later](LICENSE).


%package help
Summary:	Development documents and examples for autohooks-plugin-black
Provides:	python3-autohooks-plugin-black-doc
%description help
![Greenbone Logo](https://www.greenbone.net/wp-content/uploads/gb_new-logo_horizontal_rgb_small.png)

# autohooks-plugin-black

[![PyPI release](https://img.shields.io/pypi/v/autohooks-plugin-black.svg)](https://pypi.org/project/autohooks-plugin-black/)

An [autohooks](https://github.com/greenbone/autohooks) plugin for python code
formatting via [black](https://github.com/ambv/black).

## Installation

### Install using pip

You can install the latest stable release of autohooks-plugin-black from the
Python Package Index using [pip](https://pip.pypa.io/):

    pip install autohooks-plugin-black

Note the `pip` refers to the Python 3 package manager. In a environment where
Python 2 is also available the correct command may be `pip3`.

### Install using poetry

It is highly encouraged to use [poetry](https://python-poetry.org) for
maintaining your project's dependencies. Normally autohooks-plugin-black is
installed as a development dependency.

    poetry add --dev autohooks-plugin-black

## Usage

To activate the black autohooks plugin please add the following setting to your
*pyproject.toml* file.

```toml
[tool.autohooks]
pre-commit = ["autohooks.plugins.black"]
```

By default, autohooks plugin black checks all files with a *.py* ending. If only
files in a sub-directory or files with different endings should be formatted,
just add the following setting:

```toml
[tool.autohooks]
pre-commit = ["autohooks.plugins.black"]

[tool.autohooks.plugins.black]
include = ['foo/*.py', '*.foo']
```

Also by default, autohooks plugin black executes black with the `-q` argument.
If e.g. the generated patch should be shown the following setting can be used:

```toml
[tool.autohooks]
pre-commit = ["autohooks.plugins.black"]

[tool.autohooks.plugins.black]
arguments = ["-q", "--diff"]
```

## Maintainer

This project is maintained by [Greenbone AG](https://www.greenbone.net/).

## Contributing

Your contributions are highly appreciated. Please
[create a pull request](https://github.com/greenbone/autohooks-plugin-black/pulls)
on GitHub. Bigger changes need to be discussed with the development team via the
[issues section at GitHub](https://github.com/greenbone/autohooks-plugin-black/issues)
first.

## License

Copyright (C) 2019 [Greenbone AG](https://www.greenbone.net/)

Licensed under the [GNU General Public License v3.0 or later](LICENSE).


%prep
%autosetup -n autohooks-plugin-black-23.4.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-autohooks-plugin-black -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 23.4.0-1
- Package Spec generated