%global _empty_manifest_terminate_build 0
Name:		python-dicom2nifti
Version:	2.4.8
Release:	1
Summary:	package for converting dicom files to nifti
License:	MIT
URL:		https://github.com/icometrix/dicom2nifti
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/7f/b6/55b0e0985fcdc121035061a942149af3a485a3612ee65ec334f1852b141b/dicom2nifti-2.4.8.tar.gz
BuildArch:	noarch

Requires:	python3-nibabel
Requires:	python3-numpy
Requires:	python3-scipy
Requires:	python3-pydicom
Requires:	python3-gdcm

%description

With this package you can convert dicom images to nifti files.
There is support for most anatomical CT and MR data.
For MR specifically there is support for most 4D data (like DTI and fMRI)


%package -n python3-dicom2nifti
Summary:	package for converting dicom files to nifti
Provides:	python-dicom2nifti
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-dicom2nifti

With this package you can convert dicom images to nifti files.
There is support for most anatomical CT and MR data.
For MR specifically there is support for most 4D data (like DTI and fMRI)


%package help
Summary:	Development documents and examples for dicom2nifti
Provides:	python3-dicom2nifti-doc
%description help

With this package you can convert dicom images to nifti files.
There is support for most anatomical CT and MR data.
For MR specifically there is support for most 4D data (like DTI and fMRI)


%prep
%autosetup -n dicom2nifti-2.4.8

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-dicom2nifti -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Tue Apr 25 2023 Python_Bot <Python_Bot@openeuler.org> - 2.4.8-1
- Package Spec generated