%global _empty_manifest_terminate_build 0
Name: python-cypcap
Version: 0.4.2
Release: 1
Summary: A Cython based binding for modern libpcap
License: BSD-3-Clause
URL: https://github.com/segevfiner/cypcap
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9b/41/44a4363b4a6678d12f7d0cba66f4bcaf4625228a736fb28319517fc86d96/cypcap-0.4.2.tar.gz
Requires: python3-cython
Requires: python3-sphinx
Requires: python3-pytest
Requires: python3-dpkt
Requires: python3-netifaces
%description
This package is a Cython based binding for modern libpcap versions, for Python 3.6+, attempting to
be more complete than existing and poorly maintained packages.
`Documentation `_
%package -n python3-cypcap
Summary: A Cython based binding for modern libpcap
Provides: python-cypcap
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-cypcap
This package is a Cython based binding for modern libpcap versions, for Python 3.6+, attempting to
be more complete than existing and poorly maintained packages.
`Documentation `_
%package help
Summary: Development documents and examples for cypcap
Provides: python3-cypcap-doc
%description help
This package is a Cython based binding for modern libpcap versions, for Python 3.6+, attempting to
be more complete than existing and poorly maintained packages.
`Documentation `_
%prep
%autosetup -n cypcap-0.4.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-cypcap -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.4.2-1
- Package Spec generated