%global _empty_manifest_terminate_build 0
Name:		python-gradient
Version:	2.0.6
Release:	1
Summary:	Paperspace Python
License:	ISC License (ISCL)
URL:		https://github.com/paperspace/gradient-cli
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/41/80/ca5a5db9522fb6b16a37bf6cb126dee78ce6808b57e338f4ca3281757faa/gradient-2.0.6.tar.gz
BuildArch:	noarch

Requires:	python3-requests[security]
Requires:	python3-six
Requires:	python3-click
Requires:	python3-terminaltables
Requires:	python3-click-didyoumean
Requires:	python3-click-help-colors
Requires:	python3-click-completion
Requires:	python3-colorama
Requires:	python3-requests-toolbelt
Requires:	python3-progressbar2
Requires:	python3-halo
Requires:	python3-marshmallow
Requires:	python3-attrs
Requires:	python3-PyYAML
Requires:	python3-dateutil
Requires:	python3-websocket-client
Requires:	python3-gradient-utils
Requires:	python3-gql[requests]
Requires:	python3-windows-curses
Requires:	python3-tox
Requires:	python3-pytest
Requires:	python3-mock
Requires:	python3-twine
Requires:	python3-sphinx
Requires:	python3-sphinx-click
Requires:	python3-recommonmark
Requires:	python3-pathlib2

%description
![PyPI](https://img.shields.io/pypi/v/gradient)
[![Downloads](https://pepy.tech/badge/gradient)](https://pepy.tech/project/gradient)
<br>
**Get started:** [Create Account](https://console.paperspace.com/signup?gradient=true) • [Install CLI](https://docs.paperspace.com/gradient/cli/) • [Tutorials](https://docs.paperspace.com/gradient/tutorials/) • [Docs](https://docs.paperspace.com/gradient)
**Resources:** [Website](https://gradient.run/) • [Blog](https://blog.paperspace.com/) • [Support](https://docs.paperspace.com/contact-support/) • [Contact Sales](https://paperspace.com/contact-sales)
<br>
Gradient is an an end-to-end MLOps platform that enables individuals and organizations to quickly develop, train, and deploy Deep Learning models.  The Gradient software stack runs on any infrastructure e.g. AWS, GCP, on-premise and low-cost [Paperspace GPUs](https://docs.paperspace.com/gradient/machines/).  Leverage automatic versioning, distributed training, built-in graphs & metrics, hyperparameter search, GradientCI, 1-click Jupyter Notebooks, our Python SDK, and more. 
Key components:
* [Notebooks](https://gradient.run/notebooks): 1-click Jupyter Notebooks.
* [Workflows](https://gradient.run/workflows): Train models at scale with composable actions. 
* [Inference](https://gradient.run/deployments): Deploy models as API endpoints.
Gradient supports any ML/DL framework (TensorFlow, PyTorch, XGBoost, etc).
<hr>
See [releasenotes.md](https://github.com/Paperspace/gradient-cli/blob/master/releasenotes.md) for details on the current release, as well as release history.
<br>

%package -n python3-gradient
Summary:	Paperspace Python
Provides:	python-gradient
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-gradient
![PyPI](https://img.shields.io/pypi/v/gradient)
[![Downloads](https://pepy.tech/badge/gradient)](https://pepy.tech/project/gradient)
<br>
**Get started:** [Create Account](https://console.paperspace.com/signup?gradient=true) • [Install CLI](https://docs.paperspace.com/gradient/cli/) • [Tutorials](https://docs.paperspace.com/gradient/tutorials/) • [Docs](https://docs.paperspace.com/gradient)
**Resources:** [Website](https://gradient.run/) • [Blog](https://blog.paperspace.com/) • [Support](https://docs.paperspace.com/contact-support/) • [Contact Sales](https://paperspace.com/contact-sales)
<br>
Gradient is an an end-to-end MLOps platform that enables individuals and organizations to quickly develop, train, and deploy Deep Learning models.  The Gradient software stack runs on any infrastructure e.g. AWS, GCP, on-premise and low-cost [Paperspace GPUs](https://docs.paperspace.com/gradient/machines/).  Leverage automatic versioning, distributed training, built-in graphs & metrics, hyperparameter search, GradientCI, 1-click Jupyter Notebooks, our Python SDK, and more. 
Key components:
* [Notebooks](https://gradient.run/notebooks): 1-click Jupyter Notebooks.
* [Workflows](https://gradient.run/workflows): Train models at scale with composable actions. 
* [Inference](https://gradient.run/deployments): Deploy models as API endpoints.
Gradient supports any ML/DL framework (TensorFlow, PyTorch, XGBoost, etc).
<hr>
See [releasenotes.md](https://github.com/Paperspace/gradient-cli/blob/master/releasenotes.md) for details on the current release, as well as release history.
<br>

%package help
Summary:	Development documents and examples for gradient
Provides:	python3-gradient-doc
%description help
![PyPI](https://img.shields.io/pypi/v/gradient)
[![Downloads](https://pepy.tech/badge/gradient)](https://pepy.tech/project/gradient)
<br>
**Get started:** [Create Account](https://console.paperspace.com/signup?gradient=true) • [Install CLI](https://docs.paperspace.com/gradient/cli/) • [Tutorials](https://docs.paperspace.com/gradient/tutorials/) • [Docs](https://docs.paperspace.com/gradient)
**Resources:** [Website](https://gradient.run/) • [Blog](https://blog.paperspace.com/) • [Support](https://docs.paperspace.com/contact-support/) • [Contact Sales](https://paperspace.com/contact-sales)
<br>
Gradient is an an end-to-end MLOps platform that enables individuals and organizations to quickly develop, train, and deploy Deep Learning models.  The Gradient software stack runs on any infrastructure e.g. AWS, GCP, on-premise and low-cost [Paperspace GPUs](https://docs.paperspace.com/gradient/machines/).  Leverage automatic versioning, distributed training, built-in graphs & metrics, hyperparameter search, GradientCI, 1-click Jupyter Notebooks, our Python SDK, and more. 
Key components:
* [Notebooks](https://gradient.run/notebooks): 1-click Jupyter Notebooks.
* [Workflows](https://gradient.run/workflows): Train models at scale with composable actions. 
* [Inference](https://gradient.run/deployments): Deploy models as API endpoints.
Gradient supports any ML/DL framework (TensorFlow, PyTorch, XGBoost, etc).
<hr>
See [releasenotes.md](https://github.com/Paperspace/gradient-cli/blob/master/releasenotes.md) for details on the current release, as well as release history.
<br>

%prep
%autosetup -n gradient-2.0.6

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-gradient -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.6-1
- Package Spec generated