%global _empty_manifest_terminate_build 0
Name:		python-mantarray-waveform-analysis
Version:	1.2.0
Release:	1
Summary:	Tools for analyzing waveforms produced by a Mantarray Instrument
License:	MIT
URL:		https://github.com/CuriBio/mantarray-waveform-analysis
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/06/57/fe1fbb3dc8f0b7f002614ffbac6ecfce3f862ca7588c386dc45cdafd067b/mantarray_waveform_analysis-1.2.0.tar.gz

Requires:	python3-numpy
Requires:	python3-scipy
Requires:	python3-nptyping
Requires:	python3-attrs

%description


%package -n python3-mantarray-waveform-analysis
Summary:	Tools for analyzing waveforms produced by a Mantarray Instrument
Provides:	python-mantarray-waveform-analysis
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
BuildRequires:	python3-cffi
BuildRequires:	gcc
BuildRequires:	gdb
%description -n python3-mantarray-waveform-analysis


%package help
Summary:	Development documents and examples for mantarray-waveform-analysis
Provides:	python3-mantarray-waveform-analysis-doc
%description help


%prep
%autosetup -n mantarray-waveform-analysis-1.2.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-mantarray-waveform-analysis -f filelist.lst
%dir %{python3_sitearch}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.0-1
- Package Spec generated