%global _empty_manifest_terminate_build 0
Name: python-volmdlr
Version: 0.10.0
Release: 1
Summary: A volume modeler computation-oriented. Include rendering bindings.
License: Creative Commons Attribution-Share Alike license
URL: https://github.com/Dessia-tech/volmdlr
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/57/f3/e6c24d0d5272e4a70941511b8391f9a81112ec45011a9c687a35832cd7bf/volmdlr-0.10.0.tar.gz
Requires: python3-packaging
Requires: python3-dessia-common
Requires: python3-Cython
Requires: python3-numpy
Requires: python3-matplotlib
Requires: python3-scipy
Requires: python3-geomdl
Requires: python3-jsonschema
Requires: python3-networkx
Requires: python3-triangle
Requires: python3-plot-data
Requires: python3-kaitaistruct
Requires: python3-binaryornot
Requires: python3-sympy
Requires: python3-trimesh
Requires: python3-rtree
%description
![](https://partage.dessia.tech/thumbnail/7861a783126742be8fe8/1024/Logo_Dessia_transparent_web.png)
Volmdlr
A computations-oriented python VOLume MoDeLeR with STEP support for import and export
## Description
Volmdlr is a python volume modeler used as a CAD platform.
With it, you can easily create 3D models from python code.
Check the examples to see what you can do with this library.
![](https://raw.githubusercontent.com/Dessia-tech/volmdlr/master/doc/source/images/casing_contours.png)
A casing is defined by a 2D contour formed with the primitive RoundedLineSegment2D. This contour is offset by the casing width.
![](https://raw.githubusercontent.com/Dessia-tech/volmdlr/master/doc/source/images/sweepMPLPlot.jpg)
A Sweep is pipes, created with Circle2D/Arc2D which is contained in a Contour2D. You have to create the neutral fiber, i.e., the pipe’s road, with the primitive RoundedLineSegment3D.
![](https://raw.githubusercontent.com/Dessia-tech/volmdlr/master/doc/source/images/polygon.jpg)
A polygon is defined out of points. Random points are sampled and the tested whether they are inside or outside the polygon. They are plotted with the Matplotlib binding MPLPlot with custom styles:
- red if they are outside,
- blue if they are inside
![](https://raw.githubusercontent.com/Dessia-tech/volmdlr/master/doc/source/images/bspline_surface_split.png)
A 3D B-spline surface split by a 3D B-spline curve.
## Features
- [x] Generate 2D and 3D geometries from python
- [x] Handles complexe geometries : B-spline curves and surfaces
- [x] Primitives provide computational tasks : distances, belonging, union, intersections, etc.
- [x] STEP/STL imports and exports
- [x] Geometries display in your web browser with [babylon.js](https://www.babylonjs.com/)
## User Installation
```bash
pip install volmdlr
# or
pip3 install volmdlr
```
## Dev Installation
Before using Volmdlr, be sure to have a C/C++ compiler (not necessary on Linux).
N.B : With Windows you have to download one and allow it to read Python’s code.
First, [clone](https://docs.github.com/en/get-started/getting-started-with-git/about-remote-repositories) the package.
Then, enter the newly created volmdlr repository.
Finally, develop the setup.py file, and you are good to go !
```bash
git clone https://github.com/Dessia-tech/volmdlr.git
cd volmdlr
python3 setup.py develop --user
# or whatever version you are using :
python3.x setup.py develop --user
```
## Usage
See the [script](https://github.com/Dessia-tech/volmdlr/tree/master/scripts) folder for examples
## Documentation
https://documentation.dessia.tech/volmdlr/
## Licence
100% opensource on LGPL licence. See LICENCE for more details.
## Team and contributors
The project leader is [Wirajan Da Silva](https://github.com/WirajanDASILVA).
Volmdlr is mainly developed by the [dessia](https://dessia.tech) company as a part of its opensource SDK, but contributions are welcomed. See [CONTRIBUTING.md](/blob/master/CONTRIBUTING.md) for details
- [DessiA team](https://github.com/orgs/Dessia-tech/people)
- [luzpaz](https://github.com/luzpaz)
%package -n python3-volmdlr
Summary: A volume modeler computation-oriented. Include rendering bindings.
Provides: python-volmdlr
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
BuildRequires: python3-cffi
BuildRequires: gcc
BuildRequires: gdb
%description -n python3-volmdlr
![](https://partage.dessia.tech/thumbnail/7861a783126742be8fe8/1024/Logo_Dessia_transparent_web.png)
Volmdlr
A computations-oriented python VOLume MoDeLeR with STEP support for import and export
## Description
Volmdlr is a python volume modeler used as a CAD platform.
With it, you can easily create 3D models from python code.
Check the examples to see what you can do with this library.
![](https://raw.githubusercontent.com/Dessia-tech/volmdlr/master/doc/source/images/casing_contours.png)
A casing is defined by a 2D contour formed with the primitive RoundedLineSegment2D. This contour is offset by the casing width.
![](https://raw.githubusercontent.com/Dessia-tech/volmdlr/master/doc/source/images/sweepMPLPlot.jpg)
A Sweep is pipes, created with Circle2D/Arc2D which is contained in a Contour2D. You have to create the neutral fiber, i.e., the pipe’s road, with the primitive RoundedLineSegment3D.
![](https://raw.githubusercontent.com/Dessia-tech/volmdlr/master/doc/source/images/polygon.jpg)
A polygon is defined out of points. Random points are sampled and the tested whether they are inside or outside the polygon. They are plotted with the Matplotlib binding MPLPlot with custom styles:
- red if they are outside,
- blue if they are inside
![](https://raw.githubusercontent.com/Dessia-tech/volmdlr/master/doc/source/images/bspline_surface_split.png)
A 3D B-spline surface split by a 3D B-spline curve.
## Features
- [x] Generate 2D and 3D geometries from python
- [x] Handles complexe geometries : B-spline curves and surfaces
- [x] Primitives provide computational tasks : distances, belonging, union, intersections, etc.
- [x] STEP/STL imports and exports
- [x] Geometries display in your web browser with [babylon.js](https://www.babylonjs.com/)
## User Installation
```bash
pip install volmdlr
# or
pip3 install volmdlr
```
## Dev Installation
Before using Volmdlr, be sure to have a C/C++ compiler (not necessary on Linux).
N.B : With Windows you have to download one and allow it to read Python’s code.
First, [clone](https://docs.github.com/en/get-started/getting-started-with-git/about-remote-repositories) the package.
Then, enter the newly created volmdlr repository.
Finally, develop the setup.py file, and you are good to go !
```bash
git clone https://github.com/Dessia-tech/volmdlr.git
cd volmdlr
python3 setup.py develop --user
# or whatever version you are using :
python3.x setup.py develop --user
```
## Usage
See the [script](https://github.com/Dessia-tech/volmdlr/tree/master/scripts) folder for examples
## Documentation
https://documentation.dessia.tech/volmdlr/
## Licence
100% opensource on LGPL licence. See LICENCE for more details.
## Team and contributors
The project leader is [Wirajan Da Silva](https://github.com/WirajanDASILVA).
Volmdlr is mainly developed by the [dessia](https://dessia.tech) company as a part of its opensource SDK, but contributions are welcomed. See [CONTRIBUTING.md](/blob/master/CONTRIBUTING.md) for details
- [DessiA team](https://github.com/orgs/Dessia-tech/people)
- [luzpaz](https://github.com/luzpaz)
%package help
Summary: Development documents and examples for volmdlr
Provides: python3-volmdlr-doc
%description help
![](https://partage.dessia.tech/thumbnail/7861a783126742be8fe8/1024/Logo_Dessia_transparent_web.png)
Volmdlr
A computations-oriented python VOLume MoDeLeR with STEP support for import and export
## Description
Volmdlr is a python volume modeler used as a CAD platform.
With it, you can easily create 3D models from python code.
Check the examples to see what you can do with this library.
![](https://raw.githubusercontent.com/Dessia-tech/volmdlr/master/doc/source/images/casing_contours.png)
A casing is defined by a 2D contour formed with the primitive RoundedLineSegment2D. This contour is offset by the casing width.
![](https://raw.githubusercontent.com/Dessia-tech/volmdlr/master/doc/source/images/sweepMPLPlot.jpg)
A Sweep is pipes, created with Circle2D/Arc2D which is contained in a Contour2D. You have to create the neutral fiber, i.e., the pipe’s road, with the primitive RoundedLineSegment3D.
![](https://raw.githubusercontent.com/Dessia-tech/volmdlr/master/doc/source/images/polygon.jpg)
A polygon is defined out of points. Random points are sampled and the tested whether they are inside or outside the polygon. They are plotted with the Matplotlib binding MPLPlot with custom styles:
- red if they are outside,
- blue if they are inside
![](https://raw.githubusercontent.com/Dessia-tech/volmdlr/master/doc/source/images/bspline_surface_split.png)
A 3D B-spline surface split by a 3D B-spline curve.
## Features
- [x] Generate 2D and 3D geometries from python
- [x] Handles complexe geometries : B-spline curves and surfaces
- [x] Primitives provide computational tasks : distances, belonging, union, intersections, etc.
- [x] STEP/STL imports and exports
- [x] Geometries display in your web browser with [babylon.js](https://www.babylonjs.com/)
## User Installation
```bash
pip install volmdlr
# or
pip3 install volmdlr
```
## Dev Installation
Before using Volmdlr, be sure to have a C/C++ compiler (not necessary on Linux).
N.B : With Windows you have to download one and allow it to read Python’s code.
First, [clone](https://docs.github.com/en/get-started/getting-started-with-git/about-remote-repositories) the package.
Then, enter the newly created volmdlr repository.
Finally, develop the setup.py file, and you are good to go !
```bash
git clone https://github.com/Dessia-tech/volmdlr.git
cd volmdlr
python3 setup.py develop --user
# or whatever version you are using :
python3.x setup.py develop --user
```
## Usage
See the [script](https://github.com/Dessia-tech/volmdlr/tree/master/scripts) folder for examples
## Documentation
https://documentation.dessia.tech/volmdlr/
## Licence
100% opensource on LGPL licence. See LICENCE for more details.
## Team and contributors
The project leader is [Wirajan Da Silva](https://github.com/WirajanDASILVA).
Volmdlr is mainly developed by the [dessia](https://dessia.tech) company as a part of its opensource SDK, but contributions are welcomed. See [CONTRIBUTING.md](/blob/master/CONTRIBUTING.md) for details
- [DessiA team](https://github.com/orgs/Dessia-tech/people)
- [luzpaz](https://github.com/luzpaz)
%prep
%autosetup -n volmdlr-0.10.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-volmdlr -f filelist.lst
%dir %{python3_sitearch}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.10.0-1
- Package Spec generated