%global _empty_manifest_terminate_build 0
Name: python-auto-editor
Version: 23.15.1
Release: 1
Summary: Auto-Editor: Effort free video editing!
License: Unlicense
URL: https://auto-editor.com
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/86/af/27ee7e91a3cf56bb0b295699c5c6715726aab8950644448ec313dd0c9c79/auto-editor-23.15.1.tar.gz
BuildArch: noarch
Requires: python3-numpy
Requires: python3-pillow
Requires: python3-av
Requires: python3-ae-ffmpeg
%description
[![Actions Status](https://github.com/wyattblue/auto-editor/workflows/build/badge.svg)](https://github.com/wyattblue/auto-editor/actions)
Before doing the real editing, you first cut out the "dead space" which is typically silence. This is known as a "first pass". Cutting these is a boring task, especially if the video is very long.
```
auto-editor path/to/your/video.mp4
```
Installing
```
pip install auto-editor
```
See [Installing](https://auto-editor.com/installing) for additional information.
Cutting
Change the **pace** of the edited video by using `--margin`.
`--margin` adds in some "silent" sections to make the editing feel nicer. Setting `--margin` to `0.2sec` will add up to 0.2 seconds in front of and 0.2 seconds behind the original clip.
```
auto-editor example.mp4 --margin 0.2sec
```
Working With Multiple Audio Tracks
By default, only the first audio track will used for editing (track 0). You can change this with these commands.
Use all audio tracks for editing:
```
auto-editor multi-track.mov --edit audio:stream=all
```
Use only the second, fourth, and sixth audio track:
```
# track numbers start at 0
auto-editor so-many-tracks.mp4 --edit "(or audio:stream=1 audio:stream=3 audio:stream=5)"
```
Methods for Making Automatic Cuts
The `--edit` option is how auto-editor makes automated cuts.
For example, edit out motionlessness in a video by setting `--edit motion`.
```
# cut out sections where percentage of motion is less than 2.
auto-editor example.mp4 --edit motion:threshold=2%
# --edit is set to "audio:threshold=4%" by default.
auto-editor example.mp4
# Different tracks can be set with different attribute.
auto-editor multi-track.mov --edit "(or audio:stream=0 audio:threshold=10%,stream=1)"
```
Different editing methods can be used together.
```
# 'threshold' is always the first argument for edit-method objects
auto-editor example.mp4 --edit "(or audio:3% motion:6%)"
```
See What Auto-Editor Cuts Out
To export what auto-editor normally cuts out. Set `--video-speed` to `99999` and `--silent-speed` to `1`. This is the reverse of the usual default values.
```
auto-editor example.mp4 --video-speed 99999 --silent-speed 1
```
Exporting to Editors
Create an XML file that can be imported to Adobe Premiere Pro using this command:
```
auto-editor example.mp4 --export premiere
```
Auto-Editor can also export to:
- DaVinci Resolve with `--export resolve`
- Final Cut Pro with `--export final-cut-pro`
- ShotCut with `--export shotcut`
Other editors, like Sony Vegas, can understand the `premiere` format. If your favorite editor doesn't, you can use ` --export clip-sequence` which creates many video clips that can be imported and manipulated like normal.
Manual Editing
Use the `--cut-out` option to always remove a section.
```
# Cut out the first 10 seconds.
auto-editor example.mp4 --cut-out start,10sec
# Cut out the first 10 frames.
auto-editor example.mp4 --cut-out start,10
# Cut out the last 10 seconds.
auto-editor example.mp4 --cut-out -10sec,end
# Cut out the first 10 seconds and cut out the range from 15 seconds to 20 seconds.
auto-editor example.mp4 --cut-out start,10sec 15sec,20sec
```
And of course, all the audio cuts still apply.
If you don't want **any automatic cuts**, use `--edit none`
```
# Cut out the first 5 seconds, leave the rest untouched.
auto-editor example.mp4 --edit none --cut-out start,5sec
# Leave in the first 5 seconds, cut everything else out.
auto-editor example.mp4 --edit all --add-in start,5sec
```
More Options
List all available options:
```
auto-editor --help
```
Use `--help` with a specific option for more information:
```
auto-editor --scale --help
--scale
type: number
%package -n python3-auto-editor
Summary: Auto-Editor: Effort free video editing!
Provides: python-auto-editor
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-auto-editor
[![Actions Status](https://github.com/wyattblue/auto-editor/workflows/build/badge.svg)](https://github.com/wyattblue/auto-editor/actions)
Before doing the real editing, you first cut out the "dead space" which is typically silence. This is known as a "first pass". Cutting these is a boring task, especially if the video is very long.
```
auto-editor path/to/your/video.mp4
```
Installing
```
pip install auto-editor
```
See [Installing](https://auto-editor.com/installing) for additional information.
Cutting
Change the **pace** of the edited video by using `--margin`.
`--margin` adds in some "silent" sections to make the editing feel nicer. Setting `--margin` to `0.2sec` will add up to 0.2 seconds in front of and 0.2 seconds behind the original clip.
```
auto-editor example.mp4 --margin 0.2sec
```
Working With Multiple Audio Tracks
By default, only the first audio track will used for editing (track 0). You can change this with these commands.
Use all audio tracks for editing:
```
auto-editor multi-track.mov --edit audio:stream=all
```
Use only the second, fourth, and sixth audio track:
```
# track numbers start at 0
auto-editor so-many-tracks.mp4 --edit "(or audio:stream=1 audio:stream=3 audio:stream=5)"
```
Methods for Making Automatic Cuts
The `--edit` option is how auto-editor makes automated cuts.
For example, edit out motionlessness in a video by setting `--edit motion`.
```
# cut out sections where percentage of motion is less than 2.
auto-editor example.mp4 --edit motion:threshold=2%
# --edit is set to "audio:threshold=4%" by default.
auto-editor example.mp4
# Different tracks can be set with different attribute.
auto-editor multi-track.mov --edit "(or audio:stream=0 audio:threshold=10%,stream=1)"
```
Different editing methods can be used together.
```
# 'threshold' is always the first argument for edit-method objects
auto-editor example.mp4 --edit "(or audio:3% motion:6%)"
```
See What Auto-Editor Cuts Out
To export what auto-editor normally cuts out. Set `--video-speed` to `99999` and `--silent-speed` to `1`. This is the reverse of the usual default values.
```
auto-editor example.mp4 --video-speed 99999 --silent-speed 1
```
Exporting to Editors
Create an XML file that can be imported to Adobe Premiere Pro using this command:
```
auto-editor example.mp4 --export premiere
```
Auto-Editor can also export to:
- DaVinci Resolve with `--export resolve`
- Final Cut Pro with `--export final-cut-pro`
- ShotCut with `--export shotcut`
Other editors, like Sony Vegas, can understand the `premiere` format. If your favorite editor doesn't, you can use ` --export clip-sequence` which creates many video clips that can be imported and manipulated like normal.
Manual Editing
Use the `--cut-out` option to always remove a section.
```
# Cut out the first 10 seconds.
auto-editor example.mp4 --cut-out start,10sec
# Cut out the first 10 frames.
auto-editor example.mp4 --cut-out start,10
# Cut out the last 10 seconds.
auto-editor example.mp4 --cut-out -10sec,end
# Cut out the first 10 seconds and cut out the range from 15 seconds to 20 seconds.
auto-editor example.mp4 --cut-out start,10sec 15sec,20sec
```
And of course, all the audio cuts still apply.
If you don't want **any automatic cuts**, use `--edit none`
```
# Cut out the first 5 seconds, leave the rest untouched.
auto-editor example.mp4 --edit none --cut-out start,5sec
# Leave in the first 5 seconds, cut everything else out.
auto-editor example.mp4 --edit all --add-in start,5sec
```
More Options
List all available options:
```
auto-editor --help
```
Use `--help` with a specific option for more information:
```
auto-editor --scale --help
--scale
type: number
%package help
Summary: Development documents and examples for auto-editor
Provides: python3-auto-editor-doc
%description help
[![Actions Status](https://github.com/wyattblue/auto-editor/workflows/build/badge.svg)](https://github.com/wyattblue/auto-editor/actions)
Before doing the real editing, you first cut out the "dead space" which is typically silence. This is known as a "first pass". Cutting these is a boring task, especially if the video is very long.
```
auto-editor path/to/your/video.mp4
```
Installing
```
pip install auto-editor
```
See [Installing](https://auto-editor.com/installing) for additional information.
Cutting
Change the **pace** of the edited video by using `--margin`.
`--margin` adds in some "silent" sections to make the editing feel nicer. Setting `--margin` to `0.2sec` will add up to 0.2 seconds in front of and 0.2 seconds behind the original clip.
```
auto-editor example.mp4 --margin 0.2sec
```
Working With Multiple Audio Tracks
By default, only the first audio track will used for editing (track 0). You can change this with these commands.
Use all audio tracks for editing:
```
auto-editor multi-track.mov --edit audio:stream=all
```
Use only the second, fourth, and sixth audio track:
```
# track numbers start at 0
auto-editor so-many-tracks.mp4 --edit "(or audio:stream=1 audio:stream=3 audio:stream=5)"
```
Methods for Making Automatic Cuts
The `--edit` option is how auto-editor makes automated cuts.
For example, edit out motionlessness in a video by setting `--edit motion`.
```
# cut out sections where percentage of motion is less than 2.
auto-editor example.mp4 --edit motion:threshold=2%
# --edit is set to "audio:threshold=4%" by default.
auto-editor example.mp4
# Different tracks can be set with different attribute.
auto-editor multi-track.mov --edit "(or audio:stream=0 audio:threshold=10%,stream=1)"
```
Different editing methods can be used together.
```
# 'threshold' is always the first argument for edit-method objects
auto-editor example.mp4 --edit "(or audio:3% motion:6%)"
```
See What Auto-Editor Cuts Out
To export what auto-editor normally cuts out. Set `--video-speed` to `99999` and `--silent-speed` to `1`. This is the reverse of the usual default values.
```
auto-editor example.mp4 --video-speed 99999 --silent-speed 1
```
Exporting to Editors
Create an XML file that can be imported to Adobe Premiere Pro using this command:
```
auto-editor example.mp4 --export premiere
```
Auto-Editor can also export to:
- DaVinci Resolve with `--export resolve`
- Final Cut Pro with `--export final-cut-pro`
- ShotCut with `--export shotcut`
Other editors, like Sony Vegas, can understand the `premiere` format. If your favorite editor doesn't, you can use ` --export clip-sequence` which creates many video clips that can be imported and manipulated like normal.
Manual Editing
Use the `--cut-out` option to always remove a section.
```
# Cut out the first 10 seconds.
auto-editor example.mp4 --cut-out start,10sec
# Cut out the first 10 frames.
auto-editor example.mp4 --cut-out start,10
# Cut out the last 10 seconds.
auto-editor example.mp4 --cut-out -10sec,end
# Cut out the first 10 seconds and cut out the range from 15 seconds to 20 seconds.
auto-editor example.mp4 --cut-out start,10sec 15sec,20sec
```
And of course, all the audio cuts still apply.
If you don't want **any automatic cuts**, use `--edit none`
```
# Cut out the first 5 seconds, leave the rest untouched.
auto-editor example.mp4 --edit none --cut-out start,5sec
# Leave in the first 5 seconds, cut everything else out.
auto-editor example.mp4 --edit all --add-in start,5sec
```
More Options
List all available options:
```
auto-editor --help
```
Use `--help` with a specific option for more information:
```
auto-editor --scale --help
--scale
type: number
%prep
%autosetup -n auto-editor-23.15.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-auto-editor -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 23.15.1-1
- Package Spec generated