%global _empty_manifest_terminate_build 0
Name:		python-repoze.xmliter
Version:	0.6.1
Release:	1
Summary:	Wrapper for ``lxml`` trees which serializes to string upon iteration.
License:	BSD-derived (http://www.repoze.org/LICENSE.txt)
URL:		http://www.repoze.org
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/60/70/3a0e82929bfe771248b628986202d983f372ad6819d05ea71755b228a145/repoze.xmliter-0.6.1.tar.gz
BuildArch:	noarch


%description
This package provides a wrapper for ``lxml`` trees which serializes to
string on iteration, but otherwise makes the tree available in an
attribute.
The primary for this is WSGI middleware which may avoid
needless XML parsing and serialization.

%package -n python3-repoze.xmliter
Summary:	Wrapper for ``lxml`` trees which serializes to string upon iteration.
Provides:	python-repoze.xmliter
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-repoze.xmliter
This package provides a wrapper for ``lxml`` trees which serializes to
string on iteration, but otherwise makes the tree available in an
attribute.
The primary for this is WSGI middleware which may avoid
needless XML parsing and serialization.

%package help
Summary:	Development documents and examples for repoze.xmliter
Provides:	python3-repoze.xmliter-doc
%description help
This package provides a wrapper for ``lxml`` trees which serializes to
string on iteration, but otherwise makes the tree available in an
attribute.
The primary for this is WSGI middleware which may avoid
needless XML parsing and serialization.

%prep
%autosetup -n repoze.xmliter-0.6.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-repoze.xmliter -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.1-1
- Package Spec generated