%global _empty_manifest_terminate_build 0
Name: python-area4
Version: 3.11.0
Release: 1
Summary: Dividers in Python, the easy way!
License: MIT
URL: https://github.com/area4lib/area4
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a5/65/92795d07dc5092f0f81becd3ede944a87f2525b68aea50dfd7f89a5094f8/area4-3.11.0.tar.gz
BuildArch: noarch
%description
# area4
Dividers in Python, the easy way! Many different types. [(As seen on PyPI!)](https://pypi.org/project/area4)
[![MIT License Badge](https://img.shields.io/badge/license-MIT-green.svg)](https://github.com/area4lib/area4/blob/master/LICENSE)
[![PyPI Project Version](https://badge.fury.io/py/area4.svg)](https://pypi.org/project/area4)
[![Documentation Status](https://readthedocs.org/projects/area4/badge/?version=latest)](https://area4.readthedocs.io/en/latest/?badge=latest)
[![Project Status: Active](https://www.repostatus.org/badges/latest/active.svg)](https://www.repostatus.org/#active)
[![Build Status](https://api.cirrus-ci.com/github/area4lib/area4.svg)](https://cirrus-ci.com/github/area4lib/area4)
area4 is a flexible Python divider library which doubles as a working emoji database. It makes dividers in console output easy. Don't want to type out `---------` every time you need to use it? We've got you covered.
## **Documentation** [can be found here](https://area4.readthedocs.io/en/stable/)
For help/troubleshooting see our [support information](https://github.com/area4lib/area4/blob/master/.github/SUPPORT.md).
%package -n python3-area4
Summary: Dividers in Python, the easy way!
Provides: python-area4
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-area4
# area4
Dividers in Python, the easy way! Many different types. [(As seen on PyPI!)](https://pypi.org/project/area4)
[![MIT License Badge](https://img.shields.io/badge/license-MIT-green.svg)](https://github.com/area4lib/area4/blob/master/LICENSE)
[![PyPI Project Version](https://badge.fury.io/py/area4.svg)](https://pypi.org/project/area4)
[![Documentation Status](https://readthedocs.org/projects/area4/badge/?version=latest)](https://area4.readthedocs.io/en/latest/?badge=latest)
[![Project Status: Active](https://www.repostatus.org/badges/latest/active.svg)](https://www.repostatus.org/#active)
[![Build Status](https://api.cirrus-ci.com/github/area4lib/area4.svg)](https://cirrus-ci.com/github/area4lib/area4)
area4 is a flexible Python divider library which doubles as a working emoji database. It makes dividers in console output easy. Don't want to type out `---------` every time you need to use it? We've got you covered.
## **Documentation** [can be found here](https://area4.readthedocs.io/en/stable/)
For help/troubleshooting see our [support information](https://github.com/area4lib/area4/blob/master/.github/SUPPORT.md).
%package help
Summary: Development documents and examples for area4
Provides: python3-area4-doc
%description help
# area4
Dividers in Python, the easy way! Many different types. [(As seen on PyPI!)](https://pypi.org/project/area4)
[![MIT License Badge](https://img.shields.io/badge/license-MIT-green.svg)](https://github.com/area4lib/area4/blob/master/LICENSE)
[![PyPI Project Version](https://badge.fury.io/py/area4.svg)](https://pypi.org/project/area4)
[![Documentation Status](https://readthedocs.org/projects/area4/badge/?version=latest)](https://area4.readthedocs.io/en/latest/?badge=latest)
[![Project Status: Active](https://www.repostatus.org/badges/latest/active.svg)](https://www.repostatus.org/#active)
[![Build Status](https://api.cirrus-ci.com/github/area4lib/area4.svg)](https://cirrus-ci.com/github/area4lib/area4)
area4 is a flexible Python divider library which doubles as a working emoji database. It makes dividers in console output easy. Don't want to type out `---------` every time you need to use it? We've got you covered.
## **Documentation** [can be found here](https://area4.readthedocs.io/en/stable/)
For help/troubleshooting see our [support information](https://github.com/area4lib/area4/blob/master/.github/SUPPORT.md).
%prep
%autosetup -n area4-3.11.0
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-area4 -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 3.11.0-1
- Package Spec generated