%global _empty_manifest_terminate_build 0
Name:		python-index.py
Version:	0.21.15
Release:	1
Summary:	An easy-to-use high-performance asynchronous web framework.
License:	Apache-2.0
URL:		https://github.com/abersheeran/index.py
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/e7/e0/0d78a1c06723bd24b3069b709cf18a8e09e5834abf2a6479ac14db458ccf/index.py-0.21.15.tar.gz
BuildArch:	noarch

Requires:	python3-baize
Requires:	python3-click
Requires:	python3-pydantic
Requires:	python3-typing-extensions

%description
Index.py 实现了 [ASGI3](http://asgi.readthedocs.io/en/latest/) 接口,并使用 Radix Tree 进行路由查找。是[最快的 Python web 框架之一](https://github.com/the-benchmarker/web-frameworks)。一切特性都服务于快速开发高性能的 Web 服务。
- 大量正确的类型注释
- 灵活且高效的路由系统
- 能作用于任意路由及路由分组上的路由中间件
- 适用于中间件与视图的依赖注入
- 可视化 API 接口与在线调试
- 支持 [Server-sent events](https://developer.mozilla.org/zh-CN/docs/Web/API/Server-sent_events/Using_server-sent_events) 与 WebSocket
- 自带一键部署命令 (基于 uvicorn 与 gunicorn)
- 可使用任何标准 ASGI 生态
## Install
```bash
pip install -U index.py
```
或者直接从 Github 上安装最新版本(不稳定)
```bash
pip install -U git+https://github.com/abersheeran/index.py@setup.py
```
中国大陆内的用户可从 Gitee 上的镜像仓库拉取
```bash
pip install -U git+https://gitee.com/abersheeran/index.py.git@setup.py
```

%package -n python3-index.py
Summary:	An easy-to-use high-performance asynchronous web framework.
Provides:	python-index.py
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-index.py
Index.py 实现了 [ASGI3](http://asgi.readthedocs.io/en/latest/) 接口,并使用 Radix Tree 进行路由查找。是[最快的 Python web 框架之一](https://github.com/the-benchmarker/web-frameworks)。一切特性都服务于快速开发高性能的 Web 服务。
- 大量正确的类型注释
- 灵活且高效的路由系统
- 能作用于任意路由及路由分组上的路由中间件
- 适用于中间件与视图的依赖注入
- 可视化 API 接口与在线调试
- 支持 [Server-sent events](https://developer.mozilla.org/zh-CN/docs/Web/API/Server-sent_events/Using_server-sent_events) 与 WebSocket
- 自带一键部署命令 (基于 uvicorn 与 gunicorn)
- 可使用任何标准 ASGI 生态
## Install
```bash
pip install -U index.py
```
或者直接从 Github 上安装最新版本(不稳定)
```bash
pip install -U git+https://github.com/abersheeran/index.py@setup.py
```
中国大陆内的用户可从 Gitee 上的镜像仓库拉取
```bash
pip install -U git+https://gitee.com/abersheeran/index.py.git@setup.py
```

%package help
Summary:	Development documents and examples for index.py
Provides:	python3-index.py-doc
%description help
Index.py 实现了 [ASGI3](http://asgi.readthedocs.io/en/latest/) 接口,并使用 Radix Tree 进行路由查找。是[最快的 Python web 框架之一](https://github.com/the-benchmarker/web-frameworks)。一切特性都服务于快速开发高性能的 Web 服务。
- 大量正确的类型注释
- 灵活且高效的路由系统
- 能作用于任意路由及路由分组上的路由中间件
- 适用于中间件与视图的依赖注入
- 可视化 API 接口与在线调试
- 支持 [Server-sent events](https://developer.mozilla.org/zh-CN/docs/Web/API/Server-sent_events/Using_server-sent_events) 与 WebSocket
- 自带一键部署命令 (基于 uvicorn 与 gunicorn)
- 可使用任何标准 ASGI 生态
## Install
```bash
pip install -U index.py
```
或者直接从 Github 上安装最新版本(不稳定)
```bash
pip install -U git+https://github.com/abersheeran/index.py@setup.py
```
中国大陆内的用户可从 Gitee 上的镜像仓库拉取
```bash
pip install -U git+https://gitee.com/abersheeran/index.py.git@setup.py
```

%prep
%autosetup -n index.py-0.21.15

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-index.py -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.21.15-1
- Package Spec generated