%global _empty_manifest_terminate_build 0
Name:		python-requests-wsgi-adapter
Version:	0.4.1
Release:	1
Summary:	WSGI Transport Adapter for Requests
License:	BSD
URL:		https://github.com/seanbrant/requests-wsgi-adapter
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/c6/f6/8bd78fb03f1212965d7e5b566a37a3ac9a8a8ece5754203356ce7820830a/requests-wsgi-adapter-0.4.1.tar.gz
BuildArch:	noarch


%description
.. code-block:: python

  >>> from django.core.wsgi import get_wsgi_application
  >>>
  >>> import requests
  >>> import wsgiadapter
  >>>
  >>> s = requests.Session()
  >>> s.mount('http://staging/', wsgiadapter.WSGIAdapter(get_wsgi_application()))
  >>> s.get('http://staging/index')
  <Response [200]>

%package -n python3-requests-wsgi-adapter
Summary:	WSGI Transport Adapter for Requests
Provides:	python-requests-wsgi-adapter
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-requests-wsgi-adapter
.. code-block:: python

  >>> from django.core.wsgi import get_wsgi_application
  >>>
  >>> import requests
  >>> import wsgiadapter
  >>>
  >>> s = requests.Session()
  >>> s.mount('http://staging/', wsgiadapter.WSGIAdapter(get_wsgi_application()))
  >>> s.get('http://staging/index')
  <Response [200]>

%package help
Summary:	Development documents and examples for requests-wsgi-adapter
Provides:	python3-requests-wsgi-adapter-doc
%description help
.. code-block:: python

  >>> from django.core.wsgi import get_wsgi_application
  >>>
  >>> import requests
  >>> import wsgiadapter
  >>>
  >>> s = requests.Session()
  >>> s.mount('http://staging/', wsgiadapter.WSGIAdapter(get_wsgi_application()))
  >>> s.get('http://staging/index')
  <Response [200]>

%prep
%autosetup -n requests-wsgi-adapter-0.4.1

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-requests-wsgi-adapter -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.1-1
- Package Spec generated