%global _empty_manifest_terminate_build 0
Name: python-jinja-cli
Version: 1.2.2
Release: 1
Summary: a command line interface to jinja;
License: GNU General Public License v3 (GPLv3)
URL: https://github.com/cykerway/jinja-cli
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4b/ca/94afaf5fd47c6a3bd92c9eebc21cc284961e4a954e4860d8b526291d59ad/jinja-cli-1.2.2.tar.gz
BuildArch: noarch
Requires: python3-Jinja2
Requires: python3-PyYAML
Requires: python3-argparse-ext
Requires: python3-xmltodict
%description
# jinja-cli
a command line interface to [jinja][jinja];
this program renders a jinja template using input data; data may be read from a
file, environment variables, or command line arguments; either template or data
file may be read from stdin; output file may be written to stdout;
supported data formats: ini, json, xml, yaml;
## install
pip install jinja-cli
## usage
to render a jinja template with data in json format:
# jinja -d {data} {template}
to use a different data format:
# jinja -d {data} -f {data_format} {template}
to read template from stdin:
# jinja -d {data} < {template}
to read data from stdin:
# jinja -d - {template} < {data}
to read data from command line arguments:
# jinja -D {key} {value} [ -D {key} {value} ... ] {template}
to read data from environment variables:
# jinja -E {key} [ -E {key} ... ] {template}
to read data from environment variables using regex:
# jinja -X {regex} {template}
to output to a file:
# jinja -d {data} -o {output} {template}
## example
template file `example.j2`:
sheep eat {{ sheep.eat }};
data file `example.json`:
{
"sheep": {
"eat": "grass"
}
}
any of these commands:
# jinja -d example.json example.j2
# jinja -d example.json < example.j2
# jinja -d - -f json example.j2 < example.json
output:
sheep eat grass;
## data priority
data priority from low to high:
- environment variables: `-E, --env`, `-X, --env-regex`;
- data file: `-d, --data`;
- command line arguments: `-D, --define`;
## undefined variables
option `-u, --undefined` sets how [undefined variables][undefined] are handled:
- `''`: an undefined variable can be printed and iterated over; this is the
default;
- `'chainable'`: an undefined variable is chainable;
- `'debug'`: an undefined variable returns debug info when printed;
- `'strict'`: an undefined variable barks on print, iteration, boolean tests
and comparisons;
## license
Copyright (C) 2018-2021 Cyker Way
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.
This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with this program. If not, see .
[jinja]: http://jinja.pocoo.org/
[undefined]: https://jinja.palletsprojects.com/en/latest/api/#undefined-types
%package -n python3-jinja-cli
Summary: a command line interface to jinja;
Provides: python-jinja-cli
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-jinja-cli
# jinja-cli
a command line interface to [jinja][jinja];
this program renders a jinja template using input data; data may be read from a
file, environment variables, or command line arguments; either template or data
file may be read from stdin; output file may be written to stdout;
supported data formats: ini, json, xml, yaml;
## install
pip install jinja-cli
## usage
to render a jinja template with data in json format:
# jinja -d {data} {template}
to use a different data format:
# jinja -d {data} -f {data_format} {template}
to read template from stdin:
# jinja -d {data} < {template}
to read data from stdin:
# jinja -d - {template} < {data}
to read data from command line arguments:
# jinja -D {key} {value} [ -D {key} {value} ... ] {template}
to read data from environment variables:
# jinja -E {key} [ -E {key} ... ] {template}
to read data from environment variables using regex:
# jinja -X {regex} {template}
to output to a file:
# jinja -d {data} -o {output} {template}
## example
template file `example.j2`:
sheep eat {{ sheep.eat }};
data file `example.json`:
{
"sheep": {
"eat": "grass"
}
}
any of these commands:
# jinja -d example.json example.j2
# jinja -d example.json < example.j2
# jinja -d - -f json example.j2 < example.json
output:
sheep eat grass;
## data priority
data priority from low to high:
- environment variables: `-E, --env`, `-X, --env-regex`;
- data file: `-d, --data`;
- command line arguments: `-D, --define`;
## undefined variables
option `-u, --undefined` sets how [undefined variables][undefined] are handled:
- `''`: an undefined variable can be printed and iterated over; this is the
default;
- `'chainable'`: an undefined variable is chainable;
- `'debug'`: an undefined variable returns debug info when printed;
- `'strict'`: an undefined variable barks on print, iteration, boolean tests
and comparisons;
## license
Copyright (C) 2018-2021 Cyker Way
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.
This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with this program. If not, see .
[jinja]: http://jinja.pocoo.org/
[undefined]: https://jinja.palletsprojects.com/en/latest/api/#undefined-types
%package help
Summary: Development documents and examples for jinja-cli
Provides: python3-jinja-cli-doc
%description help
# jinja-cli
a command line interface to [jinja][jinja];
this program renders a jinja template using input data; data may be read from a
file, environment variables, or command line arguments; either template or data
file may be read from stdin; output file may be written to stdout;
supported data formats: ini, json, xml, yaml;
## install
pip install jinja-cli
## usage
to render a jinja template with data in json format:
# jinja -d {data} {template}
to use a different data format:
# jinja -d {data} -f {data_format} {template}
to read template from stdin:
# jinja -d {data} < {template}
to read data from stdin:
# jinja -d - {template} < {data}
to read data from command line arguments:
# jinja -D {key} {value} [ -D {key} {value} ... ] {template}
to read data from environment variables:
# jinja -E {key} [ -E {key} ... ] {template}
to read data from environment variables using regex:
# jinja -X {regex} {template}
to output to a file:
# jinja -d {data} -o {output} {template}
## example
template file `example.j2`:
sheep eat {{ sheep.eat }};
data file `example.json`:
{
"sheep": {
"eat": "grass"
}
}
any of these commands:
# jinja -d example.json example.j2
# jinja -d example.json < example.j2
# jinja -d - -f json example.j2 < example.json
output:
sheep eat grass;
## data priority
data priority from low to high:
- environment variables: `-E, --env`, `-X, --env-regex`;
- data file: `-d, --data`;
- command line arguments: `-D, --define`;
## undefined variables
option `-u, --undefined` sets how [undefined variables][undefined] are handled:
- `''`: an undefined variable can be printed and iterated over; this is the
default;
- `'chainable'`: an undefined variable is chainable;
- `'debug'`: an undefined variable returns debug info when printed;
- `'strict'`: an undefined variable barks on print, iteration, boolean tests
and comparisons;
## license
Copyright (C) 2018-2021 Cyker Way
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.
This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
GNU General Public License for more details.
You should have received a copy of the GNU General Public License
along with this program. If not, see .
[jinja]: http://jinja.pocoo.org/
[undefined]: https://jinja.palletsprojects.com/en/latest/api/#undefined-types
%prep
%autosetup -n jinja-cli-1.2.2
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-jinja-cli -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 1.2.2-1
- Package Spec generated