%global _empty_manifest_terminate_build 0
Name: python-CodeChat-Server
Version: 0.2.9
Release: 1
Summary: The CodeChat Server for software documentation
License: GPLv3+
URL: http://codechat.readthedocs.io/en/latest/
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4e/37/2ec355690a21bc91dc40d4b16417c4a295e2b9917d1a3853d24d71d29b91/CodeChat_Server-0.2.9.tar.gz
BuildArch: noarch
Requires: python3-bottle
Requires: python3-CodeChat
Requires: python3-markdown
Requires: python3-psutil
Requires: python3-strictyaml
Requires: python3-thrift
Requires: python3-typer
Requires: python3-watchdog
Requires: python3-websockets
Requires: python3-black
Requires: python3-coverage
Requires: python3-flake8
Requires: python3-mypy
Requires: python3-pytest
Requires: python3-requests
Requires: python3-tox
%description
The CodeChat System provides a powerful literate programming authoring system to a variety of text editors and IDEs. Specifically, it provides a GUI to automatically render source code and/or markup documents to HTML, displaying the HTML document produced by the rendering process next to the source. For example:
This screenshot shows the Visual Studio Code editor with the CodeChat extension.
In ❶, the left panel shows a the Visual Studio Code text editor with Python source code. CodeChat renders this source code to ❷, the right panel, which shows the resulting HTML document. Finally, ❸ displays output from the build process. A splitter between ❷ and ❸ allows the user to adjust the build output size or hide it entirely. Below ❸, a status bar displays the build status and a count of errors and warnings produced by the build.
In addition to native support for Markdown and reStructuredText, the CodeChat System supports almost any external renderer via user-provided JSON configuration files. For example, CodeChat can:
- invoke `Pandoc `_ to render a wide variety of markup formats;
- use `Sphinx `_ to build project documentation;
- call `Runestone `_ to create interactive textbooks;
- employ `Doxygen `_ to generate documentation from source code;
%package -n python3-CodeChat-Server
Summary: The CodeChat Server for software documentation
Provides: python-CodeChat-Server
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-CodeChat-Server
The CodeChat System provides a powerful literate programming authoring system to a variety of text editors and IDEs. Specifically, it provides a GUI to automatically render source code and/or markup documents to HTML, displaying the HTML document produced by the rendering process next to the source. For example:
This screenshot shows the Visual Studio Code editor with the CodeChat extension.
In ❶, the left panel shows a the Visual Studio Code text editor with Python source code. CodeChat renders this source code to ❷, the right panel, which shows the resulting HTML document. Finally, ❸ displays output from the build process. A splitter between ❷ and ❸ allows the user to adjust the build output size or hide it entirely. Below ❸, a status bar displays the build status and a count of errors and warnings produced by the build.
In addition to native support for Markdown and reStructuredText, the CodeChat System supports almost any external renderer via user-provided JSON configuration files. For example, CodeChat can:
- invoke `Pandoc `_ to render a wide variety of markup formats;
- use `Sphinx `_ to build project documentation;
- call `Runestone `_ to create interactive textbooks;
- employ `Doxygen `_ to generate documentation from source code;
%package help
Summary: Development documents and examples for CodeChat-Server
Provides: python3-CodeChat-Server-doc
%description help
The CodeChat System provides a powerful literate programming authoring system to a variety of text editors and IDEs. Specifically, it provides a GUI to automatically render source code and/or markup documents to HTML, displaying the HTML document produced by the rendering process next to the source. For example:
This screenshot shows the Visual Studio Code editor with the CodeChat extension.
In ❶, the left panel shows a the Visual Studio Code text editor with Python source code. CodeChat renders this source code to ❷, the right panel, which shows the resulting HTML document. Finally, ❸ displays output from the build process. A splitter between ❷ and ❸ allows the user to adjust the build output size or hide it entirely. Below ❸, a status bar displays the build status and a count of errors and warnings produced by the build.
In addition to native support for Markdown and reStructuredText, the CodeChat System supports almost any external renderer via user-provided JSON configuration files. For example, CodeChat can:
- invoke `Pandoc `_ to render a wide variety of markup formats;
- use `Sphinx `_ to build project documentation;
- call `Runestone `_ to create interactive textbooks;
- employ `Doxygen `_ to generate documentation from source code;
%prep
%autosetup -n CodeChat-Server-0.2.9
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-CodeChat-Server -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.2.9-1
- Package Spec generated