%global _empty_manifest_terminate_build 0
Name: python-chronumental
Version: 0.0.60
Release: 1
Summary: Large timetrees
License: MIT License
URL: https://github.com/theosanderson/chronumental
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d6/2a/42916add15b9c89cfeee32dbc116dd8f6f131215fc9efb8d5ddd7668d191/chronumental-0.0.60.tar.gz
BuildArch: noarch
Requires: python3-numpyro
Requires: python3-alive-progress
Requires: python3-pandas
Requires: python3-treeswift
Requires: python3-scipy
Requires: python3-xopen
Requires: python3-numpy
%description
## Chronumental
***Chron**ologies from mon**umental** phylogenetic trees*
Chronumental is a tool for creating a "time-tree" (where distance on the tree represents time) from a phylogenetic divergence-tree (where distance on the tree reflects a number of genetic substitutions).
What sets Chronumental apart from most other tools is that it scales to extremely large trees, which can contain millions of nodes. Chronumental uses JAX to represent the task of computing a time tree in a differentiable graph for efficient calculation on a CPU or GPU.
#### [📝 Read the preprint](https://www.biorxiv.org/content/10.1101/2021.10.27.465994v1)
#### [📚 View the documentation](https://chronumental.readthedocs.io/en/latest/)
### Installation
#### Method 1: Using pipx (recommended for basic use - installs in its own isolated environment)
```
pip install --local pipx
pipx install chronumental
```
#### Method 2: In your python environment
```
pip install chronumental
```
#### Method 3: Bioconda
Chronumental is [now](https://github.com/bioconda/bioconda-recipes/pull/34410) available on bioconda
```
conda config --add channels bioconda
conda install chronumental
```
### Usage
This demo uses trees and metadata collated by the [UShER](https://github.com/yatisht/usher) [team](https://hgwdev.gi.ucsc.edu/~angie/UShER_SARS-CoV-2/).
```
wget https://hgwdev.gi.ucsc.edu/~angie/UShER_SARS-CoV-2/2021/10/06/public-2021-10-06.all.nwk.gz
wget https://hgwdev.gi.ucsc.edu/~angie/UShER_SARS-CoV-2/2021/10/06/public-2021-10-06.metadata.tsv.gz
chronumental --tree public-2021-10-06.all.nwk.gz --dates public-2021-10-06.metadata.tsv.gz --steps 100
```
📚 Please [visit our documentation page](https://chronumental.readthedocs.io/en/latest/) to learn more about the parameters you can use to control Chronumental.
### Integrations
[Taxonium](https://github.com/theosanderson/taxonium) can automatically call Chronumental, and generate a combined visualisation that allows switching between distance and time phylogenies
### Similar tools
[TreeTime](https://github.com/neherlab/treetime) is a more advanced tool for inferring time trees. If you have a dataset of e.g. <10,000 rather than millions of nodes you are definitely best off trying it. The TreeTime readme also links to other similar tools.
### Troubleshooting
- Chronumental uses the earliest date in your dataset as an anchor to calibrate everything else. If this earliest date is wrong due to a metadata error things won't work well, you can set the reference node manually with `--reference_node`
%package -n python3-chronumental
Summary: Large timetrees
Provides: python-chronumental
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-chronumental
## Chronumental
***Chron**ologies from mon**umental** phylogenetic trees*
Chronumental is a tool for creating a "time-tree" (where distance on the tree represents time) from a phylogenetic divergence-tree (where distance on the tree reflects a number of genetic substitutions).
What sets Chronumental apart from most other tools is that it scales to extremely large trees, which can contain millions of nodes. Chronumental uses JAX to represent the task of computing a time tree in a differentiable graph for efficient calculation on a CPU or GPU.
#### [📝 Read the preprint](https://www.biorxiv.org/content/10.1101/2021.10.27.465994v1)
#### [📚 View the documentation](https://chronumental.readthedocs.io/en/latest/)
### Installation
#### Method 1: Using pipx (recommended for basic use - installs in its own isolated environment)
```
pip install --local pipx
pipx install chronumental
```
#### Method 2: In your python environment
```
pip install chronumental
```
#### Method 3: Bioconda
Chronumental is [now](https://github.com/bioconda/bioconda-recipes/pull/34410) available on bioconda
```
conda config --add channels bioconda
conda install chronumental
```
### Usage
This demo uses trees and metadata collated by the [UShER](https://github.com/yatisht/usher) [team](https://hgwdev.gi.ucsc.edu/~angie/UShER_SARS-CoV-2/).
```
wget https://hgwdev.gi.ucsc.edu/~angie/UShER_SARS-CoV-2/2021/10/06/public-2021-10-06.all.nwk.gz
wget https://hgwdev.gi.ucsc.edu/~angie/UShER_SARS-CoV-2/2021/10/06/public-2021-10-06.metadata.tsv.gz
chronumental --tree public-2021-10-06.all.nwk.gz --dates public-2021-10-06.metadata.tsv.gz --steps 100
```
📚 Please [visit our documentation page](https://chronumental.readthedocs.io/en/latest/) to learn more about the parameters you can use to control Chronumental.
### Integrations
[Taxonium](https://github.com/theosanderson/taxonium) can automatically call Chronumental, and generate a combined visualisation that allows switching between distance and time phylogenies
### Similar tools
[TreeTime](https://github.com/neherlab/treetime) is a more advanced tool for inferring time trees. If you have a dataset of e.g. <10,000 rather than millions of nodes you are definitely best off trying it. The TreeTime readme also links to other similar tools.
### Troubleshooting
- Chronumental uses the earliest date in your dataset as an anchor to calibrate everything else. If this earliest date is wrong due to a metadata error things won't work well, you can set the reference node manually with `--reference_node`
%package help
Summary: Development documents and examples for chronumental
Provides: python3-chronumental-doc
%description help
## Chronumental
***Chron**ologies from mon**umental** phylogenetic trees*
Chronumental is a tool for creating a "time-tree" (where distance on the tree represents time) from a phylogenetic divergence-tree (where distance on the tree reflects a number of genetic substitutions).
What sets Chronumental apart from most other tools is that it scales to extremely large trees, which can contain millions of nodes. Chronumental uses JAX to represent the task of computing a time tree in a differentiable graph for efficient calculation on a CPU or GPU.
#### [📝 Read the preprint](https://www.biorxiv.org/content/10.1101/2021.10.27.465994v1)
#### [📚 View the documentation](https://chronumental.readthedocs.io/en/latest/)
### Installation
#### Method 1: Using pipx (recommended for basic use - installs in its own isolated environment)
```
pip install --local pipx
pipx install chronumental
```
#### Method 2: In your python environment
```
pip install chronumental
```
#### Method 3: Bioconda
Chronumental is [now](https://github.com/bioconda/bioconda-recipes/pull/34410) available on bioconda
```
conda config --add channels bioconda
conda install chronumental
```
### Usage
This demo uses trees and metadata collated by the [UShER](https://github.com/yatisht/usher) [team](https://hgwdev.gi.ucsc.edu/~angie/UShER_SARS-CoV-2/).
```
wget https://hgwdev.gi.ucsc.edu/~angie/UShER_SARS-CoV-2/2021/10/06/public-2021-10-06.all.nwk.gz
wget https://hgwdev.gi.ucsc.edu/~angie/UShER_SARS-CoV-2/2021/10/06/public-2021-10-06.metadata.tsv.gz
chronumental --tree public-2021-10-06.all.nwk.gz --dates public-2021-10-06.metadata.tsv.gz --steps 100
```
📚 Please [visit our documentation page](https://chronumental.readthedocs.io/en/latest/) to learn more about the parameters you can use to control Chronumental.
### Integrations
[Taxonium](https://github.com/theosanderson/taxonium) can automatically call Chronumental, and generate a combined visualisation that allows switching between distance and time phylogenies
### Similar tools
[TreeTime](https://github.com/neherlab/treetime) is a more advanced tool for inferring time trees. If you have a dataset of e.g. <10,000 rather than millions of nodes you are definitely best off trying it. The TreeTime readme also links to other similar tools.
### Troubleshooting
- Chronumental uses the earliest date in your dataset as an anchor to calibrate everything else. If this earliest date is wrong due to a metadata error things won't work well, you can set the reference node manually with `--reference_node`
%prep
%autosetup -n chronumental-0.0.60
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-chronumental -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.0.60-1
- Package Spec generated