%global _empty_manifest_terminate_build 0
Name: python-kmapper
Version: 2.0.1
Release: 1
Summary: Python implementation of Mapper algorithm for Topological Data Analysis.
License: MIT
URL: http://kepler-mapper.scikit-tda.org
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/72/7e/d3ff347d053fd60f13c42522e7264b8bc3003c3e389cf61745274447a0d1/kmapper-2.0.1.tar.gz
BuildArch: noarch
Requires: python3-scikit-learn
Requires: python3-numpy
Requires: python3-scipy
Requires: python3-Jinja2
Requires: python3-sktda-docs-config
Requires: python3-pandas
Requires: python3-sphinx-gallery
Requires: python3-networkx
Requires: python3-matplotlib
Requires: python3-igraph
Requires: python3-plotly
Requires: python3-ipywidgets
Requires: python3-pytest
Requires: python3-networkx
Requires: python3-matplotlib
Requires: python3-igraph
Requires: python3-plotly
Requires: python3-ipywidgets
%description
[](https://badge.fury.io/py/kmapper)
[](https://pypi.python.org/pypi/kmapper/)
[](https://travis-ci.org/scikit-tda/kepler-mapper)
[](https://codecov.io/gh/scikit-tda/kepler-mapper)
[](https://doi.org/10.21105/joss.01315)
[](https://doi.org/10.5281/zenodo.1002377)
# KeplerMapper
> Nature uses as little as possible of anything. - Johannes Kepler
This is a Python implementation of the TDA Mapper algorithm for visualization of high-dimensional data. For complete documentation, see [https://kepler-mapper.scikit-tda.org](https://kepler-mapper.scikit-tda.org).
KeplerMapper employs approaches based on the Mapper algorithm (Singh et al.) as first described in the paper "Topological Methods for the Analysis of High Dimensional Data Sets and 3D Object Recognition".
KeplerMapper can make use of Scikit-Learn API compatible cluster and scaling algorithms.
## Install
### Dependencies
KeplerMapper requires:
- Python (>= 3.6)
- NumPy
- Scikit-learn
Using the plotly visualizations requires a few extra libraries:
- Python-Igraph
- Plotly
- Ipywidgets
Additionally, running some of the examples requires:
- matplotlib
- umap-learn
### Installation
Install KeplerMapper with pip:
```
pip install kmapper
```
To install from source:
```
git clone https://github.com/MLWave/kepler-mapper
cd kepler-mapper
pip install -e .
```
## Usage
KeplerMapper adopts the scikit-learn API as much as possible, so it should feel very familiar to anyone who has used these libraries.
### Python code
```python
# Import the class
import kmapper as km
# Some sample data
from sklearn import datasets
data, labels = datasets.make_circles(n_samples=5000, noise=0.03, factor=0.3)
# Initialize
mapper = km.KeplerMapper(verbose=1)
# Fit to and transform the data
projected_data = mapper.fit_transform(data, projection=[0,1]) # X-Y axis
# Create dictionary called 'graph' with nodes, edges and meta-information
graph = mapper.map(projected_data, data, cover=km.Cover(n_cubes=10))
# Visualize it
mapper.visualize(graph, path_html="make_circles_keplermapper_output.html",
title="make_circles(n_samples=5000, noise=0.03, factor=0.3)")
```
## Disclaimer
Standard MIT disclaimer applies, see `DISCLAIMER.md` for full text. Development status is Alpha.
## How to cite
To credit KeplerMapper in your work: https://kepler-mapper.scikit-tda.org/en/latest/#citations
%package -n python3-kmapper
Summary: Python implementation of Mapper algorithm for Topological Data Analysis.
Provides: python-kmapper
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-kmapper
[](https://badge.fury.io/py/kmapper)
[](https://pypi.python.org/pypi/kmapper/)
[](https://travis-ci.org/scikit-tda/kepler-mapper)
[](https://codecov.io/gh/scikit-tda/kepler-mapper)
[](https://doi.org/10.21105/joss.01315)
[](https://doi.org/10.5281/zenodo.1002377)
# KeplerMapper
> Nature uses as little as possible of anything. - Johannes Kepler
This is a Python implementation of the TDA Mapper algorithm for visualization of high-dimensional data. For complete documentation, see [https://kepler-mapper.scikit-tda.org](https://kepler-mapper.scikit-tda.org).
KeplerMapper employs approaches based on the Mapper algorithm (Singh et al.) as first described in the paper "Topological Methods for the Analysis of High Dimensional Data Sets and 3D Object Recognition".
KeplerMapper can make use of Scikit-Learn API compatible cluster and scaling algorithms.
## Install
### Dependencies
KeplerMapper requires:
- Python (>= 3.6)
- NumPy
- Scikit-learn
Using the plotly visualizations requires a few extra libraries:
- Python-Igraph
- Plotly
- Ipywidgets
Additionally, running some of the examples requires:
- matplotlib
- umap-learn
### Installation
Install KeplerMapper with pip:
```
pip install kmapper
```
To install from source:
```
git clone https://github.com/MLWave/kepler-mapper
cd kepler-mapper
pip install -e .
```
## Usage
KeplerMapper adopts the scikit-learn API as much as possible, so it should feel very familiar to anyone who has used these libraries.
### Python code
```python
# Import the class
import kmapper as km
# Some sample data
from sklearn import datasets
data, labels = datasets.make_circles(n_samples=5000, noise=0.03, factor=0.3)
# Initialize
mapper = km.KeplerMapper(verbose=1)
# Fit to and transform the data
projected_data = mapper.fit_transform(data, projection=[0,1]) # X-Y axis
# Create dictionary called 'graph' with nodes, edges and meta-information
graph = mapper.map(projected_data, data, cover=km.Cover(n_cubes=10))
# Visualize it
mapper.visualize(graph, path_html="make_circles_keplermapper_output.html",
title="make_circles(n_samples=5000, noise=0.03, factor=0.3)")
```
## Disclaimer
Standard MIT disclaimer applies, see `DISCLAIMER.md` for full text. Development status is Alpha.
## How to cite
To credit KeplerMapper in your work: https://kepler-mapper.scikit-tda.org/en/latest/#citations
%package help
Summary: Development documents and examples for kmapper
Provides: python3-kmapper-doc
%description help
[](https://badge.fury.io/py/kmapper)
[](https://pypi.python.org/pypi/kmapper/)
[](https://travis-ci.org/scikit-tda/kepler-mapper)
[](https://codecov.io/gh/scikit-tda/kepler-mapper)
[](https://doi.org/10.21105/joss.01315)
[](https://doi.org/10.5281/zenodo.1002377)
# KeplerMapper
> Nature uses as little as possible of anything. - Johannes Kepler
This is a Python implementation of the TDA Mapper algorithm for visualization of high-dimensional data. For complete documentation, see [https://kepler-mapper.scikit-tda.org](https://kepler-mapper.scikit-tda.org).
KeplerMapper employs approaches based on the Mapper algorithm (Singh et al.) as first described in the paper "Topological Methods for the Analysis of High Dimensional Data Sets and 3D Object Recognition".
KeplerMapper can make use of Scikit-Learn API compatible cluster and scaling algorithms.
## Install
### Dependencies
KeplerMapper requires:
- Python (>= 3.6)
- NumPy
- Scikit-learn
Using the plotly visualizations requires a few extra libraries:
- Python-Igraph
- Plotly
- Ipywidgets
Additionally, running some of the examples requires:
- matplotlib
- umap-learn
### Installation
Install KeplerMapper with pip:
```
pip install kmapper
```
To install from source:
```
git clone https://github.com/MLWave/kepler-mapper
cd kepler-mapper
pip install -e .
```
## Usage
KeplerMapper adopts the scikit-learn API as much as possible, so it should feel very familiar to anyone who has used these libraries.
### Python code
```python
# Import the class
import kmapper as km
# Some sample data
from sklearn import datasets
data, labels = datasets.make_circles(n_samples=5000, noise=0.03, factor=0.3)
# Initialize
mapper = km.KeplerMapper(verbose=1)
# Fit to and transform the data
projected_data = mapper.fit_transform(data, projection=[0,1]) # X-Y axis
# Create dictionary called 'graph' with nodes, edges and meta-information
graph = mapper.map(projected_data, data, cover=km.Cover(n_cubes=10))
# Visualize it
mapper.visualize(graph, path_html="make_circles_keplermapper_output.html",
title="make_circles(n_samples=5000, noise=0.03, factor=0.3)")
```
## Disclaimer
Standard MIT disclaimer applies, see `DISCLAIMER.md` for full text. Development status is Alpha.
## How to cite
To credit KeplerMapper in your work: https://kepler-mapper.scikit-tda.org/en/latest/#citations
%prep
%autosetup -n kmapper-2.0.1
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-kmapper -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 2.0.1-1
- Package Spec generated