%global _empty_manifest_terminate_build 0
Name: python-lib-programname
Version: 2.0.5
Release: 1
Summary: get reliably the name of the executed script
License: MIT License
URL: https://github.com/bitranox/lib_programname
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/49/c6/5332b5c2cd1f2648e6a0c3ebef3290b630846da2fd2cadfdbd06a6b72d4e/lib_programname-2.0.5.tar.gz
BuildArch: noarch
Requires: python3-click
Requires: python3-cli-exit-tools
Requires: python3-lib-detect-testenv
%description
Version v2.0.5 as of 2022-06-02 see `Changelog`_
|build_badge| |license| |jupyter| |pypi| |pypi-downloads| |black|
|codecov| |better_code| |cc_maintain| |cc_issues| |cc_coverage| |snyk|
Finding the name of the program from which a Python module is running can be trickier than it would seem at first, so lets make it damned easy.
This works under pycharm, pytest, pytest-docrunner, uwsgi, dreampie etc. correctly.
You might dive into Dough Hellmans `article `_
about that issue.
$> python -m pip install lib_programname
$> python
>>> import lib_programname
%package -n python3-lib-programname
Summary: get reliably the name of the executed script
Provides: python-lib-programname
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-lib-programname
Version v2.0.5 as of 2022-06-02 see `Changelog`_
|build_badge| |license| |jupyter| |pypi| |pypi-downloads| |black|
|codecov| |better_code| |cc_maintain| |cc_issues| |cc_coverage| |snyk|
Finding the name of the program from which a Python module is running can be trickier than it would seem at first, so lets make it damned easy.
This works under pycharm, pytest, pytest-docrunner, uwsgi, dreampie etc. correctly.
You might dive into Dough Hellmans `article `_
about that issue.
$> python -m pip install lib_programname
$> python
>>> import lib_programname
%package help
Summary: Development documents and examples for lib-programname
Provides: python3-lib-programname-doc
%description help
Version v2.0.5 as of 2022-06-02 see `Changelog`_
|build_badge| |license| |jupyter| |pypi| |pypi-downloads| |black|
|codecov| |better_code| |cc_maintain| |cc_issues| |cc_coverage| |snyk|
Finding the name of the program from which a Python module is running can be trickier than it would seem at first, so lets make it damned easy.
This works under pycharm, pytest, pytest-docrunner, uwsgi, dreampie etc. correctly.
You might dive into Dough Hellmans `article `_
about that issue.
$> python -m pip install lib_programname
$> python
>>> import lib_programname
%prep
%autosetup -n lib-programname-2.0.5
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-lib-programname -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 2.0.5-1
- Package Spec generated