%global _empty_manifest_terminate_build 0
Name:		python-PyPardotSF
Version:	0.1.0
Release:	1
Summary:	API wrapper for API v3 & v4 of Pardot marketing automation software.
License:	MIT License
URL:		https://github.com/anelendata/PyPardotSF
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/26/55/b39d4b4df6cdf3c7ca9b8ccbcaa33f2221aa3fd321b35ae877f15b6d78bd/PyPardotSF-0.1.0.tar.gz
BuildArch:	noarch

Requires:	python3-requests

%description
PyPardot was originally created by Josh Geller as a wrapper for Version 3 of the Pardot API.
I, Matt Needham, have edited PyPardot for compatibility with Version 4 of the Pardot API.
Version 4 accommodates multiple prospects with the same email address. If your Pardot org does not have this featured enabled, you must use version 3.
To determine if your Pardot org has this feature enabled, [check out this guide](http://developer.pardot.com/kb/api-version-4/).
PyPardot is an API wrapper for [Pardot](http://www.pardot.com/), written in Python.
Using it is simple:
```python
from pypardot.client import PardotAPI
p = PardotAPI(
  email='email@email.com',
  password='password',
  user_key='userkey'
)
p.authenticate()
# Create a new prospect
p.prospects.create(email='joe@company.com', first_name='Joe', last_name='Schmoe')
# Read data about our prospect
print(p.prospects.read_by_email(email='joe@company.com'))
```

%package -n python3-PyPardotSF
Summary:	API wrapper for API v3 & v4 of Pardot marketing automation software.
Provides:	python-PyPardotSF
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-PyPardotSF
PyPardot was originally created by Josh Geller as a wrapper for Version 3 of the Pardot API.
I, Matt Needham, have edited PyPardot for compatibility with Version 4 of the Pardot API.
Version 4 accommodates multiple prospects with the same email address. If your Pardot org does not have this featured enabled, you must use version 3.
To determine if your Pardot org has this feature enabled, [check out this guide](http://developer.pardot.com/kb/api-version-4/).
PyPardot is an API wrapper for [Pardot](http://www.pardot.com/), written in Python.
Using it is simple:
```python
from pypardot.client import PardotAPI
p = PardotAPI(
  email='email@email.com',
  password='password',
  user_key='userkey'
)
p.authenticate()
# Create a new prospect
p.prospects.create(email='joe@company.com', first_name='Joe', last_name='Schmoe')
# Read data about our prospect
print(p.prospects.read_by_email(email='joe@company.com'))
```

%package help
Summary:	Development documents and examples for PyPardotSF
Provides:	python3-PyPardotSF-doc
%description help
PyPardot was originally created by Josh Geller as a wrapper for Version 3 of the Pardot API.
I, Matt Needham, have edited PyPardot for compatibility with Version 4 of the Pardot API.
Version 4 accommodates multiple prospects with the same email address. If your Pardot org does not have this featured enabled, you must use version 3.
To determine if your Pardot org has this feature enabled, [check out this guide](http://developer.pardot.com/kb/api-version-4/).
PyPardot is an API wrapper for [Pardot](http://www.pardot.com/), written in Python.
Using it is simple:
```python
from pypardot.client import PardotAPI
p = PardotAPI(
  email='email@email.com',
  password='password',
  user_key='userkey'
)
p.authenticate()
# Create a new prospect
p.prospects.create(email='joe@company.com', first_name='Joe', last_name='Schmoe')
# Read data about our prospect
print(p.prospects.read_by_email(email='joe@company.com'))
```

%prep
%autosetup -n PyPardotSF-0.1.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-PyPardotSF -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.0-1
- Package Spec generated