%global _empty_manifest_terminate_build 0
Name: python-Sunback
Version: 0.1.4
Release: 1
Summary: Sets your desktop background to the most recent images of the Sun.
License: BSD-3-Clause
URL: https://github.com/GillySpace27/sunback
Source0: https://mirrors.nju.edu.cn/pypi/web/packages/65/5d/16092b471f33c001442bea98b0cdcfd9776e443dfca344150610db21251a/Sunback-0.1.4.tar.gz
BuildArch: noarch
Requires: python3-boto3
Requires: python3-matplotlib
Requires: python3-twine
Requires: python3-pillow
Requires: python3-moviepy
Requires: python3-pippi
Requires: python3-parfive
Requires: python3-playsound
Requires: python3-opencv-python
Requires: python3-numba
Requires: python3-appscript
%description
[//]: # (Badges)









A program that downloads the most current images of the sun from the SDO satellite, then normalizes them. Then it sets each of the images to the desktop background in series.
Basic Usage:
pip install sunback
python3
import sunback as sb
sb.run(delay=20)
Check contribute.md to see how you can help out!
### Copyright
Copyright (c) 2019, [Chris R. Gilly](https://gilly.space) [ORCiD](https://orcid.org/0000-0003-0021-9056)
#### Acknowledgements
Project based on the
[Computational Molecular Science Python Cookiecutter](https://github.com/molssi/cookiecutter-cms) version 1.1.
%package -n python3-Sunback
Summary: Sets your desktop background to the most recent images of the Sun.
Provides: python-Sunback
BuildRequires: python3-devel
BuildRequires: python3-setuptools
BuildRequires: python3-pip
%description -n python3-Sunback
[//]: # (Badges)









A program that downloads the most current images of the sun from the SDO satellite, then normalizes them. Then it sets each of the images to the desktop background in series.
Basic Usage:
pip install sunback
python3
import sunback as sb
sb.run(delay=20)
Check contribute.md to see how you can help out!
### Copyright
Copyright (c) 2019, [Chris R. Gilly](https://gilly.space) [ORCiD](https://orcid.org/0000-0003-0021-9056)
#### Acknowledgements
Project based on the
[Computational Molecular Science Python Cookiecutter](https://github.com/molssi/cookiecutter-cms) version 1.1.
%package help
Summary: Development documents and examples for Sunback
Provides: python3-Sunback-doc
%description help
[//]: # (Badges)









A program that downloads the most current images of the sun from the SDO satellite, then normalizes them. Then it sets each of the images to the desktop background in series.
Basic Usage:
pip install sunback
python3
import sunback as sb
sb.run(delay=20)
Check contribute.md to see how you can help out!
### Copyright
Copyright (c) 2019, [Chris R. Gilly](https://gilly.space) [ORCiD](https://orcid.org/0000-0003-0021-9056)
#### Acknowledgements
Project based on the
[Computational Molecular Science Python Cookiecutter](https://github.com/molssi/cookiecutter-cms) version 1.1.
%prep
%autosetup -n Sunback-0.1.4
%build
%py3_build
%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .
%files -n python3-Sunback -f filelist.lst
%dir %{python3_sitelib}/*
%files help -f doclist.lst
%{_docdir}/*
%changelog
* Fri May 05 2023 Python_Bot - 0.1.4-1
- Package Spec generated