%global _empty_manifest_terminate_build 0
Name:		python-Mathics-Scanner
Version:	1.3.0
Release:	1
Summary:	Character Tables and Tokenizer for Mathics and the Wolfram Language.
License:	GPL-3.0-only
URL:		https://mathics.org/
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/bd/2d/ceb5d263a73bc1009580489d5d80d5f8ed0cb9d86fb2a1f52d2ed8e00c45/Mathics_Scanner-1.3.0.tar.gz
BuildArch:	noarch

Requires:	python3-chardet
Requires:	python3-PyYAML
Requires:	python3-click
Requires:	python3-pytest
Requires:	python3-ujson

%description
This repository really contains two things:
* extensive tables describing WL symbols and operators their properties
* a tokenizer or scanner portion for the Wolfram Language.
With respect to the first item, there is a commented YAML that contains a
full set of translation between:
* Wolfram Language named characters,
* Unicode/ASCII equivalents and Unicode and WL code-points,
* AMSLaTeX equivalent names,
* Operator name (if symbol is an operator),
* Operator precedence (if an operator)
* Keyboard escape sequences for the symbol

%package -n python3-Mathics-Scanner
Summary:	Character Tables and Tokenizer for Mathics and the Wolfram Language.
Provides:	python-Mathics-Scanner
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-Mathics-Scanner
This repository really contains two things:
* extensive tables describing WL symbols and operators their properties
* a tokenizer or scanner portion for the Wolfram Language.
With respect to the first item, there is a commented YAML that contains a
full set of translation between:
* Wolfram Language named characters,
* Unicode/ASCII equivalents and Unicode and WL code-points,
* AMSLaTeX equivalent names,
* Operator name (if symbol is an operator),
* Operator precedence (if an operator)
* Keyboard escape sequences for the symbol

%package help
Summary:	Development documents and examples for Mathics-Scanner
Provides:	python3-Mathics-Scanner-doc
%description help
This repository really contains two things:
* extensive tables describing WL symbols and operators their properties
* a tokenizer or scanner portion for the Wolfram Language.
With respect to the first item, there is a commented YAML that contains a
full set of translation between:
* Wolfram Language named characters,
* Unicode/ASCII equivalents and Unicode and WL code-points,
* AMSLaTeX equivalent names,
* Operator name (if symbol is an operator),
* Operator precedence (if an operator)
* Keyboard escape sequences for the symbol

%prep
%autosetup -n Mathics-Scanner-1.3.0

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-Mathics-Scanner -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.0-1
- Package Spec generated