%global _empty_manifest_terminate_build 0 Name: python-ibl Version: 0.0.6 Release: 1 Summary: Python api wrapper for infinity bot list License: MIT URL: https://ibl.gitbook.io/ibl/ Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ff/9f/946c1c6897e1788e6acf383115cd82e8679b66d187cc65eea215aa6d047e/ibl-0.0.6.tar.gz BuildArch: noarch Requires: python3-aiohttp %description # IBL #### Python API Wrapper for https://infinitybots.xyz # POST BOT STATS ## await ibl.post_stats(bot_id, auth_token, servers, shards=0) ### Example: ```py import discord from discord.ext import tasks @tasks.loop(minutes=30) async def update_ibl(): await ibl.post_stats(bot.user.id, "auth_token", len(bot.guilds)) ``` # GET USER INFO ## await ibl.user_info(id) ### Returns: user.username - String user.about - String user.certified_dev - BOOL user.staff - LIST/ARRAY user.developer - STRING user.error - BOOL # GET BOT INFO ## await ibl.bot_info(id) ### RETURNS bot.name
bot.certified
bot.tags
bot.prefix
bot.owner
bot.library
bot.short_desc
bot.long_desc
bot.premium
bot.nsfw
bot.servers
bot.shards
bot.votes
bot.invites
bot.website
bot.donate
bot.support
bot.banner
bot.staff
bot.error
%package -n python3-ibl Summary: Python api wrapper for infinity bot list Provides: python-ibl BuildRequires: python3-devel BuildRequires: python3-setuptools BuildRequires: python3-pip %description -n python3-ibl # IBL #### Python API Wrapper for https://infinitybots.xyz # POST BOT STATS ## await ibl.post_stats(bot_id, auth_token, servers, shards=0) ### Example: ```py import discord from discord.ext import tasks @tasks.loop(minutes=30) async def update_ibl(): await ibl.post_stats(bot.user.id, "auth_token", len(bot.guilds)) ``` # GET USER INFO ## await ibl.user_info(id) ### Returns: user.username - String user.about - String user.certified_dev - BOOL user.staff - LIST/ARRAY user.developer - STRING user.error - BOOL # GET BOT INFO ## await ibl.bot_info(id) ### RETURNS bot.name
bot.certified
bot.tags
bot.prefix
bot.owner
bot.library
bot.short_desc
bot.long_desc
bot.premium
bot.nsfw
bot.servers
bot.shards
bot.votes
bot.invites
bot.website
bot.donate
bot.support
bot.banner
bot.staff
bot.error
%package help Summary: Development documents and examples for ibl Provides: python3-ibl-doc %description help # IBL #### Python API Wrapper for https://infinitybots.xyz # POST BOT STATS ## await ibl.post_stats(bot_id, auth_token, servers, shards=0) ### Example: ```py import discord from discord.ext import tasks @tasks.loop(minutes=30) async def update_ibl(): await ibl.post_stats(bot.user.id, "auth_token", len(bot.guilds)) ``` # GET USER INFO ## await ibl.user_info(id) ### Returns: user.username - String user.about - String user.certified_dev - BOOL user.staff - LIST/ARRAY user.developer - STRING user.error - BOOL # GET BOT INFO ## await ibl.bot_info(id) ### RETURNS bot.name
bot.certified
bot.tags
bot.prefix
bot.owner
bot.library
bot.short_desc
bot.long_desc
bot.premium
bot.nsfw
bot.servers
bot.shards
bot.votes
bot.invites
bot.website
bot.donate
bot.support
bot.banner
bot.staff
bot.error
%prep %autosetup -n ibl-0.0.6 %build %py3_build %install %py3_install install -d -m755 %{buildroot}/%{_pkgdocdir} if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi pushd %{buildroot} if [ -d usr/lib ]; then find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/lib64 ]; then find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/bin ]; then find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst fi if [ -d usr/sbin ]; then find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst fi touch doclist.lst if [ -d usr/share/man ]; then find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst fi popd mv %{buildroot}/filelist.lst . mv %{buildroot}/doclist.lst . %files -n python3-ibl -f filelist.lst %dir %{python3_sitelib}/* %files help -f doclist.lst %{_docdir}/* %changelog * Fri May 05 2023 Python_Bot - 0.0.6-1 - Package Spec generated