%global _empty_manifest_terminate_build 0
Name:		python-sportsreference
Version:	0.5.2
Release:	1
Summary:	A free sports API written for python
License:	MIT
URL:		https://github.com/roclark/sportsreference
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/65/17/6e96bd49451ddd77a03ddc7c2565fad4d26dde612270850564407aed94ac/sportsreference-0.5.2.tar.gz
BuildArch:	noarch

Requires:	python3-pandas
Requires:	python3-pyquery
Requires:	python3-requests

%description
The easiest way to install `sportsreference` is by downloading the latest
released binary from PyPI using PIP. For instructions on installing PIP, visit
`PyPA.io <https://pip.pypa.io/en/stable/installing/>`_ for detailed steps on
installing the package manager for your local environment.
Next, run::
    pip install sportsreference
to download and install the latest official release of `sportsreference` on
your machine. You now have the latest stable version of `sportsreference`
installed and can begin using it following the examples below!
If the bleeding-edge version of `sportsreference` is desired, clone this
repository using git and install all of the package requirements with PIP::
    git clone https://github.com/roclark/sportsreference
    cd sportsreference
    pip install -r requirements.txt
Once complete, create a Python wheel for your default version of Python by
running the following command::
    python setup.py sdist bdist_wheel
This will create a `.whl` file in the `dist` directory which can be installed
with the following command::
    pip install dist/*.whl

%package -n python3-sportsreference
Summary:	A free sports API written for python
Provides:	python-sportsreference
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-sportsreference
The easiest way to install `sportsreference` is by downloading the latest
released binary from PyPI using PIP. For instructions on installing PIP, visit
`PyPA.io <https://pip.pypa.io/en/stable/installing/>`_ for detailed steps on
installing the package manager for your local environment.
Next, run::
    pip install sportsreference
to download and install the latest official release of `sportsreference` on
your machine. You now have the latest stable version of `sportsreference`
installed and can begin using it following the examples below!
If the bleeding-edge version of `sportsreference` is desired, clone this
repository using git and install all of the package requirements with PIP::
    git clone https://github.com/roclark/sportsreference
    cd sportsreference
    pip install -r requirements.txt
Once complete, create a Python wheel for your default version of Python by
running the following command::
    python setup.py sdist bdist_wheel
This will create a `.whl` file in the `dist` directory which can be installed
with the following command::
    pip install dist/*.whl

%package help
Summary:	Development documents and examples for sportsreference
Provides:	python3-sportsreference-doc
%description help
The easiest way to install `sportsreference` is by downloading the latest
released binary from PyPI using PIP. For instructions on installing PIP, visit
`PyPA.io <https://pip.pypa.io/en/stable/installing/>`_ for detailed steps on
installing the package manager for your local environment.
Next, run::
    pip install sportsreference
to download and install the latest official release of `sportsreference` on
your machine. You now have the latest stable version of `sportsreference`
installed and can begin using it following the examples below!
If the bleeding-edge version of `sportsreference` is desired, clone this
repository using git and install all of the package requirements with PIP::
    git clone https://github.com/roclark/sportsreference
    cd sportsreference
    pip install -r requirements.txt
Once complete, create a Python wheel for your default version of Python by
running the following command::
    python setup.py sdist bdist_wheel
This will create a `.whl` file in the `dist` directory which can be installed
with the following command::
    pip install dist/*.whl

%prep
%autosetup -n sportsreference-0.5.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-sportsreference -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.2-1
- Package Spec generated