%global _empty_manifest_terminate_build 0
Name:		python-ruamel.yaml.convert
Version:	0.3.2
Release:	1
Summary:	data format conversion routines to/from YAML
License:	MIT license
URL:		https://bitbucket.org/ruamel/yaml.convert
Source0:	https://mirrors.nju.edu.cn/pypi/web/packages/14/21/d7bac6201ea527b64529943d41bbf6b3c2657cdfbc8acfc69ac951fabea4/ruamel.yaml.convert-0.3.2.tar.gz
BuildArch:	noarch


%description
The conversion process from other formats requires additional packages.
These are not installed by default. To install all packages do::
    pip install ruamel.yaml.convert[all]
Instead of ``all`` you can provide ``html``, ``csv``, to install
only the dependencies needed for those formats.

%package -n python3-ruamel.yaml.convert
Summary:	data format conversion routines to/from YAML
Provides:	python-ruamel.yaml.convert
BuildRequires:	python3-devel
BuildRequires:	python3-setuptools
BuildRequires:	python3-pip
%description -n python3-ruamel.yaml.convert
The conversion process from other formats requires additional packages.
These are not installed by default. To install all packages do::
    pip install ruamel.yaml.convert[all]
Instead of ``all`` you can provide ``html``, ``csv``, to install
only the dependencies needed for those formats.

%package help
Summary:	Development documents and examples for ruamel.yaml.convert
Provides:	python3-ruamel.yaml.convert-doc
%description help
The conversion process from other formats requires additional packages.
These are not installed by default. To install all packages do::
    pip install ruamel.yaml.convert[all]
Instead of ``all`` you can provide ``html``, ``csv``, to install
only the dependencies needed for those formats.

%prep
%autosetup -n ruamel.yaml.convert-0.3.2

%build
%py3_build

%install
%py3_install
install -d -m755 %{buildroot}/%{_pkgdocdir}
if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
pushd %{buildroot}
if [ -d usr/lib ]; then
	find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/lib64 ]; then
	find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/bin ]; then
	find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
fi
if [ -d usr/sbin ]; then
	find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
fi
touch doclist.lst
if [ -d usr/share/man ]; then
	find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
fi
popd
mv %{buildroot}/filelist.lst .
mv %{buildroot}/doclist.lst .

%files -n python3-ruamel.yaml.convert -f filelist.lst
%dir %{python3_sitelib}/*

%files help -f doclist.lst
%{_docdir}/*

%changelog
* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.2-1
- Package Spec generated